Login  •  Register


The time is now: Sun Dec 16, 2018 10:21 am

Emaculation wiki  •  Delete all board cookies



Post new topic  Reply to topic Page 1 of 1 [ 5 posts ]
Print view Previous topic  |  Next topic
Author Message
PostPosted: Sun Feb 18, 2018 1:21 pm 
Offline
Space Cadet

Joined: Sun Feb 18, 2018 1:13 pm
Posts: 3
Hello, I'm new to the forums...
I'm looking for a version of sheepshaver
SheepShaver UB 2009-07-26.zip
I'm looking for it because sheepshaver otherwise crashes and I've had the best luck with this version, if the latest version is supposed to work on 1.6GHz PowerPC G5 Leopard machines I would like to diagnose why it does not if someone doesn't have the sheepshaver version I requested. Thank you for your time :)
EDIT: Running the 2014 build in terminal displays that it cannot read the rom file, Have I not named it correctly by naming it "MACOS.ROM"?


Last edited by PowerBrickg5 on Sun Feb 18, 2018 1:49 pm, edited 1 time in total.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Sun Feb 18, 2018 1:45 pm 
Offline
Expert User
User avatar

Joined: Thu Feb 09, 2006 10:24 pm
Posts: 5199
Location: Amsterdam, Netherlands
In the Sheeshaver for OSX download topic you can find the 25 October 2009 build that should run fine on a PPC machine. Scroll down to the "Known Issues" section.
viewtopic.php?f=20&t=7360


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Sun Feb 18, 2018 1:48 pm 
Offline
Space Cadet

Joined: Sun Feb 18, 2018 1:13 pm
Posts: 3
Thank you for the version, However I'm also curious as to why the 2014 build cannot locate the rom file, I get this in terminal for both the 2009 and 2014 version:
Power-mac-g5:sheepshaver2014 leeder$ /users/leeder/desktop/sheepshaver2014/Sheepshaver.app/Contents/MacOS/SheepShaver
SheepShaver V2.4 by Christian Bauer and Mar"c" Hellwig
Paranoia checks...
[tick_thread] waiting for emul thread to initialize
[emul_thread] waiting for tick thread to initialize
[emul_thread] filling in registers and waiting for interrupt
[tick_thread] trigger interrupt
SIGUSR2 caught
...passed
ERROR: Cannot open ROM file.
I've named the rom file "MACOS.ROM" is this not correct?


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Sun Feb 18, 2018 2:00 pm 
Offline
Expert User
User avatar

Joined: Thu Feb 09, 2006 10:24 pm
Posts: 5199
Location: Amsterdam, Netherlands
That can have different reasons:
- The path to the ROM file in prefs is not correct
- If no path is yet configured, the ROM file needs to be in the same folder as the SheepShaver application and needs to be named "Mac OS ROM", without a file name extension. (The exact name and possible hidden extension can be checked in Finder Info for the file.)
- The file is not a compatible ROM file.

"MACOS.ROM" is indeed not correct.


Last edited by Ronald P. Regensburg on Sun Feb 18, 2018 2:02 pm, edited 2 times in total.
 


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Sun Feb 18, 2018 2:14 pm 
Offline
Space Cadet

Joined: Sun Feb 18, 2018 1:13 pm
Posts: 3
So I've found the tutorial, now the problem is I have to force quit after it freezes and it won't save settings, do I need the preferences editor?
EDIT:After Modifying settings, I've encountered a problem, when using a new world rom both crash, I'm using select roms from redundant robot however none seem to work with both the 2009 and 2014 version of sheepshaver.
SheepShaver V2.4 by Christian Bauer and Mar"c" Hellwig
Paranoia checks...
[tick_thread] waiting for emul thread to initialize
[emul_thread] waiting for tick thread to initialize
[emul_thread] filling in registers and waiting for interrupt
[tick_thread] trigger interrupt
SIGUSR2 caught
...passed
Reading ROM file...
Using SDL/coreaudio audio output
WARNING: Cannot open /dev/sheep_net (No such file or directory). Ethernet will not be available.
ERROR: Unsupported ROM type.
This is what I get in both versions (from now on I'm sticking with the 2014 version as everything done in the 2009 version outputs the same error in the 2014 version) what could I be doing wrong?
EDIT 2:After Re downloading the New World rom I've managed to boot successfully! Thank you for your help


Top
 Profile  
Reply with quote Post a reply  
Display posts from previous:  Sort by  
Post new topic  Reply to topic Page 1 of 1 [ 5 posts ]


Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
 

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group