Switch to full style
About SheepShaver, a PPC Mac emulator for Windows, MacOSX, and Linux that can run System 7.5.3 through MacOS 9.0.4.
Post a reply

ROM image from previous installation

Fri May 11, 2018 4:03 am

Dear helpful sheepshaver community,

I have been running sheepshaver for many old versions of macs, quite happily. Now I got a new Mac PowerBook with OS High Sierra. The migration of the previous sheepshaver did not work, so I downloaded a fresh copy and installed it. The problem is that is "quits upon launch" as indicated if no ROM is recognized (without telling me that this is the exact problem). I simply copied all ROM files from the previous sheepshaver installation, hoping this would work. I also copied the newly downloaded version of the sheepshaver application to the old location and started it there, and had the same problem.

What's wrong, and what do I need to do to fix it? Should it not be a standard problem with a standard solution? (I couldn't find any appropriate advice though on this forum.)

Thanks a lot!


PS.: For copyright reassurance: I have owned Macs continuously since the times of OS 7, so own(ed) legal files and am not trying to circumvent purchasing a legal version of OS9 (but may no longer own the actual CDs of those days).

Re: ROM image from previous installation

Fri May 11, 2018 7:16 am


You might be stumbling on a High Sierra specific issue here.
Copy the SheepShaver application to your desktop, then remove the old one from your folder and copy the one from your desktop into your folder.
Make sure you have your old working rom in your folder and that it is named "Mac OS Rom" (no qoutes, no extension)
Then try to start SheepShaver from your folder. If it runs, remove the one from your desktop.


Re: ROM image from previous installation

Fri May 11, 2018 1:58 pm

Dear Cat_7,

thanks a lot for your quick reply. I had tried out your "copy the application file" trick before, and it might have done its magic. Meanwhile, I resolved the issue, and it was what you mentioned in passing: the rom file must not have an extension. I had copied it from the previous installation, where it had a .rom extension, and once I deleted that it worked fine. (It forgot all preferences though.)

A bit surprising that a previously running system does not simply run by migrating, or at least by copying, but at least it's working now.



Re: ROM image from previous installation

Fri May 11, 2018 5:06 pm

The reason it didn't simply run is that it depends on an invisible preference file in your Users folder. If your username changed or you failed to copy the invisible preferences file, the configuration would not load correctly.

For this reason, I avoid using that prefs file altogether and store all my guest configuration in .sheepvm bundles. Using this method, I've never had an issue moving between computers.
Post a reply