E-Maculation
https://www.emaculation.com/forum/

SheepShaver crashes when JIT Compiler is enabled
https://www.emaculation.com/forum/viewtopic.php?f=20&t=9869
Page 1 of 1

Author:  Bajiru [ Sat Sep 29, 2018 4:25 pm ]
Post subject:  SheepShaver crashes when JIT Compiler is enabled

I downloaded SheepShaver for Windows (the May 2010 build), found an OS 9 image (redundantrobot), and started it.

It ran at a great speed. However, it crashed after the Mac OS 9 Loading screen. No report showed.

If I turn off JIT it works, however, it is as slow as molasses.

However, after enabling 'Ignore Illegal Memory Access' in the settings, I had a report.

This is what it said:

Code:
  Problem event name:   APPCRASH
  Application name:   SheepShaver.exe
  Application version:   0.0.0.0
  Application timestamp:   4be119af
  Faulty module name:   StackHash_0a9e
  Faulty module version:   0.0.0.0
  Faulty module timestamp:   00000000
  Exception code:   c0000005
  Exception displacement:   05eb72ea
  Operating system version :   6.1.7601.2.1.0.768.11
  Local settings identifier:   1032
  Additional information 1:   0a9e
  Additional information 2:   0a9e372d3b4ad19135b953a78882e789
  Additional information 3:   0a9e
  Additional information 4:   0a9e372d3b4ad19135b953a78882e789



(The report is translated from Greek, so it might not be correctly translated.)

My system is:

Code:
Dell OptiPlex GX270
Windows 7 Starter Service Pack 1
Intel Pentium 4 Northwood @ 2.40 GHz (No VT/AM-x, but I can run virtualization software)
1024 MB RAM


The exact same thing also happens on another Windows 10 laptop that I have, and that system features VT/AM-x & NX bit. Again, with JIT disabled, it works, but this time with an acceptable speed because of the newer and faster processor.

Any suggestions as to why it crashes?

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/