Login  •  Register


The time is now: Sun Nov 18, 2018 3:48 am

Emaculation wiki  •  Delete all board cookies



Post new topic  Reply to topic Page 1 of 1 [ 16 posts ]
Print view Previous topic  |  Next topic
Author Message
PostPosted: Sun Nov 04, 2018 1:30 pm 
Offline
Space Cadet

Joined: Sun Nov 05, 2017 9:02 am
Posts: 6
Bonjour,
J'utilise SheepShaver depuis des années sans le moindre problème et depuis la mise à jour en version 2.5 mon clavier est passé en QWERTY au lieu de l'AZERTY !
Pour faire la mise à jour, j'ai juste remplacé l'application SheepShaver comme les autres fois.

- J'ai bien le fichier keycodes avec son chemin d'accès renseigné.
- Le clavier de mon Mac sous High Sierra fonctionne correctement. ( Français - AZERTY)
- Les préférences du clavier dans SheepShaver sont bien sur Français.

Si je remet la version 2.4 de SheepShaver, mon clavier fonctionne bien en AZERTY.
Quelqu'un peut-il m'aider à retrouver mon clavier AZERTY avec la version 2.5 ?

Merci ;)

---------------------------------

Hello,
I use SheepShaver for years without any problem and since the update in version 2.5 my keyboard has been changed to QWERTY instead of AZERTY!
To update, I just replaced the SheepShaver app like other times.

- I have the file keycodes with its path filled.
- The keyboard of my Mac under High Sierra is working properly. (French - AZERTY)
- The keyboard preferences in SheepShaver are of course French.

If I release the 2.4 version of SheepShaver, my keyboard works well in AZERTY.
Can someone help me find my AZERTY keyboard with version 2.5?

Thank you ;)

_________________
Sorry for my English, I use Google translation.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Sun Nov 04, 2018 3:47 pm 
Offline
Expert User
User avatar

Joined: Thu Feb 09, 2006 10:24 pm
Posts: 5185
Location: Amsterdam, Netherlands
I tried it and this is indeed a bug in this version.

If you choose in the High Sierra host System Preferences a QWERTY keyboard (like US English), the guest MacOS can use the AZERTY keyboard. But this is, of course, not how it should be.

I will try to find where in the source development this problem was introduced.

Edit: You can use the 2.4 version, the 9 July 2018 build, for now.


Last edited by Ronald P. Regensburg on Sun Nov 04, 2018 3:50 pm, edited 1 time in total.
 


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Sun Nov 04, 2018 3:50 pm 
Offline
Space Cadet

Joined: Sun Nov 05, 2017 9:02 am
Posts: 6
OK
Many thanks :)

_________________
Sorry for my English, I use Google translation.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Sun Nov 04, 2018 7:27 pm 
Offline
Expert User
User avatar

Joined: Thu Feb 09, 2006 10:24 pm
Posts: 5185
Location: Amsterdam, Netherlands
The issue may be related to SDL2. The 2.5 version uses SDL2 and I think the existing keycodes file is not compatible with SDL2.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Mon Nov 05, 2018 12:48 am 
Offline
Forum All-Star

Joined: Tue Oct 14, 2008 12:12 am
Posts: 922
Ronald P. Regensburg wrote:
The issue may be related to SDL2. The 2.5 version uses SDL2 and I think the existing keycodes file is not compatible with SDL2.


kanjitalk755's latest code removes the keycodes from the resources. I have no idea what effect this has on a non-US keyboard.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Mon Nov 05, 2018 3:24 am 
Offline
Tinkerer

Joined: Thu Nov 09, 2017 12:06 pm
Posts: 53
Ronald P. Regensburg wrote:
The issue may be related to SDL2. The 2.5 version uses SDL2 and I think the existing keycodes file is not compatible with SDL2.

As I had previously posted, keycodes file is not compatible.

https://www.emaculation.com/forum/viewt ... 172#p60172

emendelson wrote:
kanjitalk755's latest code removes the keycodes from the resources. I have no idea what effect this has on a non-US keyboard.

It's BasiliskII.xcodeproj.
In previous version, there are two keycodes entry in "Copy Bundle Resources".
I had fixed it because Xcode10 reports it as error.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Mon Nov 05, 2018 11:21 am 
Offline
Expert User
User avatar

Joined: Thu Feb 09, 2006 10:24 pm
Posts: 5185
Location: Amsterdam, Netherlands
Yes, I remember it now.

I put a copy of the keycodes file from kanjitalk755 source here: https://ronaldpr.home.xs4all.nl/sheepsh ... m/keycodes
The "sdl Quartz"(SDL1)" entry was duplicated by kanjitalk755 to "sdl cocoa"(SDL2)" but that does not work because keymaps differ between SDL1 and SDL2.

Hopefully someone here is able to edit the keycodes for "sdl cocoa"(SDL2)" correctly.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Mon Nov 05, 2018 12:25 pm 
Offline
Expert User
User avatar

Joined: Thu Feb 09, 2006 10:24 pm
Posts: 5185
Location: Amsterdam, Netherlands
OK, I found some tables. I will try to edit the keycodes file and translate SDL2 scancodes to Mac keycodes.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Mon Nov 05, 2018 3:58 pm 
Offline
Expert User
User avatar

Joined: Thu Feb 09, 2006 10:24 pm
Posts: 5185
Location: Amsterdam, Netherlands
This new keycodes file should work with SheepShaver version 2.5 with other than US QWERTY keyboards.

Simply replace the existing file with the new one.

Please report when keys do not work correctly.

http://ronaldpr.home.xs4all.nl/sheepsha ... ycodes.zip


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Mon Nov 05, 2018 5:46 pm 
Offline
Space Cadet

Joined: Sun Nov 05, 2017 9:02 am
Posts: 6
Merci beaucoup d’avoir corrigé ce problème aussi rapidement. :)
J'ai retrouvé l'usage de mon clavier AZERTY dans SheepShaver 2.5.

A+++ ;)

----------------

Thank you very much for correcting this problem so quickly. :)
I found the use of my AZERTY keyboard in SheepShaver 2.5.

A +++;)

_________________
Sorry for my English, I use Google translation.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Mon Nov 05, 2018 6:16 pm 
Offline
Forum All-Star

Joined: Wed Nov 11, 2009 5:47 pm
Posts: 1156
Location: Germany
Thanks a bunch from my side too Ronald.
I´m getting unexpected characters with a German keyboard in SheepShaver from Alt + l.
Should be "@" but is "¬" , not sure whether @ was assigned correctly before, though.
I´m not sending mails from SheepShaver.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Mon Nov 05, 2018 8:06 pm 
Offline
Expert User
User avatar

Joined: Thu Feb 09, 2006 10:24 pm
Posts: 5185
Location: Amsterdam, Netherlands
There is no separate entry for @ in the keycodes file because there is no separate key for @. It is always produced in a combination with a modifier key.

The missing @ on a German keyboard could be an issue in SheepShaver itself. The issue is in all SheepShaver versions I have available here, at least since 2009. The other characters that are produced with the Option key seem OK. Strange that all those years no one complained. I tested this in High Sierra. I do not know if the host OS plays a role here, although on the host the @ is where it should be on a German keyboard.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Mon Nov 05, 2018 8:36 pm 
Offline
Expert User
User avatar

Joined: Thu Feb 09, 2006 10:24 pm
Posts: 5185
Location: Amsterdam, Netherlands
Could the @ character on a German keyboard have been in a different place in Classic MacOS? It appears to be on option-shift-1.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Mon Nov 05, 2018 8:49 pm 
Offline
Forum All-Star

Joined: Wed Nov 11, 2009 5:47 pm
Posts: 1156
Location: Germany
Thanks Ronald!
That solved the riddle. I must have forgotten Alt-Shift-1 over time.
The key was not that popular in the pre web era either. :)


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Mon Nov 05, 2018 8:53 pm 
Offline
Forum All-Star
User avatar

Joined: Fri Nov 27, 2009 5:11 am
Posts: 2265
Location: Emaculation.com
On a US-International keyboard it's at shift-2; maybe the difference in mapping type between AZERTY and QWERTY is part of the problem here? "¬" is option-l or option-; I believe.

Here's what appears to be the physical key mapping on a Windows keyboard:

https://amdunet.files.wordpress.com/201 ... azerty.gif

And that places it at alt-shift-0.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Mon Nov 05, 2018 9:12 pm 
Offline
Expert User
User avatar

Joined: Thu Feb 09, 2006 10:24 pm
Posts: 5185
Location: Amsterdam, Netherlands
24bit wrote:
I must have forgotten Alt-Shift-1 over time.

Issue solved. It works as it should. Sometime around the transition from MacOS to MacOSX, on the German Mac keyboard the key combos for ¬ and @ where apparently exchanged, probably to make @ better accessible.

BTW: The German keyboard is not QWERTY, not AZERTY, but QWERTZ.


Last edited by Ronald P. Regensburg on Mon Nov 05, 2018 9:26 pm, edited 2 times in total.
 


Top
 Profile  
Reply with quote Post a reply  
Display posts from previous:  Sort by  
Post new topic  Reply to topic Page 1 of 1 [ 16 posts ]


Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
 

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group