Login  •  Register


The time is now: Wed Jun 19, 2019 1:41 pm

Emaculation wiki  •  Delete all board cookies



Post new topic  Reply to topic Page 1 of 1 [ 23 posts ]
Print view Previous topic  |  Next topic
Author Message
PostPosted: Wed Nov 14, 2018 9:50 pm 
Offline
Student Driver

Joined: Wed Nov 14, 2018 9:41 pm
Posts: 13
Hi,
I installed Sheepshaver on my Mac (Mojave 10.14.1). I only experience one (a bit annoying) problem:
When I click using my MBP trackpad or using my Magic Mouse 2, I always need to press the click button during a very small delay (something like 0.5 seconds or maybe a bit less) otherwise the click is not taken into account if too fast (like pressing and releasing just quickly then with no "perceptible" delay).
In other hands I have to make a kind of latency before each click release.

Could this problem be solved in the parameters of Sheepshaver for instance?

I thank you a lot in advance,
Best Regards,
Pierre


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Wed Nov 14, 2018 10:34 pm 
Offline
Forum All-Star
User avatar

Joined: Fri Nov 27, 2009 5:11 am
Posts: 2602
Location: Emaculation.com
I'm not having that issue on my 2015 MBP with force touch trackpad. Which version of SheepShaver are you using? Which OS are you running inside it? Are you using JIT?

This is most likely a config issue, not an emulator issue.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Wed Nov 14, 2018 10:38 pm 
Offline
Student Driver

Joined: Wed Nov 14, 2018 9:41 pm
Posts: 13
Thanks a lot for your answer.
I am using SheepShaver 2.5, with Mac OS 9.0.4 (installed from New Rom Intl if I well remember).
And I also use a 2015 MPB with force touch trackpad as well.

What is JIT? Looks like I don't use it.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Wed Nov 14, 2018 10:41 pm 
Offline
Student Driver

Joined: Wed Nov 14, 2018 9:41 pm
Posts: 13
I downloaded also the keycode file because I have a French keyboard.
I don't know if there are also some mouse-related parameters in that file?


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Wed Nov 14, 2018 10:46 pm 
Offline
Student Driver

Joined: Wed Nov 14, 2018 9:41 pm
Posts: 13
So I checked on internet what if JIT and checked in the parameters of SheepShaver.
JIT is ENABLED.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Wed Nov 14, 2018 11:05 pm 
Offline
Student Driver

Joined: Wed Nov 14, 2018 9:41 pm
Posts: 13
I just figured out one thing:
Looks like the right click is taken into account as left click, and with no delay on my Magic mouse. The same on the trackpad.

I am wondering if there is a way to enable left click with no delay?


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Wed Nov 14, 2018 11:23 pm 
Offline
Student Driver

Joined: Wed Nov 14, 2018 9:41 pm
Posts: 13
Ok I found the culprit.

On my Magic Mouse, it is not evident but left click is really on the left edge, right click on the right of course, and every place between will be considered as the scroll wheel in Sheep Shaver (maybe).

So every time I clicked it was recognised as a wheel click. Now I place my finder close to the left edge and everything is fine!

Thank you again for your help.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Wed Nov 14, 2018 11:28 pm 
Offline
Forum All-Star
User avatar

Joined: Fri Nov 27, 2009 5:11 am
Posts: 2602
Location: Emaculation.com
<erases paragraphs of suggested steps>

Glad you fixed it -- I was going to try and replicate your setup as my next step ;)


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Wed Nov 14, 2018 11:37 pm 
Offline
Student Driver

Joined: Wed Nov 14, 2018 9:41 pm
Posts: 13
Thank you.

After other tests it is not easy to get a proper left click from the left side of the magic mouse. Sometimes it works, sometimes it needs the delay.

But right edge is alway working well as a left click, with no delay.

This is ok but a bit annoying as you can imagine, my first think is pressing on the left and not on the right.

I am wondering if this could be solved in a next update of SheepShaver.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Wed Nov 14, 2018 11:47 pm 
Offline
Forum All-Star
User avatar

Joined: Fri Nov 27, 2009 5:11 am
Posts: 2602
Location: Emaculation.com
This is something that needs to be fixed in your mouse / mouse driver; SheepShaver's just taking the inputs it's getting, as it gets them.

Testing with my magic mouse shows I don't have this issue; you might want to change the settings on your mouse to adjust sensitivity and click area.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Wed Nov 14, 2018 11:53 pm 
Offline
Student Driver

Joined: Wed Nov 14, 2018 9:41 pm
Posts: 13
Do you have Magic Mouse 1 or 2?
If I remember well the first version has less sensitivity option than the 2nd one.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Wed Nov 14, 2018 11:55 pm 
Offline
Forum All-Star
User avatar

Joined: Fri Nov 27, 2009 5:11 am
Posts: 2602
Location: Emaculation.com
I've got the A1296 magic mouse; that's probably the first. But the sensitivity is adjustable in the mouse prefs.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Thu Nov 15, 2018 12:03 am 
Offline
Student Driver

Joined: Wed Nov 14, 2018 9:41 pm
Posts: 13
Thanks.
Changing the sensitivity didn't solve the issue.

Maybe the 2nd version, with more options leads to some confusing inputs for SheepShaver. I don't want to change every preferences of my Magic Mouse, I will consider buying another more 'standard' mouse when using Mac OS 9 ;-)


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Mon Nov 19, 2018 2:48 pm 
Offline
Tinkerer

Joined: Fri Nov 09, 2007 5:42 pm
Posts: 99
adespoton wrote:
I've got the A1296 magic mouse; that's probably the first. But the sensitivity is adjustable in the mouse prefs.


The first one has user replaceable batteries, the second one has a lightning connector at the bottom(!) to charge the mouse.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Mon Nov 19, 2018 4:14 pm 
Offline
Student Driver

Joined: Wed Nov 14, 2018 9:41 pm
Posts: 13
Right, the mine has the connector.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Sat Apr 13, 2019 7:29 pm 
Offline
Space Cadet

Joined: Sat Apr 13, 2019 7:23 pm
Posts: 2
I'm experiencing a very similar problem with the trackpad on my MacBook Pro. If I click normally, SheepShaver doesn't register the click. I must press down on the trackpad and linger for a while before lifting up, and then the click is registered normally.

I am running a fresh copy from here: http://www.columbia.edu/~em36/macos9osx.html

This is a 2016 15-inch MacBook Pro running Sierra (10.12.6).


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Wed Jun 05, 2019 6:46 pm 
Offline
Student Driver

Joined: Wed Nov 14, 2018 9:41 pm
Posts: 13
Do you know if the latest build from 2019 May solved this problem?


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Thu Jun 06, 2019 3:23 pm 
Offline
Space Cadet

Joined: Sat Apr 13, 2019 7:23 pm
Posts: 2
I downloaded the latest version, and indeed its creation date is May 21. The behavior seems unchanged.

The key to having a click register seems to be that the click need to be held down for a certain minimum amount of time to be recognized. I routinely click faster than that.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Thu Jun 06, 2019 3:49 pm 
Offline
Expert User
User avatar

Joined: Thu Feb 09, 2006 10:24 pm
Posts: 5420
Location: Amsterdam, Netherlands
I wonder how many experience this issue. It seems to occur with only trackpad or Magic Mouse 2. But even then, one would expect more users to report the issue.

I myself use the Magic Mouse 1, now in Mojave, and I never experienced this problem. Mouse clicks work in SheepShaver as they do in the host macOS. I use my right hand. I always have both my index finger and middle finger on the mouse, the index finger just left of the middle, the middle finger just right of the middle. A click with with both index finger and middle finger touching the mouse results in a left click and when I lift my index finger while clicking, I get a right-click. I don't need to click slowly nor do I need to introduce some kind of delay while clicking.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Thu Jun 06, 2019 4:03 pm 
Offline
Forum All-Star
User avatar

Joined: Fri Nov 27, 2009 5:11 am
Posts: 2602
Location: Emaculation.com
The only time I've experienced this issue was using a Magic Trackpad; using the force touch trackpad on multiple generations of MacBook(Pro) hasn't been a problem for me, and neither has using the Magic Mouse 1. I haven't had a Magic Mouse 2 to test with.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Thu Jun 06, 2019 10:29 pm 
Offline
Student Driver

Joined: Wed Nov 14, 2018 9:41 pm
Posts: 13
Well... regarding the Magic Mouse 2 behaviour, I've also seen the following:

* If I click (left or right) with a finger on the 'Touch' area (where we expect to have the finger when you click btw), it needs a click-delay to be taken into account, as described in this thread.

* However if I click (left or right) with the finger on the very very edge of the Magic Mouse 2 (so somewhere where there is no 'Touch' area), it works fine and is instantaneous!

So the problem should really come from the impact of having a finger (or any part of your hand I guess) on the Touch surface when you click.

-> I didn't try but maybe putting a piece of paper between the mouse and the finger (to avoid Touch to be detected) should solve the problem (well not really solve but at least confirm that behaviour).

I don't have Sheepshaver installed for now but if someone can try this quick experiment and give a feedback ;-) (using Magic Mouse 2)


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Thu Jun 06, 2019 10:56 pm 
Offline
Forum All-Star
User avatar

Joined: Fri Nov 27, 2009 5:11 am
Posts: 2602
Location: Emaculation.com
What happens if you disable the scroll feature in SheepShaver? I suspect that this may have to do with the delay.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Thu Jun 06, 2019 11:37 pm 
Offline
Student Driver

Joined: Wed Nov 14, 2018 9:41 pm
Posts: 13
Well good idea I'll give it a try later (I need to reinstall Sheepshaver).
Thanks!


Top
 Profile  
Reply with quote Post a reply  
Display posts from previous:  Sort by  
Post new topic  Reply to topic Page 1 of 1 [ 23 posts ]


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
 

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group