E-Maculation
https://www.emaculation.com/forum/

Running Game in SheepShaver "Failed to startup -1856"
https://www.emaculation.com/forum/viewtopic.php?f=20&t=9985
Page 1 of 1

Author:  bobbyboy [ Fri Dec 28, 2018 5:33 pm ]
Post subject:  Running Game in SheepShaver "Failed to startup -1856"

I am trying to figure out how to play my favorite childhood game "Greebles" and for my life I can't figure it out.

I'm have OS 10.11.6 right now, and I am using sheepshaver 2.5 to emulate Mac OS 9.0.4, which I have successfully done and everything seems to be working fine. I gave it 1000Mb of space and 512 for RAM, which should be way more than enough.
I then downloaded "Greebles" from a number of websites and they all download as a .sit file, which expands into a folder containing the game, which is supposed to be compatible with Mac OS 7 - 9.

When I navigate to this application through the "unix" folder and copy it to a folder on the emulated hard drive, the application icon is a script icon and when I try to open it i get a message that reads: "Failed to startup (-1856)"

I have since tried switching to OS 8.5 in sheepshaver, this gave me the Greebles logo as the application icon, and a very brief hoorah before getting the same error message upon opening the game.

Does anyone know what this error means or what I am doing wrong? I can't believe nobody has updated this game or rereleased it, it is such a cool game and I'm dying to play it!

Thanks

Author:  peter_j [ Fri Dec 28, 2018 5:54 pm ]
Post subject:  Re: Running Game in SheepShaver "Failed to startup -1856"

Did you unstuff the .sit file on an emulated hard drive? Not directly on a host drive. You need to do that.

Seems to run fine on my setup - 1GB RAM, ROM 1995 PM7200,7500,8500,9500 [7.5.2 SE701-9.1 512-1.5GB].rom:

Image

Author:  Ronald P. Regensburg [ Fri Dec 28, 2018 8:23 pm ]
Post subject:  Re: Running Game in SheepShaver "Failed to startup -1856"

@ bobbyboy
I do not know what you could be doing wrong.

I downloaded "greebles.sit" from the Macintosh Garden site, unstuffed the archive in my macOS 10.13.6 host system *, moved the resulting "Greebles 1.0" folder to the shared folder, started SheepShaver 2.5 running MacOS 9.0.4, copied the "Greebles 1.0" folder from the "Unix" volume to the virtual HD, opened the copied folder on the virtual HD, and launched Greebles with no problem.

* I unstuffed the sit archive using "The Unarchiver" application.

Author:  bobbyboy [ Fri Dec 28, 2018 8:48 pm ]
Post subject:  Re: Running Game in SheepShaver "Failed to startup -1856"

well, I'm not sure what I had done wrong, however I finally had success running it on OS 7.5.3!

Thanks for the responses everyone!

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/