Login  •  Register


The time is now: Sat Oct 20, 2018 11:02 am

Emaculation wiki  •  Delete all board cookies



Post new topic  Reply to topic Page 1 of 1 [ 11 posts ]
Print view Previous topic  |  Next topic
Author Message
 Post subject: Pearpc 0.4 Network
PostPosted: Tue Apr 14, 2009 12:47 pm 
Offline
Space Cadet

Joined: Tue Apr 14, 2009 12:09 pm
Posts: 3
Location: Brazil
Hi

Thank you
Thanks for the tips, my installation is ok but the network is not working this with the following messages.


[TAP-WIN32]: Enumerating TAP devices...
main() caught exception: Could not locate any installed TAP-WIN32
devices.

My card is a RTL 8139, it installed and running on Windows

thanks for now.


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Tue Apr 14, 2009 1:10 pm 
Offline
Site Admin
User avatar

Joined: Mon May 20, 2002 4:37 am
Posts: 3633
Location: Uiwang
Post a copy of your config file to help us solve your problem...


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Tue Apr 14, 2009 1:59 pm 
Offline
Expert User
User avatar

Joined: Fri Feb 13, 2004 8:59 am
Posts: 4421
Location: Sittard, The Netherlands
Hi,

I understand you have a real realtek 8139 network card in your computer?
PearPC will not use that. It will use a TAP device network adapter you can install as part of the OPENVPN package and pretent to use a fake realtek 8139 in OSX.

http://openvpn.net/release/openvpn-2.0.9-install.exe

Please take care to only install the tap device during installation.

The error you reported should then be history. Further configuration should be done: you should use Internet Connection Sharing with the TAP device on your real network card in Windows and you should configure Mac OSX networking, but first thing first.

Best,
Cat_7


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Fri Apr 17, 2009 10:54 am 
Offline
Space Cadet

Joined: Tue Apr 14, 2009 12:09 pm
Posts: 3
Location: Brazil
Hi

Work fine,I understood that to be not just a card realtec,openvpn installed and it worked but now the problem is that I can not connect to internet in my mac emulation, my connection is PPPoE, I have made several attempts but not the right.


Thanks


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Sun Apr 19, 2009 6:26 am 
Offline
Expert User
User avatar

Joined: Fri Feb 13, 2004 8:59 am
Posts: 4421
Location: Sittard, The Netherlands
Does the connection in OSX show a green button in front of it?

Cat_7


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Mon Apr 20, 2009 2:24 am 
Offline
Space Cadet

Joined: Tue Apr 14, 2009 12:09 pm
Posts: 3
Location: Brazil
Yes,in the connection in OSX show a green button , witch ip 192.168.0.69
e router 192.168.0.1 but an example of I can ping the ip of the router which is 192.168.1.1 but that does not connect in internet.I shared lan of the host but donĀ“t work.


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Mon Apr 20, 2009 4:59 am 
Offline
Expert User
User avatar

Joined: Fri Feb 13, 2004 8:59 am
Posts: 4421
Location: Sittard, The Netherlands
In a terminal window, you can try to stop and start your connection in OSX:
give these three commands:

sudo ifconfig en0 down (you have to enter your administrator password after this)
sudo ifconfig en0 up
sudo route add default 192.168.0.1 (this should be your router ip address)


Saludos,
Cat_7


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Mon Apr 20, 2009 10:30 am 
Offline
Site Admin
User avatar

Joined: Mon May 20, 2002 4:37 am
Posts: 3633
Location: Uiwang
I finally understand this comic:

http://xkcd.com/149/


Top
 Profile  
Reply with quote Post a reply  
 Post subject: Re: Pearpc 0.4 Network
PostPosted: Sun Sep 16, 2018 12:30 pm 
Offline
Space Cadet

Joined: Thu Aug 23, 2018 2:55 pm
Posts: 7
How do I configure Internet Connection Sharing in Windows? I have searched both Control Panel and the Start Menu, but all that comes up is "Diagnose Internet Connection problems". Also, In my virtual Mac, it does not connect to the Internet at all (I think the virtual Mac can't see the adapter?) The virtual Mac OS X version is Mac OS X 10.2.


Top
 Profile  
Reply with quote Post a reply  
 Post subject: Re: Pearpc 0.4 Network
PostPosted: Mon Sep 17, 2018 6:59 am 
Offline
Expert User
User avatar

Joined: Fri Feb 13, 2004 8:59 am
Posts: 4421
Location: Sittard, The Netherlands
Hi,

I don know how far you already got in getting networking going in 10.2

10.2 requires that you install the 3com network card driver. You can find it on an iso here:
http://pearpc.sourceforge.net/downloads ... sw-pkg.iso

I'm not sure whether ICS will work to get the network going. In any case, you first need to install the OpenVPN tap driver. Please make sure to only install the tap driver, not all the rest of OpenVPN.
In the pearpc config file, you then need to enable the 3com card (installed=1).

ICS in windows 10 is done through the properties of the network card itself:
Right click the start button, click network connections. Click Network and Sharing Center.
Then click Change Adapter settings. You will then find the network connections your PC uses. Right click the local area connection and select Properties. Then at the Sharing tab, select "Allow other....." and select the tap device to share the connection.

Windows 7 follows the same path, except you have to get to the network connections through the control panel.

Best,
Cat_7


Top
 Profile  
Reply with quote Post a reply  
 Post subject: Re: Pearpc 0.4 Network
PostPosted: Thu Sep 27, 2018 7:34 pm 
Offline
Space Cadet

Joined: Tue Mar 10, 2015 4:47 pm
Posts: 7
Hello Cat_7,

your had written:
Quote:
ICS in windows 10 is done through the properties of the network card itself:
Right click the start button, click network connections. Click Network and Sharing Center.
Then click Change Adapter settings. You will then find the network connections your PC uses. Right click the local area connection and select Properties. Then at the Sharing tab, select "Allow other....." and select the tap device to share the connection.

Windows 7 follows the same path, except you have to get to the network connections through the control panel


I have Windows 7 64 bit.
I installed the newest Version of TAP device network adapter and only installed the Adapter as you sad.
If I go to "System" and look for the installed Diveces, I can see the Network TAP Card.

There is LAN1 and LAN2 Connects.
LAN1 is the one I use and LAN2 the one for TAP.
LAN2 is shown as not connected, because it is not connected to the Cable.

Please give me a Advise to solve the Problem so I can go on.

Regards, maclinux


Top
 Profile  
Reply with quote Post a reply  
Display posts from previous:  Sort by  
Post new topic  Reply to topic Page 1 of 1 [ 11 posts ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
 

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group