Page 1 of 1

How does one change the default ICS IP address?

Posted: Thu May 12, 2005 4:16 am
by CaptainValor
The router on my network already uses, how do I change the IP address that ICS uses by default?

Posted: Fri May 13, 2005 12:55 pm
by Havin_it
I don't think this is possible in Windows. It was discussed before (here?), and someone told me you could just change the address in the TAP adapter's properties, but this didn't work for me. I also had a dig around in the registry to see if the value was stored there, but no joy yet. It only appears when you have an adapter set up with that IP, so I guess it's hard-coded, or tucked away in a .inf somewhere. Happy huntin'...

Strangely though, when I hooked up PearPC to my office network (whose modem has that IP) it worked. Quite a complex network chain though:

Modem ( goes to
Router ( goes to
PC LAN adapter (192.168.1.x) goes to
Network Bridge (192.168.1.x) DHCP from router, goes to
Wifi adapter (192.168.1.x) goes to
Wifi adapter on my laptop (192.168.1.x DHCP from router) goes to
<<Internet Connection Sharing>>
TAP adapter ( goes to
OS X Realtek adapter (, gateway=router)

And believe it or not, OS X can get DNS no problem! Windows doesn't even throw a warning so I can only think it doesn't 'see' the modem.

Academic I know, since the router is your problem device and there's no hiding from that. Ho hum...

Seriously though, change your network's IP range if possible. Easier than taking Windows to bits...

Posted: Fri May 13, 2005 12:57 pm
by Havin_it
Double-posted too. Oops!

Posted: Fri May 13, 2005 1:14 pm
by CaptainValor
Well that really stinks, then...

I've been trying the proxy method for three days now with no luck. I don't know what I'm doing wrong, either. :(

Posted: Fri May 13, 2005 2:28 pm
by Havin_it
If you're on XP, there is also the option to make a Network Bridge between the adapters.

1) Setup the XP -> Mac connection as a 192.168.0.x static connection, avoid any IP addresses assigned to the router and other network clients, and give both interfaces the router'r IP as Default Gateway ('router' in the Mac settings).

2) In XP's Network Connections, Ctrl+click to select both the connection to the router, and the TAP device. Right-click and 'Bridge Connections'.

3) When the bridge appears, check its TCP/IP properties. The simplest method is DHCP, provided your router has a DHCP server (most do), this should do the trick.

4) Go into Mac OS and see if you can get Web. If not, open the Network Utility and see what IPs (TAP adapter, bridge, router) you can successfully ping. Then report back.

I've never used proxy but am opposed to it. You shouldn't need this much extra software running just to get PPC on the Net. Give bridging a try, if it doesn't work come back and tell us what happened.

Posted: Sat May 14, 2005 2:13 am
by CaptainValor
Bridging works for me up to a point, more details in this thread...

So I can browse using bridging, but cannot transfer files. And I cannot use ICS because my router has an IP of :(

Posted: Sat May 14, 2005 7:17 am
by Cat_7
Do you even see the files in your windows share?
Or does it display the server not available message immediately?

I created a user on the windows side with the same name as the mac os X user and full rights to a share. Then connect to smb://"ip-adress of windows machine"/"sharename"

And then there is the question what build of pear you are using. The newer ones have 3com networking repaired.

Works for me.

Posted: Sat May 14, 2005 8:35 am
by Havin_it
So it looks like your uploads get clobbered after a very small limit (127kb). I'll have to check this out for myself...

I have seen the 'Bad packet read by client' message before - usually long repeats of same at a time - in the context of internet connection.

Could you upload successfully when you used to use ICS?
When you connect to one of the Windows shares, does it create a .DS_STORE file there? (This file may be hidden in Win Explorer, I can't rememmber...)

Posted: Sat May 14, 2005 8:56 pm
by CaptainValor
Yes, I can see the Windows file list and it does create the .DS_Store file there, but fails as soon as I try to transfer anything. Everything worked fine back when I could use ICS. I'm using the 3-23-05 build of 0.4pre.

Posted: Sat May 14, 2005 11:34 pm
by Cat_7
CV: there have been 3 updates to the 3com support in pear since 3-23-2005. I suggest you first try a newer build.


Posted: Sun May 15, 2005 3:53 am
by CaptainValor
Well I just got the 5-11-05 build with a bunch of bells and whistles. The 3com card does not work for me in OS X using it. Only the realtek. :(

Posted: Sun May 15, 2005 7:35 am
by Cat_7
The 3com driver itself needs to be installed in Panther.
Download this file from: Take the "Download kext package for easy install" and mount it as slave in Panther, then install the 3com package from it.

In Tiger however, the "build-in" ethernet card becomes available, without any extra drivers.