Cannot find bootfile?

About PearPC, a PPC Mac emulator for Windows and Linux that can run MacOS X up to 10.4.

Moderators: Cat_7, Ronald P. Regensburg

Post Reply
hijr21
Space Cadet
Posts: 1
Joined: Sun Apr 13, 2008 3:52 am

Cannot find bootfile?

Post by hijr21 »

When I choose wihich partition to choose from, it gets an error saying "error dumping bootfile cannot find bootfile.

config file:
ppc_start_resolution = "800x600x15"

ppc_start_full_screen = 0

redraw_interval_msec = 40

key_compose_dialog = "F11"
key_change_cd_0 = "none"
key_toggle_mouse_grab = "F12"
key_toggle_full_screen = "Alt+Return"

prom_bootmethod = "select"

#prom_bootmethod = "auto"
#prom_loadfile = "test/yaboot"
#prom_env_bootpath = "disk"

#prom_env_bootargs = ""
#prom_env_machargs = "-v"

prom_driver_graphic = "video.x"

#page_table_pa = 104857600

#cpu_pvr = 0x00088302
#cpu_pvr = 0x000c0201

memory_size=0x8000000

##
## PCI IDE Config
##
## Drive type will be set according to file extension:
## .img: Harddisk (filesize must be multiple of 516096)
## .iso: CD-Rom
## Or you can override this by specifying the type via
## pci_ide0_master_type / pci_ide0_slave_type
##
## Valid drive types are:
## hd: A hdd image should be specified
## e.g. "test/imgs/linux.img"
## cdrom: A cdrom image should be specified
## For Linux or BeOS a cdrom device can be specified as well
## e.g. "/dev/cdrom"
## nativecdrom: Platform dependant
## Win (SPTI): drive letter, e.g. "d:\"
## Win (ASPI): SCSI host adapter,target,lun e.g. "2,0,1"
## BeOS (ATAPI): device path, e.g. "/dev/disk/ide/atapi/0/master/0/raw"

pci_ide0_master_installed = 1
pci_ide0_master_image = "c:\PearPC\24gb.img"
pci_ide0_master_type = "hd"

pci_ide0_slave_installed = 1
pci_ide0_slave_image = "c:\PearPC\Mac OS X Install Disc 1.dmg.iso"
#pci_ide0_slave_image = "2,0,0"
#pci_ide0_slave_image = "/dev/cdrom"
pci_ide0_slave_type = "hd"

pci_3c90x_installed = 0
pci_3c90x_mac = "de:ad:ca:fe:12:34"

pci_rtl8139_installed = 0
pci_rtl8139_mac = "de:ad:ca:fe:12:35"

pci_usb_installed = 1
nvram_file = "nvram"
MacOSX
Tinkerer
Posts: 55
Joined: Fri Jul 30, 2004 2:23 pm
Location: Canada

Post by MacOSX »

You CD image needs to be correct.
maybe your image file is not uncompressed? the file name seems a bit wierd.
boyanml
Inquisitive Elf
Posts: 35
Joined: Tue Oct 19, 2004 11:15 am
Location: Sofia, Bulgaria

Re: Cannot find bootfile?

Post by boyanml »

hijr21 wrote:pci_ide0_slave_type = "hd"
Try with
pci_ide0_slave_type = "cdrom"

And how do you created "Mac OS X Install Disc 1.dmg.iso"?
Post Reply