Switch to full style
About PearPC, a PPC Mac emulator for Windows and Linux, and to a limited extent MacOSX, that can run MacOSX up to 10.4.
Post a reply

PearPC for Windows Setup Guide (with the new 0.5.0 release)

Sat Nov 22, 2008 9:35 am

I added a pearpc setup guide to the wiki:

http://www.emaculation.com/doku.php/pearpc_setup

Update: This was rewritten on October 28, 2018.
Last edited by ClockWise on Sat Oct 27, 2018 3:55 am, edited 3 times in total.
Reason:  

Mon Feb 09, 2009 6:41 am

Hey, it would be really cool if someone could work through this guide and report back here if it works.

Someone on pearpc.net followed it (maybe) and had a problem that I did not.

PearPC is sort of wonky in the set-up phase, I know, so maybe the guide needs a few extra tips.

Redscorp Install

Thu Apr 09, 2009 10:24 pm

Hi.

I have been using your guide and the Redscorp files and I get to the PROM Boot loader page, select the boot device and this is what I keep getting on the output display:

21:44:09:327> This program is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License version 2 as published by
the Free Software Foundation.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.

You should have received a copy of the GNU General Public License
along with this program; if not, write to the Free Software
Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111 USA

21:44:09:327> GenuineIntel
21:44:09:327> CMOV MMX SSE
21:44:09:947> [IO/IDE] add IDE0 master.
21:44:09:947> [IO/IDE] add IDE0 slave.
21:44:09:947> [IO/IDE] add IDE1 master.
21:44:09:947> [IO/IDE] add IDE1 slave.
21:44:09:947> [IO/IDE] add IDE2 master.
21:44:09:947> [IO/IDE] add IDE2 slave.
21:44:09:947> [IO/IDE] add IDE3 master.
21:44:09:947> [IO/IDE] add IDE3 slave.
21:44:11:379> [CPU/MMU] new pagetable: sdr1 = 0x00300003
21:44:11:379> [CPU/MMU] new pagetable: sdr1 accepted
21:44:11:379> [CPU/MMU] number of pages: 2^15 pagetable_start: 0x00300000 size: 2^18
21:44:11:500> start: 512
21:44:11:530> start: 134250496
getStartBlock: 0 Apple_HFS
getStartBlock: 1 Apple_HFS
getStartBlock: 2 Apple_HFS
getStartBlock: 3 Apple_HFS
21:44:11:570> start: 32768
getStartBlock: 0 Apple_Free
getStartBlock: 1 Apple_Free
getStartBlock: 2 Apple_Free
getStartBlock: 3 Apple_Free
21:44:11:580> start: 2147450880
getStartBlock: 0 Apple_Free
getStartBlock: 1 Apple_Free
getStartBlock: 2 Apple_Free
getStartBlock: 3 Apple_Free
21:44:11:620> [IO/PROM] Add alias disk0 -> /pci/pci-bridge/pci-ata/ata-4/disk0@0
getStartBlock: 0 Apple_HFS
getStartBlock: 1 Apple_HFS
getStartBlock: 2 Apple_HFS
getStartBlock: 3 Apple_HFS
21:44:16:226> [IO/PROM] <Error> can't open boot file

Here is my Config file:

#WinMAC
# Created with PearPC Control Panel
#D:\Pat\PearPC\Redscorp\redscorp-release-20080329.1\release\ppc-generic-mmx.exe
#FinderIcon
#No SDL
pci_ide0_master_installed = 1
pci_ide0_master_image = "D:\Pat\PearPC\macosx_6gb.img"
pci_ide0_master_type = "hd"
memory_size = 0x8000000
ppc_start_resolution = "1280x1024x15"
redraw_interval_msec = 75
prom_driver_graphic = "D:\Pat\PearPC\Redscorp\redscorp-release-20080329.1\release\video.x"
ppc_start_full_screen = 0
key_toggle_mouse_grab = "F12"
key_toggle_full_screen = "Alt+Return"
key_change_cd_0 = "none"
cpu_pvr = 0x00088302
pci_rtl8139_installed = 0
pci_rtl8139_mac = "de:ad:ca:fe:12:35"
pci_rtl8139_type = "tap"
pci_rtl8139_interface = ""
pci_3c90x_installed = 0
pci_3c90x_mac = "de:ad:ca:fe:12:35"
pci_3c90x_type = "tap"
pci_3c90x_interface = ""
pci_usb_installed = 1
prom_bootmethod = "select"
prom_env_bootargs = ""
prom_env_machargs = ""
nvram_file = "nvram"
pci_ide0_slave_installed = 0
pci_ide0_slave_image = ""

(D:\ is my second HD)

Do I need to burn a copy of the ISO and install from a DVD?

Any ideas what I should do to be able to continue?

Thanks,

Pat

Fri Apr 10, 2009 6:24 am

Hi,

It seems you have nothing defined to boot from:

pci_ide0_slave_installed = 0
pci_ide0_slave_image = ""

This should read:
pci_ide0_slave_installed = 1
pci_ide0_slave_image = "Driveletter/path/to/your/iso"
pci_ide0_slave_type = "cdrom"


If that doesn't work, you might want to change the master and slave entries: put the iso as master ide0 and hard disk image as slave ide0.

Tue Sep 01, 2009 4:04 pm

Last edited by dicamarques on Tue Sep 01, 2009 4:07 pm, edited 1 time in total.

Tue Sep 01, 2009 4:06 pm

Cat_7 wrote:Hi,

It seems you have nothing defined to boot from:

pci_ide0_slave_installed = 0
pci_ide0_slave_image = ""

This should read:
pci_ide0_slave_installed = 1
pci_ide0_slave_image = "Driveletter/path/to/your/iso"
pci_ide0_slave_type = "cdrom"


If that doesn't work, you might want to change the master and slave entries: put the iso as master ide0 and hard disk image as slave ide0.


I have the same error see my configuration file.

#dg
# Created with PearPC Control Panel
#C:\Documents and Settings\Diogo\Ambiente de trabalho\redscorp-release-20080329.1\release\ppc-generic-mmx.exe
#FinderIcon
#No SDL
pci_ide0_master_installed = 1
pci_ide0_master_image = "E:\pear pc\macosx_6gb.img"
pci_ide0_master_type = "hd"
memory_size = 0x14000000
ppc_start_resolution = "800x600x15"
redraw_interval_msec = 60
prom_driver_graphic = "E:\pear pc\video.x"
ppc_start_full_screen = 0
key_toggle_mouse_grab = "F12"
key_toggle_full_screen = "Alt+Return"
key_change_cd_0 = "none"
cpu_pvr = 0x00088302
pci_rtl8139_installed = 0
pci_rtl8139_mac = "de:ad:ca:fe:12:35"
pci_rtl8139_type = "tap"
pci_rtl8139_interface = ""
pci_3c90x_installed = 0
pci_3c90x_mac = "de:ad:ca:fe:12:35"
pci_3c90x_type = "tap"
pci_3c90x_interface = ""
pci_usb_installed = 1
prom_bootmethod = "select"
prom_env_bootargs = ""
prom_env_machargs = ""
nvram_file = "nvram"
pci_ide0_slave_installed = 1
pci_ide0_slave_image = "E:\Mac OS X Install DVD.iso"
pci_ide0_slave_type = "cdrom"

please awnser

Wed Sep 02, 2009 4:47 am

What version of OS X are you trying to install?

This might be a little patronizing, but maybe also make sure that the path to the file is correct...

Wed Sep 02, 2009 2:27 pm

ClockWise wrote:What version of OS X are you trying to install?

This might be a little patronizing, but maybe also make sure that the path to the file is correct...


THIS ISO image as only the boot camp. I did think that was it the macintosh.
it as it what was saying in the fle

Wed Sep 02, 2009 4:07 pm

Boot camp?

PearPC will only allow PowerPC OSX disks to be booted, not Intel Mac disks

Cat_7

Thu Sep 03, 2009 4:14 pm

Cat_7 wrote:Boot camp?

PearPC will only allow PowerPC OSX disks to be booted, not Intel Mac disks

Cat_7


BUT CAN I INSTALL IT WITH BOOT CAMP

Sat Sep 05, 2009 4:40 am

Probably not.

Probably no one has ever tried. You should give it a shot.

Mon Oct 26, 2009 12:59 am

i have a different problem. i've tried following the setup instructions (http://www.emaculation.com/doku.php/pearpc_setup) but i cant get from figure four to figure five. keeps getting stuck somewhere in the middle. here's my config file.

#mac os x
# Created with PearPC Control Panel
#D:\home installers\Mac OS Sim\redscorp-release-20080329.1\redscorp-release-20080329.1\release\ppc-intel-sse2.exe
#FinderIcon
#No SDL
pci_ide0_master_installed = 1
pci_ide0_master_image = "D:\home installers\Mac OS Sim\pearpc-6gib.img\pearpc-6gib.img"
pci_ide0_master_type = "hd"
memory_size = 0x40000000
ppc_start_resolution = "800x600x15"
redraw_interval_msec = 60
prom_driver_graphic = "D:\home installers\Mac OS Sim\redscorp-release-20080329.1\redscorp-release-20080329.1\release\video.x"
ppc_start_full_screen = 0
key_toggle_mouse_grab = "F12"
key_toggle_full_screen = "Alt+Return"
key_change_cd_0 = "none"
cpu_pvr = 0x00088302
pci_rtl8139_installed = 0
pci_rtl8139_mac = "de:ad:ca:fe:12:35"
pci_rtl8139_type = "tap"
pci_rtl8139_interface = ""
pci_3c90x_installed = 0
pci_3c90x_mac = "de:ad:ca:fe:12:35"
pci_3c90x_type = "tap"
pci_3c90x_interface = ""
pci_usb_installed = 1
prom_bootmethod = "select"
prom_env_bootargs = ""
prom_env_machargs = ""
nvram_file = "nvram"
pci_ide0_slave_installed = 1
pci_ide0_slave_image = "D:\home installers\Mac OS Sim\Mac OS X 10.4 CD version\Mac OS X Install Disc 1.iso"
pci_ide0_slave_type = "cdrom"

would appreciate help on this one. thanks

Mon Oct 26, 2009 1:05 am

Do you mean that you CAN see the "PROM-Bootloader" screen, but that you can progress no farther?

Are you given an option to select a bootable partition? What happens when you select one?

Does some error come up?

Did you install the OS, or does this happen even before you get that far?

Mon Oct 26, 2009 1:16 am

yes, i get to select a bootable partition. after that i get the gray screen with the apple logo, after which the apple becomes a circle with a diagonal slash, then nothing more. it would just stay that way. message from the console:

18:01:59:461> This program is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License version 2 as published by
the Free Software Foundation.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.

You should have received a copy of the GNU General Public License
along with this program; if not, write to the Free Software
Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111 USA

18:01:59:461> GenuineIntel
18:01:59:461> CMOV MMX SSE SSE2
18:01:59:551> [IO/IDE] add IDE0 master.
18:01:59:551> [IO/IDE] add IDE0 slave.
18:01:59:551> [IO/IDE] add IDE1 master.
18:01:59:551> [IO/IDE] add IDE1 slave.
18:01:59:551> [IO/IDE] add IDE2 master.
18:01:59:551> [IO/IDE] add IDE2 slave.
18:01:59:551> [IO/IDE] add IDE3 master.
18:01:59:551> [IO/IDE] add IDE3 slave.
18:01:59:712> [CPU/MMU] new pagetable: sdr1 = 0x00300003
18:01:59:712> [CPU/MMU] new pagetable: sdr1 accepted
18:01:59:712> [CPU/MMU] number of pages: 2^15 pagetable_start: 0x00300000 size: 2^18
18:01:59:722> start: 0
18:01:59:722> [IO/PROM] Add alias disk0 -> /pci/pci-bridge/pci-ata/ata-4/disk0@0
18:01:59:722> [IO/PROM] Add alias cdrom0 -> /pci/pci-bridge/pci-ata/ata-4/disk1@1
18:02:03:277> Loading XCOFF...
18:02:03:277> [CPU/CPU] execution started at 05600adc
18:02:04:408> [CPU/MMU] new pagetable: sdr1 = 0x3fc0003f
18:02:04:418> [CPU/MMU] new pagetable: sdr1 accepted
18:02:04:418> [CPU/MMU] number of pages: 2^19 pagetable_start: 0x3fc00000 size: 2^22
18:02:11:979> [IO/CUDA] <Warning> keyb reg1

and it does nothing after this.[/quote]

Mon Oct 26, 2009 1:18 am

also tried using the generic-mmx release instead of the sse2, but it still does the same thing.

Mon Oct 26, 2009 2:10 am

I think that might be because of the media you are trying to install from.

Did you download it, or make a copy of an install disk that you already have? Is the disk a grey disk that is bundled with some model? I think that might not work well.

If possible, I would suggest downloading another install CD (you can find one via torrent) and try again.

I hope that is a reasonable suggestion...

Mon Oct 26, 2009 2:28 am

the iso images were taken from torrentz.com, initially a .dmg file format and had it converted using PowerISO. yeah, i'll try and download another copy as well as the 6gig bootable disk image.

might as well do that since right now i'm getting error "path not found" after i tried creating a new config file, which was after i changed directories (thinking that the long directory filenames may be part of the cause), un-installed & re-installing pearpc control panel.

even after going back and using the original directory structure, importing the config file, i would still get "path not found". oh well.

Mon Oct 26, 2009 2:37 am

I'm not a PearPC expert at all. So take all my advice with a grain of salt.

Anyhow, I might suggest getting rid of the control panel altogether. Sounds like you are proficent enough to figure out command lines. So you don't need it.

While you are waiting for your download to finish, try generating your own config file using this VERY handy form:

http://guillaumejamet.eu/index?rub=rubr ... pc_cfg.php

And then start PPC.exe directly, from a command line:

C:\your\install\dir> ppc CONFIGFILENAME

http://pearpc.sourceforge.net/getstart.html#starting

The control panel can introduce problems. I should re-write the guide and get rid of it.

Mon Oct 26, 2009 2:45 am

appeciate the support. will let you know when i get it up an running. :)

Mon Oct 26, 2009 5:32 am

Hi,

When you create a config file with the web service, please make sure you set boot_args to "-v". That way you can see what is causing the "no entry" sign to appear. My guess would be that the 6Gb image is not OK.

Best,
Cat_7

Mon Oct 26, 2009 6:44 am

tried downloading a different 6gb bootable image file but i still get the same error

[IO/CUDA] <Warning> keyb reg1

also tried the

prom_env_machargs = "-v"

as well as removing the '-v' but it's still the same thing.

last thing i tried was installing a gcc compiler and try to compile it myself. however when i tried running the command

$ ./configure --enable-ui=$UI --enable-cpu=$CPU && make

or even

$ ./configure && make

i get error messages like:

gcc: $: No such file or directory
gcc: ./configure: No such file or directory
gcc: no input files"

at this point i really have no idea what do now since it's been a far too long a time since i've done any compiling or anything of that sort.

i'd really appreciate it if anybody send me/post a newly compiled version.

thanks

Mon Oct 26, 2009 7:46 am

:(

Did you try a different iso?

You can try using the last stable version of the emulator, if you haven't already:

http://pearpc.sourceforge.net/downloads.html

The version in the guide is a sort of unofficial version

Mon Oct 26, 2009 8:21 am

the one i'm using is the latest one. as for the iso file, download hasn't finished yet, i'm also downloading a 10.3 version as well.

anyways, appreciate the help. thanks

Tue Oct 27, 2009 1:49 am

am now happily installing mac os x 10.4. finally it worked! gonna be completed in about an hour or so.

the things i did to make it work:

1. ditched the PearPC Control Panel
2. downloaded a new bootable 6gb disk image (http://www.emaculation.com/pearpc/macosx_6gb.rar)
3. downloaded via torrent another copy of mac os x 10.4 (a one-file dvd image copy, toast format) previous copy was a 4-file cd image, dmg file format converted to iso (using PowerISO)
4. had my own config file created (http://guillaumejamet.eu/index?rub=rubr ... pc_cfg.php)
5. a whole lot of trial and error to get the right settings on my config file.
6. didn't have to use: prom_env_machargs = "-v", worked quiet well without it


#test
# Created with PearPC Control Panel
#D:\PearPC\pearpc-0.4-win32-jitc\ppc.exe
#FinderIcon

# This PearPC config file has been generated by a script located on http://guillaumejamet.eu

# Mon, 26 Oct 2009 03:09:51 GMT
# Config reference : http://wiki.pearpc.net/index.php?title= ... ation_File
# More info about PearPc, forums and community : http://pearpc.net

prom_env_machargs = ""
prom_env_bootargs = ""
prom_bootmethod = "select"

key_compose_dialog = "F11"
key_change_cd_0 = "F10"
key_toggle_mouse_grab = "F12"
key_toggle_full_screen = "Alt+Return"

prom_driver_graphic = "D:\PearPC\pearpc-0.4-win32-jitc\video.x"
ppc_start_full_screen = 0
redraw_interval_msec = 20
ppc_start_resolution = "800x600x15@60"

pci_ide0_master_installed = 1
pci_ide0_master_type = "hd"
pci_ide0_master_image = "D:\PearPC\macosx_6gb.img"
pci_ide0_slave_installed = 1
pci_ide0_slave_type = "cdrom"
pci_ide0_slave_image = "C:\Mac OS X Install DVD.iso"

pci_3c90x_installed = 0
pci_3c90x_mac = "de:ad:ca:fe:12:34"
pci_rtl8139_installed = 0
pci_rtl8139_mac = "de:ad:ca:fe:12:35"

cpu_pvr = 0x00088302

nvram_file = "nvram"
#page_table_pa = 104857600
memory_size = 0x8000000


by the way,
1. didn't have to compile my own version of pearpc, used the latest compiled version available on pearpc's site.
2. still get the error message: [IO/CUDA] <Warning> keyb reg1
3. i get a lot of this error message during installation:
[IO/CUDA] <Warning> Event processing timed out. Event dropped.
4. set my memory setting to 128 MB, since Tiger won't install on anything less or more than 128 MB (can always be increased later)

again, appreciate all the help extended. thanks

Tue Oct 27, 2009 2:11 am

clarification:

what i stopped using was the redscorp release (http://www.emaculation.com/pearpc/redsc ... 0329.1.zip) of PearPC Control Panel. instead, i used this copy (http://prdownloads.sourceforge.net/pear ... 2-jitc.zip).
Post a reply