Switch to full style
Anything not about Mac emulation.
Post a reply

Mac OS X 10.5 and VirtualBox

Sun May 01, 2016 7:37 pm

Well, here's the issue:
VirtualBox 4.3.6 runs OS X 10.5.8 just fine.
My 2015 MBP however, runs OS X 10.11, which is incompatible with 4.3.6 -- it needs 5.something.
Furthermore, the MBP uses the CrystalWell architecture, which 10.5 doesn't recognize.

So, I've done the following:
1. remove /System/Library/Extensions/AppleIntelCPUPowerManagement.kext
2. Apply
Code:
VBoxManage modifyvm "<vmname>" --cpuidset 00000001 000006f6 00000800 80000209 078bfbff
-- to set the CPU to a recognized one instead of CrystalWell
3. Apply
Code:
VBoxManage setextradata "<vmname>" VBoxInternal/Devices/efi/0/Config/DmiSystemProduct "MacBookPro2,1"
-- to set the machine ID to a recognized one instead of MacBookPro11,2 or whatever my current one is.
4. Play with theh 32/64-bit settings -- some versions of 4.3 will run 10.5 in 32-bit, some will run it in 64-bit
5. Set memory to 1024 MBs -- it sometimes behaves oddly with more memory

So: if I use an already installed image from when I had an older computer and 4.3.6, I get:
Image

I saw from that that I had modified the IOACPI kernel to attempt to use a newer one, so I tried to use an older version of the kext...

I get:
Image

So; moving back to original install media, when I attempt to boot from that I get:
Image

Anyone have any idea how I could move forward here? The kernel patch for 10.4 doesn't work for 10.5, and supposedly isn't needed (the one where the cpuid actually is missing some info in newer architectures that it uses to set things up).

I've spent almost a year wrestling with this now, and am at a loss. I've had some advice saying things like "it works for me" and similar, but nothing's working in my case.

Anyone have ideas on what else I can try to get 10.5 running again?

Re: Mac OS X 10.5 and VirtualBox

Sun May 22, 2016 9:14 pm

Use Vmware Workstation, or better yet Vmware Fusion on OS X.

Re: Mac OS X 10.5 and VirtualBox

Wed May 25, 2016 5:45 pm

That's (kind of) the easy way out. Using VMWare Fusion, you need to apply the VMWare patch, as VMWare actively looks to see if it is installing the client version of 10.4 or 10.5, due to licensing issues. This can be patched.

However, once patched, I still run up against the CrystalWell incompatibility with 10.5.

Have you successfully got 10.5 running on a 2015/2016 Mac?

The bigger thing though, is I want to figure out what broke with VBox and apply a patch so that my current workflow (previous workflow in the case of 10.5) still works going forward. I figure if something broke, it can be fixed. Otherwise, we'll hit this same issue again in the future and still not know what's going on.
Post a reply