Login  •  Register


The time is now: Tue Jul 23, 2019 2:20 pm

Emaculation wiki  •  Delete all board cookies



Post new topic  Reply to topic Page 1 of 1 [ 5 posts ]
Print view Previous topic  |  Next topic
Author Message
PostPosted: Tue Mar 26, 2019 11:19 pm 
Offline
Student Driver

Joined: Thu Mar 21, 2019 4:41 am
Posts: 10
I'm running Edward Mendelson's excellent pre-packaged SheepShaver, from URL http://www.columbia.edu/~em36/macos9osx.html. My host is a late 2013 iMac (2.7 GHz Intel Core i5), running Yosemite 10.10.5.

When I first installed this emulator, I could copy files from Mac OS 9 to the Yosemite host by dropping the file onto the icon "Copy to Host." The file would then appear in my Yosemite's User-->Documents-->Desktop Folder (as Edward documented).

That function has stopped working.

Now when I drop a file onto the "Copy to Host" icon, I immediately get the error, "Unable to copy the file to the host system: File some object wasn't found."


(I do have "SOMobjects™ for Mac OS" in my Extensions folder.)

How can I fix this?

After several seconds, I usually also get the error, "The application '~MacOS9BackgroundScript' has unexpectedly quit, because an error of type 2 occurred."

How can I fix this?

(I have several screen shots; how can I include them here?)

Thanks.

--Mark


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Wed Mar 27, 2019 12:32 am 
Offline
Forum All-Star

Joined: Tue Oct 14, 2008 12:12 am
Posts: 1053
Probably something's corrupted on the OS9 hard disk. Best thing is to download the MacOS9 application again and start over.

Alternately, if you're feeling brave, open the "Copy to Host" applet in either Script Debugger (in the SheepShaver Applications folder) or the Script Editor; make a trivial change (like adding a space somewhere), and then save it again, and see if that fixes it. But it probably won't. Best thing is to download again.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Wed Mar 27, 2019 10:28 pm 
Offline
Student Driver

Joined: Thu Mar 21, 2019 4:41 am
Posts: 10
Thanks, emendelson, I'll download the Mac OS 9 application and re-install.

What do I need to do to uninstall it first? I'd delete "Desktop Folder" and "SendToMacOS9" from Documents. Anything else?

--Mark


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Wed Mar 27, 2019 10:40 pm 
Offline
Forum All-Star

Joined: Tue Oct 14, 2008 12:12 am
Posts: 1053
You don't need to uninstall anything. Just download the new version and launch it. Please let us know the results.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Mon Apr 01, 2019 1:42 am 
Offline
Student Driver

Joined: Thu Mar 21, 2019 4:41 am
Posts: 10
Thanks, emendelson, I downloaded and re-installed the Mac OS 9 application, and that fixed my problems.


Top
 Profile  
Reply with quote Post a reply  
Display posts from previous:  Sort by  
Post new topic  Reply to topic Page 1 of 1 [ 5 posts ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
 

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group