Processor Speed Too Slow for Game

About unsupported SheepShaver configurations, like COI (Chubby Bunny), SheepShaver Wrapper, etc.

Moderators: Cat_7, Ronald P. Regensburg

Post Reply
nostaglicweekend
Space Cadet
Posts: 1
Joined: Sat Feb 08, 2020 6:27 am

Processor Speed Too Slow for Game

Post by nostaglicweekend »

Hello!

After feeling a profound wave of nostalgia this evening, I wanted to play the original Zoo Tycoon game again. I have spent the evening learning about SheepShaver and while I thought I was following instructions to the letter, I've run into an issue where when I try and launch the game in the MAC OS 9 window it gives me an error message stating "Zoo Tycoon requires a PowerPC processor running at 233 MHZ or faster". After doing some digging on this forum I found a couple instances of people running into the same problem, but for the life of me I still don't know how to fix it. Apologies, as I am just beginning to learn about computers.

So here is what I've done so far:

I downloaded the game from Macintosh Garden here: http://macintoshgarden.org/games/zoo-tycoon.
I downloaded the MAC OS 9.0.4 SheepShaver system from here: http://www.columbia.edu/~em36/macos9osx.html

Image

I was able to run everything, put the game file into the 'SendToMacOS9' folder, drag it out of there into the Mac OS 9 window, drag it into the Mac OS 9 drive, open it, and just when everything seemed like it is about to work, I get the processor speed error

Image

So I did some digging around on this site, and saw that someone had a very similar issue a year ago (https://www.emaculation.com/forum/viewt ... 20&t=10010), and while they were able to resolve the issues I couldn't quite understand how to fix it for myself. They were able to insert a line of code into a file somewhere so the game didn't assume that the emulator was running at 100 MHz.

Again, very sorry for repeating a question, but would someone be able to walk me through exactly how to fix this issue? I am at my wits end here but feel like I'm so close and I can't give up now.

Many thanks in advance!!
User avatar
Cat_7
Expert User
Posts: 5384
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Re: Processor Speed Too Slow for Game

Post by Cat_7 »

Hi,

I moved your post to this forum, as you seem to be using the SheepShaver setup this forum is about. (Note that I don't know whether this setup behaves differently from the default SheepShaver app we provide).

You did the digging for an answer yourself ;-)

Following the post below might solve your problem. It involve manually editing your preferences file:

The prefs file is a hidden file in your Home folder. You can open it in Text Editor using a Terminal command.
Launch Terminal (in /Application/Utilities/) and type at the prompt

Code: Select all

open ~/.sheepshaver_prefs
Followed by a return.
The file will open in your default text editor, normally Text Editor.
At bottom add the line:

Code: Select all

cpuclock 300
Then close the file while saving the changes.

You can then start SheepShaver.

Best,
Cat_7
Post Reply