Login  •  Register


The time is now: Tue Aug 20, 2019 2:53 pm

Emaculation wiki  •  Delete all board cookies



Post new topic  Reply to topic Page 1 of 1 [ 7 posts ]
Print view Previous topic  |  Next topic
Author Message
PostPosted: Tue Dec 03, 2013 1:52 pm 
Offline
Space Cadet

Joined: Tue Dec 03, 2013 12:51 pm
Posts: 4
Hi all! :)
I'm new here, and i'm reading a few hours all regarding emulation of MAC OS 8.5, 8.6, 8.7... in MAc OS x (Snow Leopard). From zero, now i'm able to install and use some of them. I just want to use a Firewire Image Memory Card Reader (Fujifilm DM-R1), but, even after overcoming all obstacles to achieve run these older operating systems, i'm at the point that, after installing proper firewire card reader drivers, system cant recognize the hardware, or cant show the new unit... don't know what, don't know why, don't know how :( Quite desperated :(

Could you please help me in anyway?

Thanks!

Javi


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Tue Dec 03, 2013 2:21 pm 
Offline
Expert User
User avatar

Joined: Thu Feb 09, 2006 10:24 pm
Posts: 5526
Location: Amsterdam, Netherlands
1. You post this in the "Other SheepShaver configurations" subforum, so I suppose you use a special SheepShaver configuration. Which one do you use?

2. You cannot use firewire with these emulators. Is there a special reason why you want to read or write files directly between the emulator and the card reader? You can use the card reader in OSX and move files between the OSX host and the MacOS guest using the shared folder feature.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Tue Dec 03, 2013 2:53 pm 
Offline
Space Cadet

Joined: Tue Dec 03, 2013 12:51 pm
Posts: 4
Hello Ronald, and thanks for your quick answer :)

I suposed that this was the right place to my question :$ Sorry if not :/ Maybe i made a mistake... i have here sheepshaver itself, and other 3 'packs', with OS 7.5 (from wp forum), OS 9.x, and another onem an APP where i could drag my ROM and OS 7, 8 or 9... But now i think i'm using just Sheepshaver, and i configured it with the ROm from an OS 8.5 image disk, and this OS 8.5 img, and then updated to OS 8.7. If i read this twice in aloud voice, i feel crazy... :D

The main question is that i have a firewire Compact flash card reader, that it's only supported by MAC OS 8.5.1 - 9.0 :( I've spent many hours trying to understand what this means, and I have concluded that my only solution is to install an emulator for older operating systems apple where my firewire drivers to install and use this card reader.... Sorry for my english, it's not my native languaje, and sorry if i can't explain my problem better, i'm trying to do both the best i can.

Any advice for further research? I promise I've spent all my known alternatives, would not bother before trying everything in my power. :)

Thanks thanks!


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Tue Dec 03, 2013 4:24 pm 
Offline
Expert User
User avatar

Joined: Thu Feb 09, 2006 10:24 pm
Posts: 5526
Location: Amsterdam, Netherlands
(I did not even know that MacOS 8.7 existed.)

But regarding your question: SheepShaver does not emulate the Firewire hardware. It is as if you have an old pre-Firewire Mac that has no Firewire ports. Installing drivers does not change that.

I would expect the card reader to work in OSX, even without special drivers. Have you tried? If it does not work, are you sure the cards you tried with it are OK?

But if it does not work in OSX, even with healthy cards, you cannot use this card reader. Have you considered buying a new reader? If the flash cards are of a usual type, you can use them in any cheap universal card reader.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Tue Dec 03, 2013 4:31 pm 
Offline
Space Cadet

Joined: Tue Dec 03, 2013 12:51 pm
Posts: 4
Well, first of all: I have Mac OS 8.7 installed and running :D (it's called Shara... I can send you some images to an e-mail if you want! :))

Apart from this, i can see Firewire capabilities extension in OS 8.5, 8.6 and 8.7; and i placed the firewire hardware extensions in it's folder, and activated them in extensions manager, without any success :(

The thing is that i have USB card readers, but i bought this Firewire one, because of it's supposed speed, but this hardware is quite old, from year 2000, and only compatible with mac OS 8.5.1 to 9.0 But... i see it's not possible to emulate firewire capabilities as you say :''(

I'm afraid i must re-sell this hardware, or save it in a box forever :(

Thank you very much for your help, Ronald :)


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Tue Dec 03, 2013 6:49 pm 
Offline
Forum All-Star
User avatar

Joined: Fri Nov 27, 2009 5:11 am
Posts: 2667
Location: Emaculation.com
Sorry to co-opt the thread, but it appears the original issue has been sorted (Firewire and USB are not exposed to the guest OS via Sheepshaver).

On to the other stuff...
By 8.7, I presume you're talking about Mac OS 8.7a6c3 (Codename: “Sarah”) (as opposed to 8.7a6c2, which was also codenamed "Sarah") -- are you finding this to be stable? I ended up scrapping this image because I found that there were still a number of stability issues in that beta version and it wasn't all that different from my 9.0.4 image, other than the version number. Are you using the US English version of this beta, or an international version?

Also, just so everyone doesn't get TOO confused, 8.7 was officially released as Mac OS 9.0. So after 8.6, the next stable version was 9.0.4 (which some of us at the time called 8.9).


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Wed Dec 04, 2013 9:38 am 
Offline
Space Cadet

Joined: Tue Dec 03, 2013 12:51 pm
Posts: 4
Hi!
This is 'Sarah', Mac OS 8.7a6c2 and, i don't use it much... i just installed it trying to use that old firewire hardware, unsuccessfully :( But it seems to be quite stable:
Finder: 8.7a6
System: 8.7a6 US
Quicktime: 4.0

:)


Top
 Profile  
Reply with quote Post a reply  
Display posts from previous:  Sort by  
Post new topic  Reply to topic Page 1 of 1 [ 7 posts ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
 

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group