Screamer, 9.2.2 & Adventures with Sound

About QEMU, a PPC Mac emulator for Windows, macOS and Linux that can run Mac OS 9.0 up to Mac OS X 10.5

Moderators: Cat_7, Ronald P. Regensburg

User avatar
adespoton
Forum All-Star
Posts: 3069
Joined: Fri Nov 27, 2009 5:11 am
Location: Emaculation.com
Contact:

Re: Screamer, 9.2.2 & Adventures with Sound

Post by adespoton »

To clarify, this means that you should run with LESS than 1024Mb memory, correct?
User avatar
Cat_7
Expert User
Posts: 5020
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Re: Screamer, 9.2.2 & Adventures with Sound

Post by Cat_7 »

Yes, I fixed that in the earlier message.

Best,
Cat_7
DaFrigN
Space Cadet
Posts: 3
Joined: Thu Jan 10, 2013 3:27 pm

Re: Screamer, 9.2.2 & Adventures with Sound

Post by DaFrigN »

After banging my head into a wall repeatedly and trying different installs, I figured out the key to my sound problems with QEMU PPC and System 9.x were resolved by simply turning ON virtual memory. Which is kind of a bummer because the app I wanted to run, Opcode's Studio Vision Pro (DAW, sort of like GarageBand) doesn't like virtual memory being on, although it does sort of try to work with the SoundManager anyway, very laggy. I'm running it on a 6th gen Core i7. Still it's more useable than with SheepShaver.
chorizo
Space Cadet
Posts: 5
Joined: Sat Dec 07, 2019 8:09 pm

Re: Screamer, 9.2.2 & Adventures with Sound

Post by chorizo »

I'm running 4.2 downloaded through Homebrew and don't have any sound on 9.2.2. Should I have sound, or do I need to apply the patches first? Here is my config (Catalina host):

qemu-system-ppc \
-L pc-bios \
-boot c \
-M mac99,via=pmu \
-m 512 \
-cpu G4 \
-prom-env 'auto-boot?=true' \
-prom-env 'boot-args=-v' \
-prom-env 'vga-ndrv?=true' \
-drive file="Macintosh HD.img",format=raw,media=disk \
-netdev user,id=network01 -device sungem,netdev=network01 \
-device VGA,edid=on \
-g 1024x768x32 \
-k en-us
User avatar
Cat_7
Expert User
Posts: 5020
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Re: Screamer, 9.2.2 & Adventures with Sound

Post by Cat_7 »

Hi,

Sound is only available when building your own Qemu from https://github.com/mcayland/qemu/tree/screamer
or when using experimental build we provide: https://www.emaculation.com/forum/viewt ... 102#p52102

Best,
Cat_7
chorizo
Space Cadet
Posts: 5
Joined: Sat Dec 07, 2019 8:09 pm

Re: Screamer, 9.2.2 & Adventures with Sound

Post by chorizo »

I tried the experimental build you provided and still no sound. Are there additional options I need to add to the config or should it work with the one you provided out of the box? I'm not running any audio add-ons in Catalina.

I will try to building my own version later.
User avatar
adespoton
Forum All-Star
Posts: 3069
Joined: Fri Nov 27, 2009 5:11 am
Location: Emaculation.com
Contact:

Re: Screamer, 9.2.2 & Adventures with Sound

Post by adespoton »

Once you've booted, you may need to make adjustments in the Monitors & Sound control panel to select the output device, if you're using an existing OS 9 and not installing from scratch.
User avatar
Cat_7
Expert User
Posts: 5020
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Re: Screamer, 9.2.2 & Adventures with Sound

Post by Cat_7 »

Hi,

Just to be sure, did you download this one?
https://surfdrive.surf.nl/files/index.p ... 2/download

You need to use all of the download. So please make sure you are not mixing files from two downloads. Put the screamer download in its own folder.

When opening the output tab in the sound control panel you should see the "spatializer audio laboratories" logo.
You als need to make sure virtual memory is turned on, and keep qemu memory below 1024Mb (as you already have).

Best,
Cat_7
chorizo
Space Cadet
Posts: 5
Joined: Sat Dec 07, 2019 8:09 pm

Re: Screamer, 9.2.2 & Adventures with Sound

Post by chorizo »

Ah, that was it! Sounds works now. I had somehow downloaded a non-screamer build from 2019. Thanks for your work on this project and being patient with those of us who are learning Qemu.
rscaboyke
Student Driver
Posts: 24
Joined: Thu May 10, 2007 7:54 am

Re: Screamer, 9.2.2 & Adventures with Sound

Post by rscaboyke »

Latest screamer build on MacBook Pro 15 late 2013 8GB 2GHz Intel Core I7 - high Sierra working great

Sound internet radio (modern live-links like here in Belgium Q-music work only via Winamp for mac) working without crackling, but when playing the live stream, rest of Apps in MacOS 9.2.2 and Finder itself almost useless because it slows down the whole machine even with 768 ram assigned. Wondering if soon we can go over 1GB ram and still keeping sound ???

https://ibb.co/6DgTT43
User avatar
adespoton
Forum All-Star
Posts: 3069
Joined: Fri Nov 27, 2009 5:11 am
Location: Emaculation.com
Contact:

Re: Screamer, 9.2.2 & Adventures with Sound

Post by adespoton »

Back when I was booting 9.2 on my iMac, any major video work meant the rest of the system slowed to a crawl. So we appear to be up to 2001 levels of compatibility.
MichaelKlaube
Inquisitive Elf
Posts: 29
Joined: Mon Nov 16, 2015 6:12 pm

Re: Screamer, 9.2.2 & Adventures with Sound

Post by MichaelKlaube »

I have no sound on Catalina with Qemu-4.2.5-sound-build downloaded from here.
My guest ist Mac OS 9.2.1 with Quicktime 5.
My command is:

../Qemu-4/qemu-system-ppc \
-monitor stdio \
-L pc-bios \
-M mac99,via=pmu \
-m 256 \
-rtc base=localtime \
-device VGA,edid=on \
-netdev user,id=network0 \
-device sungem,netdev=network0 \
-k de \
-usb \
-device usb-mouse \
-device usb-kbd \
-device usb-audio \
-drive format=raw,media=disk,file="Mac OS HD.img" \
-boot c

is the QuickTime version the problem?
MichaelKlaube
Inquisitive Elf
Posts: 29
Joined: Mon Nov 16, 2015 6:12 pm

Re: Screamer, 9.2.2 & Adventures with Sound

Post by MichaelKlaube »

I have Virtual Memory on.
I can though see the Qemu USB Audio in the System Profiler and can choose it in the Sound Control Panel.

When I play the Sound from the Scrapbook the System hangs.
User avatar
Cat_7
Expert User
Posts: 5020
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Re: Screamer, 9.2.2 & Adventures with Sound

Post by Cat_7 »

Hi,

No, QuickTime is not the problem. You should not use -device usb-audio. Usb support is known to be flaky, certainly with Mac OS 9.0 and some 10.x -device usb-audio is known to hang or only play sound for a few seconds. Just let Qemu use your default audio device in macOS.
Btw: your command line can be simplified, so some suggestions are:

The network defaults to user mode with the sungem device, so these 2 lines are not strictly needed.
-netdev user,id=network0 \
-device sungem,netdev=network0 \

When using mac99,via=pmu, usb support and the usb devices mouse and kbd are activated by default. It is best to keep the usb configuration to a minimum. So all of the 4 lines below can be removed:
-usb \
-device usb-mouse \
-device usb-kbd \
-device usb-audio \

Best,
Cat_7
MichaelKlaube
Inquisitive Elf
Posts: 29
Joined: Mon Nov 16, 2015 6:12 pm

Re: Screamer, 9.2.2 & Adventures with Sound

Post by MichaelKlaube »

Ok! I stripped the bad arguments.
But still no sound((
(Same applies to my Mac OS X Qemu VMs.)
I don't see the Audio Device in the System Profiler or System Settings.
I don't see the "spatializer audio laboratories" item.
I go crazy.
MichaelKlaube
Inquisitive Elf
Posts: 29
Joined: Mon Nov 16, 2015 6:12 pm

Re: Screamer, 9.2.2 & Adventures with Sound

Post by MichaelKlaube »

This is my Command:

../Qemu-4/qemu-system-ppc \
-monitor stdio \
-L pc-bios \
-M mac99,via=pmu \
-m 128 \
-rtc base=localtime \
-device VGA,edid=on \
-k de \
-drive format=raw,media=disk,file="Mac OS HD.img" \
-boot c
User avatar
Cat_7
Expert User
Posts: 5020
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Re: Screamer, 9.2.2 & Adventures with Sound

Post by Cat_7 »

If you don't see the spatializer, that indicates you are using a non-screamer enabled openbios-ppc file. Did you perhaps mix up various pc-bios folders?

You can use the one from our latest screamer download.

Best,
Cat_7
MichaelKlaube
Inquisitive Elf
Posts: 29
Joined: Mon Nov 16, 2015 6:12 pm

Re: Screamer, 9.2.2 & Adventures with Sound

Post by MichaelKlaube »

Thanks! This brought me to an idea: I was wondering about the date of the OpenFirmware which told me the 19th of October 2019))) So in the end I had an old Qemu installation from Homebrew installed))) Stupid me! So It works now perfectly!!! Really appreciate your work and patience!!!
QuestForTori
Space Cadet
Posts: 1
Joined: Sat Jun 27, 2020 9:48 pm

Re: Screamer, 9.2.2 & Adventures with Sound

Post by QuestForTori »

Hello! I'm also having issues with audio in Screamer. I compiled QEMU myself using this guide:

https://www.jamesbadger.ca/2018/11/07/e ... with-qemu/

And whenever a sound plays, it is incredibly distorted and bass-boosted, but it does technically output audio. Is there anyone else who managed to fix this issue when running Screamer in Catalina?

(Also on an unrelated note is there a good way to share your actual computer hard drive, similar to what Sheepshaver does?)
Post Reply