Need Help Installing Mac OS X 10.4 Tiger into QEMU

About QEMU, a PPC Mac emulator for Windows, macOS and Linux that can run Mac OS 9.0 up to Mac OS X 10.5

Moderators: Cat_7, Ronald P. Regensburg

Post Reply
shiggitay
Space Cadet
Posts: 7
Joined: Mon Apr 17, 2017 3:57 pm

Need Help Installing Mac OS X 10.4 Tiger into QEMU

Post by shiggitay »

Hey all. I've had good luck installing Mac OS X 10.0-10.3 into QEMU for a project I'm doing, but I wanted to see the limits of it all and also install 10.4 Tiger. I of course know it and Leopard are the last PowerPC OS X releases ever made, as a year later it was also released for Intel CPUs, but I'd like to have it in QEMU because I ripped my own physical copy of it and it'd be cool to have handy.

Here's my command line:

./qemu-system-ppc -bios ./openbios-qemu-vga.elf -boot d -M mac99 -m 256 -prom-env 'auto-boot?=true' -drive file=/Volumes/Rin/Qemu\ v2.8\ PPC/10.4\ Tiger/tiger.iso,format=raw,media=cdrom -drive file=tiger_10.4.0.raw,format=raw,media=disk

Each time I go to launch that QEMU's console complains that it can't load up/init. What am I doing wrong there? I'm using cat_7's 2.8pre-vga build, of which with 10.0-10.3 installed with little issues.

Thanks,
Shiggitay

EDIT: I'm going to try the Qemu_28pre-vga-OSX-Leopard-wip-11082016 build.

EDIT 2: Nope not working.
User avatar
Cat_7
Expert User
Posts: 5103
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Re: Need Help Installing Mac OS X 10.4 Tiger into QEMU

Post by Cat_7 »

What is the exact error you get?

Do you have spaces in your path to the iso?
Writing it out in full or putting it between " " might help.

Best,
Cat_7
shiggitay
Space Cadet
Posts: 7
Joined: Mon Apr 17, 2017 3:57 pm

Re: Need Help Installing Mac OS X 10.4 Tiger into QEMU

Post by shiggitay »

Cat_7 wrote:What is the exact error you get?

Do you have spaces in your path to the iso?
Writing it out in full or putting it between " " might help.

Best,
Cat_7
it's the "No valid state has been set by load or init-program" error.
User avatar
Cat_7
Expert User
Posts: 5103
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Re: Need Help Installing Mac OS X 10.4 Tiger into QEMU

Post by Cat_7 »

Ah, then perhaps you didn't rip the cd/dvd properly.

Best,
Cat_7
shiggitay
Space Cadet
Posts: 7
Joined: Mon Apr 17, 2017 3:57 pm

Re: Need Help Installing Mac OS X 10.4 Tiger into QEMU

Post by shiggitay »

Cat_7 wrote:Ah, then perhaps you didn't rip the cd/dvd properly.

Best,
Cat_7
Ah. What's the best way to do that? I used Disk Utility and made it a CD/DVD Master. I'll try dd next.

EDIT: Using dd worked a charm! 10.4 Tiger now installing! Thanks anyway.

EDIT 2: 10.4 installed just fine, but now I can't boot it up... My command line looks fine.... What can I do?
Bon_Glung
Student Driver
Posts: 21
Joined: Wed Aug 29, 2012 5:23 am

Re: Need Help Installing Mac OS X 10.4 Tiger into QEMU

Post by Bon_Glung »

Thanks for all your work so far. I have been having trouble running OSX 10.4.7 in QEMU on my Late 09 iMac in Sierra.

So far I have been able to boot the install disk image and install onto my HD image. I can mount the disk image with Sierra and see all the files have been installed, but I can't figure how to boot it and complete the setup.... The qemu.command file is:

cd "$(dirname "$0")"

./qemu-system-ppc -bios ./openbios-qemu-screamer.elf -boot c -M mac99 -m 256 -prom-env 'auto-boot?=true' -prom-env 'boot-args=-v' -prom-env 'vga-ndrv?=true' -drive file=./40gigs.img,format=raw,media=disk -drive file=./Mac_Os_X_10.4_Tiger_For_Intel.iso,format=raw,media=cdrom

I get QEMU to partially start, but I get this message:

Welcome to OpenBIOS v 1.1 built on May 19 2017 12:06
Trying hd:.\\:tbx1...
No valid state has been set by load or init-program

0 >

I just noticed the Terminal file qemu.command-80x24 file says (over and over):

coreaudio: Could not lock voice for audioDeviceIOProc
Reason: Invalid argument

It is tantalising to be so close... Any ideas?
iMac 21.5-inch, Late 2009, 3.06 GHz Intel Core 2 Duo, 8 GB RAM. OS X 10.12.6
mcayland
Granny Smith
Posts: 113
Joined: Sun Nov 01, 2015 10:33 pm

Re: Need Help Installing Mac OS X 10.4 Tiger into QEMU

Post by mcayland »

shiggitay wrote:Ah. What's the best way to do that? I used Disk Utility and made it a CD/DVD Master. I'll try dd next.

EDIT: Using dd worked a charm! 10.4 Tiger now installing! Thanks anyway.

EDIT 2: 10.4 installed just fine, but now I can't boot it up... My command line looks fine.... What can I do?
If you're using the command line you gave above you'll need to change "-boot d" to "-boot c" after installation otherwise QEMU will try and boot from the non-existent CDROM.
User avatar
Cat_7
Expert User
Posts: 5103
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Re: Need Help Installing Mac OS X 10.4 Tiger into QEMU

Post by Cat_7 »

Hi,

I'm assuming that Mac_Os_X_10.4_Tiger_For_Intel.iso is in fact a Tiger for PPC dvd image?
You say you have been able to install onto the 40gigs.img and the only thing that happens is that you cannot boot from that hard disk image?

Did you format/partition the 40gigs.img during installation of Tiger? How did you create that image file?

I see you are running with the openbuild-qemu-screamer with sound support. Can you try the default build from 19-05 with the openbios that came with that build? The openbios-qemu-screamer can only be used with the qemu build with which it came. You cannot simple mix these components as they often depend on each other.

Best,
Cat_7
Bon_Glung
Student Driver
Posts: 21
Joined: Wed Aug 29, 2012 5:23 am

Re: Need Help Installing Mac OS X 10.4 Tiger into QEMU

Post by Bon_Glung »

Cat_7 wrote:Hi,

I'm assuming that Mac_Os_X_10.4_Tiger_For_Intel.iso is in fact a Tiger for PPC dvd image?
Yes. It's a binary installer. (I got it from the internet.....)
You say you have been able to install onto the 40gigs.img and the only thing that happens is that you cannot boot from that hard disk image?

Did you format/partition the 40gigs.img during installation of Tiger? How did you create that image file?
I made the new blank image with Sierra Disk Utility as Mac OS Extended (Journalled). Info says it is NDIF Disk Image. Then used Sheepshaver to initialise and format as HFS+. Tiger installer could see that, and installed normally. Asks for a restart, and that is as far as I get. (Shutdown, modify qemu.command to d and changed order of disks.) I can mount and see the files are all there in Sierra.
I see you are running with the openbuild-qemu-screamer with sound support. Can you try the default build from 19-05 with the openbios that came with that build? The openbios-qemu-screamer can only be used with the qemu build with which it came. You cannot simple mix these components as they often depend on each other.
Ok. I went right to the beginning with 19-05 version. I made a new HD image with Sierra's Disk Utility then initialled and reformatted it in Sheepshaver to HFS+. A few small edits to the qemu.command file.

After starting QEMU the OSX Installer appears. I chose Erase and Install the 40gig.dmg disk as HFS+ (Journalled) from the OSX Tiger installer Options... menu when prompted for the destination. That was a bit different from my earlier attempt.

The actual installation went smoothly. It took ages! At the end a restart is automatic, and returns to the installer disk. Startup Disk sees the new system and set. Restart returns to the installer (as expected). Shutdown QEMU. A check of the 40gigs.dmg shows the files are there.

So then I edit qemu.command:

#!/bin/bash
cd "$(dirname "$0")"

./qemu-system-ppc -boot c -M mac99 -m 256 -prom-env 'auto-boot?=true' -prom-env 'vga-ndrv?=true' -drive file=./40gigs.dmg,format=raw,media=disk -drive file=./Mac_Os_X_10_4_Tiger_For_Intel.iso,format=raw,media=cdrom

It won't boot. QEMU says:

Welcome to OpenBIOS v1.1 built on May1 2017 13:14
Trying hd:\\:thxi...
Trying hd:\\:.\ppc\bootinfo.txt...
Trying hd:.%BOOT...
No valid state has been set by load or init-program

o>

So close.....
iMac 21.5-inch, Late 2009, 3.06 GHz Intel Core 2 Duo, 8 GB RAM. OS X 10.12.6
User avatar
Cat_7
Expert User
Posts: 5103
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Re: Need Help Installing Mac OS X 10.4 Tiger into QEMU

Post by Cat_7 »

Hi,

Somehow you disk image doesn't become bootable for qemu.
My suggestion is to leave out the step of formatting the disk in SheepShaver. Just make an image, add it to the command line for qemu and use disk utility from the Tiger installer to partition and format the disk.

Did you follow our guide for the creation of the image? http://www.emaculation.com/doku.php/ppc ... iskutility

Best,
Cat_7
Bon_Glung
Student Driver
Posts: 21
Joined: Wed Aug 29, 2012 5:23 am

Re: Need Help Installing Mac OS X 10.4 Tiger into QEMU

Post by Bon_Glung »

Thanks again. Your advice about the disk image solved my puzzle.

I made a new disk image in Sierra's Disk Utility and repeated the full install from the beginning. After changing d to c, and disk order in qemu.command, then restart, the hd image booted to the setup and registration utility.

The same qemu.command file and hd image started the experimental 6-07 Screemer build as well. I like the resolution switching.
iMac 21.5-inch, Late 2009, 3.06 GHz Intel Core 2 Duo, 8 GB RAM. OS X 10.12.6
Bon_Glung
Student Driver
Posts: 21
Joined: Wed Aug 29, 2012 5:23 am

Re: Need Help Installing Mac OS X 10.4 Tiger into QEMU

Post by Bon_Glung »

So, how can I get internet networking from the host machine? Running Sierra with wifi. OSX 10.4 networking doesn't know about wifi yet?

Sorry to seem such a newb....
iMac 21.5-inch, Late 2009, 3.06 GHz Intel Core 2 Duo, 8 GB RAM. OS X 10.12.6
Bon_Glung
Student Driver
Posts: 21
Joined: Wed Aug 29, 2012 5:23 am

Re: Need Help Installing Mac OS X 10.4 Tiger into QEMU

Post by Bon_Glung »

Bon_Glung wrote:So, how can I get internet networking from the host machine? Running Sierra with wifi. OSX 10.4 networking doesn't know about wifi yet?

Sorry to seem such a newb....
No worries. I got it going somehow. QEMU is using the internal ethernet system. (I couldn't see a way to get wifi going....)

Excellent!
iMac 21.5-inch, Late 2009, 3.06 GHz Intel Core 2 Duo, 8 GB RAM. OS X 10.12.6
User avatar
adespoton
Forum All-Star
Posts: 3105
Joined: Fri Nov 27, 2009 5:11 am
Location: Emaculation.com
Contact:

Re: Need Help Installing Mac OS X 10.4 Tiger into QEMU

Post by adespoton »

Bon_Glung wrote:So, how can I get internet networking from the host machine? Running Sierra with wifi. OSX 10.4 networking doesn't know about wifi yet?

Sorry to seem such a newb....
You need to add

Code: Select all

  -netdev user,id=vlan0 -device sungem,netdev=vlan0 
Then it should automatically detect a new PCI Ethernet device which is proxied through the host OS. It doesn't need to know that it's a WiFi card on the other side.
Bon_Glung
Student Driver
Posts: 21
Joined: Wed Aug 29, 2012 5:23 am

Re: Need Help Installing Mac OS X 10.4 Tiger into QEMU

Post by Bon_Glung »

Thanx. That worked.
iMac 21.5-inch, Late 2009, 3.06 GHz Intel Core 2 Duo, 8 GB RAM. OS X 10.12.6
Post Reply