Mac OS 9.2.2 installation doesn't start

About QEMU, a PPC Mac emulator for Windows, macOS and Linux that can run Mac OS 9.0 up to Mac OS X 10.5

Moderators: Cat_7, Ronald P. Regensburg

Post Reply
User avatar
macplus
Inquisitive Elf
Posts: 31
Joined: Sat Feb 04, 2017 5:12 am
Location: Argentina

Mac OS 9.2.2 installation doesn't start

Post by macplus »

When I start QEMU (following the steps of the guide) inside the window of QEMU, after a while, it says the following:
MacOS: unable to find a usable NVRAM partition - using offset 0x1400.
And it never begins the installation. What is the problem?
Compact Macs will rule supreme for all eternity! :twisted:
User avatar
Cat_7
Expert User
Posts: 5249
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Re: Mac OS 9.2.2 installation doesn't start

Post by Cat_7 »

Hi,

Which Qemu build are you trying? And what is your command line?

Best,
Cat_7
almeath
Granny Smith
Posts: 119
Joined: Mon Jul 18, 2005 5:42 am
Location: Australia

Re: Mac OS 9.2.2 installation doesn't start

Post by almeath »

I was able to install MacOS 9.2.1 but I get the same NVRAM partition error every time QEMU boots up.

The MacOS will still proceed to startup and run normally, but I am wondering if there is a way to stop this error occurring?

The terminal produces the following:

Trying to write invalid spr 0 (0x000) at 00f113c0
Trying to read invalid spr 0 (0x000) at 00f113c8
Trying to write privileged spr 955 (0x3bb) at 00f164b8
Trying to write invalid spr 959 (0x3bf) at 00f16520
Trying to read invalid spr 959 (0x3bf) at 00f16528
Trying to write privileged spr 955 (0x3bb) at 00f164b8
Trying to write invalid spr 959 (0x3bf) at 00f16520
Trying to read invalid spr 959 (0x3bf) at 00f16528

I get the same errors in both the latest official build 16-09-2017 and also the experimental build 06-07-2017
zoinho
Space Cadet
Posts: 1
Joined: Fri Jan 26, 2018 12:53 pm

Re: Mac OS 9.2.2 installation doesn't start

Post by zoinho »

almeath wrote:I was able to install MacOS 9.2.1 but I get the same NVRAM partition error every time QEMU boots up.

The MacOS will still proceed to startup and run normally, but I am wondering if there is a way to stop this error occurring?

The terminal produces the following:

Trying to write invalid spr 0 (0x000) at 00f113c0
Trying to read invalid spr 0 (0x000) at 00f113c8
Trying to write privileged spr 955 (0x3bb) at 00f164b8
Trying to write invalid spr 959 (0x3bf) at 00f16520
Trying to read invalid spr 959 (0x3bf) at 00f16528
Trying to write privileged spr 955 (0x3bb) at 00f164b8
Trying to write invalid spr 959 (0x3bf) at 00f16520
Trying to read invalid spr 959 (0x3bf) at 00f16528

I get the same errors in both the latest official build 16-09-2017 and also the experimental build 06-07-2017
Still "Mac OS 9.2.2 installation doesn't start" ? For me too
User avatar
adespoton
Forum All-Star
Posts: 3245
Joined: Fri Nov 27, 2009 5:11 am
Location: Emaculation.com
Contact:

Re: Mac OS 9.2.2 installation doesn't start

Post by adespoton »

The NVRAM partition error and the invalid spr errors don't prevent the image from booting. The NVRAM error ALWAYS displays itself. The SPR ones are related to audio builds IIRC.

But all of this made me wonder: are you using a DVD-image, or might it be a compressed image? If it's compressed, it won't boot.

I had similar issues when attempting to boot from a block device in any of the 2017 builds; it would get to that point, or part way into the boot welcome screen, and then everything would lock up. Switching to an uncompressed disk image, using the USB keyboard flag and the ADB mouse did the trick and allowed me to boot to the installer, and then allowed me to fully install. My previous already-installed image wouldn't boot on these recent versions of QEMU because the virtual hardware had changed slightly.
User avatar
Cat_7
Expert User
Posts: 5249
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Re: Mac OS 9.2.2 installation doesn't start

Post by Cat_7 »

These errors are normal for every build.

We can't help with boot problems unless you provide the command line with which you start qemu.

Best,
Cat_7
Riskerdegree87
Space Cadet
Posts: 1
Joined: Fri Nov 02, 2018 1:54 pm

Re: Mac OS 9.2.2 installation doesn't start

Post by Riskerdegree87 »

help me Cat_7 i have problem in installing Mac OS 9.0.4 in qemu

Code: Select all

Unable to find a usable NVRAM partition - using offset 0x1400
however my command line is:

sudo qemu-system-ppc -boot d -M mac99 -m 512 -prom-env 'auto-boot?=true' -prom-env 'boot-args=-v' -prom-env 'vga-ndrv?=true' -drive file='/home/alireza/Downloads/mac9.iso',format=raw,media=cdrom -drive file='/home/alireza/shit.qcow2',format=raw,media=disk -device usb-mouse -device usb-kbd -d fpu -monitor stdio

it was stops after this error shown in openbios
but.. i have qemu-3.0.0 rc0 and my laptop is 2760p:

Kubuntu - ubuntu 18.10 with sddm
7963 GB ram
corei 5 intel SandyBridge Mobile (tablet pc)
Chipset: hp-core/can7.5 update 2018

my debug resaults after this error is:

WARNING: Trying to write invalid spr 0 (0x000) at 00f110b4
WARNING: Trying to read invalid spr 0 (0x000) at 00f110bc
User avatar
adespoton
Forum All-Star
Posts: 3245
Joined: Fri Nov 27, 2009 5:11 am
Location: Emaculation.com
Contact:

Re: Mac OS 9.2.2 installation doesn't start

Post by adespoton »

As mentioned above, the NVRAM errors and SPR errors shouldn't affect emulation. I'd recommend removing the USB mouse flag. Everything else in the command line looks good to me; someone else may spot something further.
User avatar
generalkenobi
Space Cadet
Posts: 3
Joined: Mon Aug 12, 2019 12:08 am

Re: Mac OS 9.2.2 installation doesn't start

Post by generalkenobi »

Hi all, new guy here.

So I'm trying to install Mac OS X Developer Preview 3 under Mac OS 9.2.2. After a fresh install using the following command line arguments

Code: Select all

PS H:\ISO\Mac\DP3> .\Start-Qemu.ps1 -hdd_image machd.dsk -cdrom_image .\MacOSX_developer_preview_3.iso -debug_instance
qemu-system-ppc.exe -bios openbios-ppc -L pc-bios -boot c -g 1280x720x32 -m 512 -M mac99 -cpu G3 -netdev user,id=network01 -device sungem,netdev=network01 -prom-env "auto-boot?=true" -sdl -prom-env "vga-ndrv?=true" -drive "file=machd.dsk,format=raw,media=disk" -drive "file=.\MacOSX_developer_preview_3.iso,format=raw,media=cdrom" -usb -device usb-mouse
I end up getting the same error.
MacOS: unable to find a usable NVRAM partition - using offset 0x1400
Is there a fix for this? Am I missing a required parameter to create NVRam? Because when I try to run the Mac OS X installer through Mac OS 9.2.2, I get the following error:

Image

I hope I'm just missing something in my arguments.

Thank you!
General Kenobi
- Super hero facedesk!
User avatar
Cat_7
Expert User
Posts: 5249
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Re: Mac OS 9.2.2 installation doesn't start

Post by Cat_7 »

Hi,

This is to be expected. Take some hints from here and adapt step 2 to your situation:
https://wiki.qemu.org/Documentation/Pla ... rver_1.2v3

Best,
Cat_7
vlad557776
Tinkerer
Posts: 91
Joined: Thu May 30, 2019 7:06 am

Re: Mac OS 9.2.2 installation doesn't start

Post by vlad557776 »

General Kenobi, just run the installer from CD-ROM and find the command line somewhere at my old topics.
User avatar
generalkenobi
Space Cadet
Posts: 3
Joined: Mon Aug 12, 2019 12:08 am

Re: Mac OS 9.2.2 installation doesn't start

Post by generalkenobi »

After taking Cat_7's advice, I carefully paid attention to Step 2's instructions and with a little tweaking of my script, I am able to get the installer to boot!

I deeply thank you! Let's hope it installs correctly. :smile:
General Kenobi
- Super hero facedesk!
Post Reply