Basilisk error on Mac OsX 10.14.5
Page 1 of 1

Author:  Evk [ Fri Jun 21, 2019 8:52 pm ]
Post subject:  Basilisk error on Mac OsX 10.14.5


I followed the instructions on https://www.emaculation.com/doku.php/basiliskii_osx_setup page, but the program presents this error message: "Could not start Basiliskii (No such file or directory)"
How is possible? Any suggest?

Author:  amfritz [ Tue Jul 02, 2019 7:02 pm ]
Post subject:  Re: Basilisk error on Mac OsX 10.14.5

I have the exact same issue. I have followed all the steps at https://www.emaculation.com/doku.php/ba ... _osx_setup to a T, and i get the same error message. Opening the BasilikII file (not the GUI) i get the flashing ? on the disk in the emulated system.

Please help with some expertise.

Author:  adespoton [ Tue Jul 02, 2019 7:16 pm ]
Post subject:  Re: Basilisk error on Mac OsX 10.14.5

Which version of Basilisk II are you using? The SDL2 one? If so, you don't need to worry about Retina in the docs.
To start, you need to have some files in your BasiliskII folder:

The BasiliskII application, the actual emulator: http://ronaldpr.home.xs4all.nl/basilisk ... 190504.zip

The BasiliskIIGUI application, to be used for setting up and configuring BasiliskII. (I think it's also in that archive?)

A floppy disk image to boot the Mac. Download it. Unzip the file, and lock it. Select “Get Info” and check the “Locked” box. Use only this floppy image. System 7/7.5 floppy images will make you run into problems later during the installation process, because they don't allow the shared folder to appear on the desktop, see below.

A compatible ROM file. Basilisk II will not run without a compatible ROM file. If BasiliskII does not find a compatible ROM file, it will immediately quit on launch. It may be difficult to get a hold of a compatible ROM file as distributing bare ROM files violates Apple license agreements. ROM files from Quadra and Performa machines work best. Google “redundant robot sheepshaver” for downloads. A total list of ROMs and their compatibility status is here: https://docs.google.com/spreadsheets/d/ ... Dk7QDyKPY/

A keycodes file. The keycodes file is not necessary if you are using a US English QWERTY keyboard layout. This is included in the archive.

A folder shared between OSX and BasiliskII. I prefer a folder in /Users/Shared/ so we don't have permissions issues.

If you get to the flashing ? then you've got the emulator running, the ROM loaded, but do not have a bootable disk image in the preferences (Volumes tab in the GUI).

If you are getting "Could not start Basiliskii", then you're trying to start from the GUI, and it can't find the BasiliskII application. Make sure they're in the same folder.

Author:  amfritz [ Wed Jul 03, 2019 8:46 am ]
Post subject:  Re: Basilisk error on Mac OsX 10.14.5

I am running Basilisk II 1.0, SDL2 port...the one that was linked in the steps, and which you quoted. I didn't mess about with the Retina stuff anyway.

I was able to complete all of the initial set-up (steps BEFORE "Inside Mac OS") with no issue. I got into the Mac OS7 system and did all of the file copying, per the steps, without any issue.

When i got to the "FInishing" steps, I also followed them exactly, removing the two disks specified and changing the mac model id as indicated. When i click start, there is no "Voila" - just the error message. If i change the mac model id BACK to what it was before the "Finishing" steps, that is when it loads with the flashing ?

As far as i can tell, i have put all the files required in the necessary locations and configured everything as it should be. I've got screenshots, but dont know how to attach them here.

ULtimately, I am doing all this just to show my kids Power Pete, so it is a lot of work for a game, lol.

Thanks :)

Author:  24bit [ Wed Jul 03, 2019 9:55 am ]
Post subject:  Re: Basilisk error on Mac OsX 10.14.5

Not sure what went wrong on your side.
You will only need the emulator app, Mac ROM and a bootable volume.
As you seem to have the first two, maybe try this boot volume:

You may inflate Power_Pete.sit on your Mac with TheUnarchiver.
http://macintoshgarden.org/games/power- ... ighty-mike
Move it to your shared folder (Unix on the emulator side) and to your emulated Mac´s HDD from within Basilisk II.
That should be enough to demonstrate game play.
The emulated Mac model does not matter, as installation was done "For every Mac".
Some error requesters may pop up therefore, just click OK to close them.

Author:  amfritz [ Wed Jul 03, 2019 11:42 am ]
Post subject:  Re: Basilisk error on Mac OsX 10.14.5

Thanks for the continued assistance. Unfortunately I am at the limit of my abilities, so I am not clear on what I need to do with this new boot volume. ??

Where in the process am I doing something with this boot disk? I don't see any steps that correspond to a file like that, so i don't know what or how to swap it out. How am I modifying the completed set-up per the configuration steps to incorporate this additional/replacement file?

Many thanks, again. :)

Author:  Ronald P. Regensburg [ Wed Jul 03, 2019 2:09 pm ]
Post subject:  Re: Basilisk error on Mac OsX 10.14.5

Forget the setup guide procedure. This MacOS753.dsk is an installed 7.5.3 System. You can use it in place of the disk image on which you installed the system (in case that installation was not completed successfully).

Add the "MacOS753.dsk" file to the folder with BasiliskII.

If you followed the setup guide, in the volumes list in the GUI application you should have only the path to "MacOS753". Remove that one from the list and instead add the path to "MacOS753.dsk" to the list. Click Save and click Start. If clicking Start does not work, quit the GUI application and launch BasiliskII directly.

Author:  adespoton [ Wed Jul 03, 2019 4:22 pm ]
Post subject:  Re: Basilisk error on Mac OsX 10.14.5

If you're just trying to demo Power Pete, might I suggest demoing Mighty Mike instead? That's what they changed the name to after the owners of Powerful Pete sent them a C&D. Same game, includes bugfixes, runs on more modern hardware.

Author:  amfritz [ Fri Jul 05, 2019 3:54 pm ]
Post subject:  Re: Basilisk error on Mac OsX 10.14.5

Thank you, thank you, thank you!!

That worked!!! :)

I still get the error if i try to run from the GUI, but if i just open the BasiliskII file, it opens perfectly and the game ran without any issues.

Have a fantastic weekend!

Author:  ejgw [ Sun Jul 21, 2019 10:27 am ]
Post subject:  Re: Basilisk error on Mac OsX 10.14.5

I'm getting the same error. I've tried adding the .dsk file to the BasiliskII folder and using that instead, but it still doesn't work. When I try to open the BasilikII app, it just closes immediately. Everything is in the same folder.

I have checked all the instructions three times and followed them all but I still can't get it to work. Does anyone have any other ideas?

Author:  Ronald P. Regensburg [ Sun Jul 21, 2019 12:28 pm ]
Post subject:  Re: Basilisk error on Mac OsX 10.14.5

Just do not use the "Start" button. After configuration in the GUI, click "Save" and launch BasiliskII directly. You will need the GUI only for setting or changing settings. (There seems to be an incompatibility between usual settings with often relative paths and the fact that the Start button only works when all paths are absolute.)

If BasiliskII quits on launch, then you probably have no compatible rom file or the path to the rom file is not configured correctly.

I've tried adding the .dsk file to the BasiliskII folder

Which file? As far as I can see, nowhere in the BasiliskII for MacOSX setup guide is a .dsk file mentioned.

Author:  emendelson [ Sun Jul 21, 2019 2:16 pm ]
Post subject:  Re: Basilisk error on Mac OsX 10.14.5

Or you might try searching "Mac OS 9 for OS X/macOS" - which will take you to a page with a link to a complete BasiliskII system that runs System 7.6.1.

That page is mostly about a SheepShaver system that runs OS 9, but it ALSO has a BasiliskII-based system that runs 7.6.1.

Author:  ejgw [ Sun Jul 21, 2019 3:41 pm ]
Post subject:  Re: Basilisk error on Mac OsX 10.14.5

Aha! I downloaded the Quadra 900 ROM from https://www.redundantrobot.com/sheepshaver.html but it doesn't seem to work. Now I have tried with the Performa ROM and it works fine. Thanks a lot for the nudge!

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group