Compiling Basilisk II on x86-64 with Fedora 31

About BasiliskII, a 68k Mac emulator for Windows, MacOSX, and Linux that can run System 7.x through MacOS 8.1.

Moderators: Cat_7, Ronald P. Regensburg

Post Reply
MadEmperorYuri
Space Cadet
Posts: 1
Joined: Sat Nov 16, 2019 10:22 pm

Compiling Basilisk II on x86-64 with Fedora 31

Post by MadEmperorYuri »

Hey guys,

I'm new to emulation and relatively inexperienced with low-level programming languages and building from source. And actually, I'm pretty new to Linux as well. So when I run into problems, it's not obvious to me which area of my knowledge is the deficient one to deal with.

I know helping newcomers is never thrilling, so I thank you in advance for you help. I will take care to keep detailed notes and, when we achieve success, put together a detailed summary so that future readers can easily skip to the good parts.

So, here's my starting point:
I have done the following:

1. Cloned the repository from GitHub to a local directory

Code: Select all

$ git clone https://github.com/cebix/macemu.git


2. Ran autogen.sh (which failed)

Code: Select all

$ cd macemu/BasiliskII/src/Unix
$ ./autogen.sh
This failed, informing me that I needed autoconf installed.



3. Installed autoconf and automake

I added automake for good measure. I installed both packages using dnfdragora, which can be installed using Fedora's graphical Software tool for everyday users. This commands is equivalent, however:

Code: Select all

$ sudo dnf install autoconf automake


4. Ran autogen.sh (which failed differently than before)

Code: Select all

$ pwd
.../macemu/BasiliskII/src/Unix
$ ./autogen.sh
This failed, with the following abridged output:

Code: Select all

 + Running aclocal: done.
 + Running autoheader: done.
 + Running autoconf: done.
 + Running 'configure ':
   ** If you wish to pass arguments to ./configure, please
   ** specify them on the command line.
checking for gcc... gcc
...
checking for X... no
configure: error: You need X11 to run Basilisk II.


5. Installed libX11-devel

I googled for "checking for X... no" and found a couple of helpful links. First, I found someone with a similar problem on Ubuntu. Then I found someone with a similar problem on Fedora.

:!: I noticed that the name of the required package was different depending on the Linux distribution. So, non-Fedora users, try googling with the name of your own distribution.

So next I did:

Code: Select all

$ sudo dnf install libX11-devel


6. Ran autogen.sh (which succeeded!)

Code: Select all

$ ./autogen.sh
...
Basilisk II configuration summary:

Mac OS X GUI ........................... : no
Mac OS X Sound ......................... : no
SDL support ............................ : none
BINCUE support ......................... : no
LIBVHD support ......................... : no
VDE support ............................ : no
XFree86 DGA support .................... : no
XFree86 VidMode support ................ : no
fbdev DGA support ...................... : yes
Enable video on SEGV signals ........... : no
ESD sound support ...................... : no
GTK user interface ..................... : no
mon debugger support ................... : yes
Running m68k code natively ............. : no
Use JIT compiler ....................... : no
JIT debug mode ......................... : no
Floating-Point emulation core .......... : IEEE fpu core
Assembly optimizations ................. : x86-64
Addressing mode ........................ : memory banks
Bad memory access recovery type ........ :

Configuration done. Now type "make" (or "gmake").


7. Ran make (which failed spectacularly)

Running make produced about 1,150 lines of error messages. Way too much copypaste here. I saved the output to a file using:

Code: Select all

$ make > ~/output.txt 2>&1
I have uploaded the contents of this file.

:arrow: So this is where I'm currently stuck. I'm suspecting that more development packages must be installed, but I do not know how to determine which ones. I would prefer to install only those packages that I need, but I understand that the best solution may be to install all packages in an appropriate package group.

Should I do that with the "C Development Tools and Libraries" package group in dnfdragora? Or is there something else I should be doing?

Thanks very much.
Jorpho
Master Emulator
Posts: 368
Joined: Fri Sep 17, 2004 4:22 am

Re: Compiling Basilisk II on x86-64 with Fedora 31

Post by Jorpho »

"You lose". What a jolly little message.

I'm not sure what you've Googled, but https://github.com/cebix/macemu/issues/168 suggests you need to disable the JIT compiler on 64-bit machines.
User avatar
rickyzhang
Mac Mechanic
Posts: 197
Joined: Mon Sep 15, 2014 7:59 pm

Re: Compiling Basilisk II on x86-64 with Fedora 31

Post by rickyzhang »

Check out the Travis CI yaml file I wrote in upstream. You can get help from build instructions.
There is an App for that!
https://github.com/rickyzhang82
Post Reply