Login  •  Register


The time is now: Mon Jul 06, 2020 8:48 am

Emaculation wiki  •  Delete all board cookies



Post new topic  Reply to topic Page 1 of 1 [ 3 posts ]
Print view Previous topic  |  Next topic
Author Message
PostPosted: Sat Dec 28, 2019 1:11 am 
Offline
Space Cadet

Joined: Sat Dec 28, 2019 1:08 am
Posts: 2
I'm running Basilisk II on linux and getting the following error about my ethernet...

Code:
Basilisk II V1.0 by Christian Bauer et al.
Reading ROM file...
selected Ethernet device type sheep_net
WARNING: Cannot open /dev/sheep_net (No such file or directory). Ethernet will not be available.


I'd really like to get MacTCP working. When I start Basilisk II, it see's my wifi device in the preference/options gui. I select it, and still get the error above.

Any ideas on how to tackle this problem?

Thanks


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Sat Dec 28, 2019 6:24 am 
Offline
Space Cadet

Joined: Sat Dec 28, 2019 1:08 am
Posts: 2
I found that I needed to load the sheep_net.ko module. Loading one that I found in these forums that was marked as for Ubuntu didn't work. I built a new sheep_net.ko from source, and then I had to go through some additional steps to sign it so that I could insmod it.

One question I have is... why don't I see an option for slirp in Basilisk II?

My second question is, what should my MacTCP settings be? I can't get anything to work. Here is the output of ifconfig for my wifi device in linux...

Code:
wlp63s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 172.20.7.10  netmask 255.255.240.0  broadcast 172.20.15.255
        inet6 fe80::bc3f:7369:c2fa:767c  prefixlen 64  scopeid 0x20<link>
        ether 00:e1:8c:74:a1:49  txqueuelen 1000  (Ethernet)
        RX packets 24898  bytes 13524631 (13.5 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 13828  bytes 2278169 (2.2 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0


resolve.conf shows my DNS to be: 127.0.0.53

What class should I be using? What about my gateway address? Will it matter if I'm connecting via a captive portal?

Thanks.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Sun May 31, 2020 1:55 pm 
Offline
Space Cadet

Joined: Sun May 31, 2020 1:48 pm
Posts: 2
Did you ever figure out what was going on with your setup? I have the same problems. "slirp" doesn't seem to be an option for me, although I can get Baslisk to boot if I type in 'Slirp' (with a a capital 'S') for some reason. I also compiled sheep_net from the source, but am unable to modprobe it...


Top
 Profile  
Reply with quote Post a reply  
Display posts from previous:  Sort by  
Post new topic  Reply to topic Page 1 of 1 [ 3 posts ]


Who is online

Users browsing this forum: No registered users and 13 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
 

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group