Trying to setup , Can not Open BasiliskIIGUI

About BasiliskII, a 68k Mac emulator for Windows, MacOSX, and Linux that can run System 7.x through MacOS 8.1.

Moderators: Cat_7, Ronald P. Regensburg

Post Reply
Chronos2086
Space Cadet
Posts: 2
Joined: Mon Mar 02, 2020 6:35 pm

Trying to setup , Can not Open BasiliskIIGUI

Post by Chronos2086 »

I'm following this Setup guide :
https://emaculation.com/doku.php/basilisk_ii_setup

But Basilisk II GUI will not Open i get the following "System Error" Messages :

"The code execution cannot proceed because libglib-2.0-0.dll was not found.reinstalling the program may fix this problem."

"The code execution cannot proceed because libgdk_pixbuf-2.0-0.dll was not found.reinstalling the program may fix this problem."

"The code execution cannot proceed because libgdk-win32-2.0-0.dll was not found.reinstalling the program may fix this problem."

Yes I Did install GTK +2 Runtime but i still get these Message's.
User avatar
Ronald P. Regensburg
Expert User
Posts: 6330
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: Trying to setup , Can not Open BasiliskIIGUI

Post by Ronald P. Regensburg »

On the BasiliskII for Windows download page: https://www.emaculation.com/forum/viewt ... f=6&t=5282
scroll down to Always start with this download. Did you do that download?
Chronos2086
Space Cadet
Posts: 2
Joined: Mon Mar 02, 2020 6:35 pm

Re: Trying to setup , Can not Open BasiliskIIGUI

Post by Chronos2086 »

Ronald P. Regensburg wrote:On the BasiliskII for Windows download page: https://www.emaculation.com/forum/viewt ... f=6&t=5282
scroll down to Always start with this download. Did you do that download?
yeah thats the first one i downloaded .

also i'm i on Windows 10 64bit if thats any help .
uabassguy
Space Cadet
Posts: 1
Joined: Sun Aug 30, 2020 8:32 am

Re: Trying to setup , Can not Open BasiliskIIGUI

Post by uabassguy »

To anyone else that may run into this, installing the gtk2 lib on windows fixed the issue https://sourceforge.net/projects/gtk-win/

The specific file I installed was gtk2-runtime-2.24.10-2012-10-10-ash.exe and chose the recommended options, and also selecting the the compat dlls during install.
Post Reply