New builds of BasiliskII for 10.4 Tiger?

About BasiliskII, a 68k Mac emulator for Windows, MacOSX, and Linux that can run System 7.x through MacOS 8.1.

Moderators: Cat_7, Ronald P. Regensburg

Post Reply
graphiteguy
Space Cadet
Posts: 7
Joined: Sat May 09, 2020 8:41 pm

New builds of BasiliskII for 10.4 Tiger?

Post by graphiteguy »

Is it possible to make a new BasiliskII build for 10.4 Tiger? I downloaded the source and tried to build it but couldn't complete the configure. I ran in to a number of errors that libraries were present but not usable. As I am not an experienced developer that means very little to me.

Does anyone know how or if this can be done with the current source? Perhaps there is a better 68k emulator for the G4 Macs I don't know of. I need MacOS 7.5 and 8.6. Neither works in the classic mode.
graphiteguy
Space Cadet
Posts: 7
Joined: Sat May 09, 2020 8:41 pm

Re: New builds of BasiliskII for 10.4 Tiger?

Post by graphiteguy »

graphiteguy wrote:Is it possible to make a new BasiliskII build for 10.4 Tiger?
Follow-up thought, I just noticed that Virtual ][ is a universal binary that runs on 10.4 and 10.13. A single binary that was universal would be very convenient.
User avatar
Ronald P. Regensburg
Expert User
Posts: 6330
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: New builds of BasiliskII for 10.4 Tiger?

Post by Ronald P. Regensburg »

I do not know if a build that will run in Tiger can be compiled from the current source.

My October 2009 build is a universal binary and should run fine in 10.4 Tiger, on both PPC and Intel. I am not sure it will also still run in macOS 10.13 High Sierra. I doubt anyone tried.
https://www.emaculation.com/forum/viewt ... 361#p47395
graphiteguy
Space Cadet
Posts: 7
Joined: Sat May 09, 2020 8:41 pm

Re: New builds of BasiliskII for 10.4 Tiger?

Post by graphiteguy »

Ronald P. Regensburg wrote:My October 2009 build is a universal binary and should run fine in 10.4 Tiger, on both PPC and Intel. I am not sure it will also still run in macOS 10.13 High Sierra.
I tried the 2009 build...and the other older variant builds. On high Sierra it produces a black screen and does nothing. On tiger it produces a grey screen and does nothing (spinning beach ball). I'm not getting to a flashing question mark on either.

Is it possible (compatibility wise) to build a statically linked binary on a newer MacOS to work backwards on 10.4? My attempts to build on Tiger have all failed. I haven't tried to build it on High Sierra but could do that if there is a way to make it backwards compatible.
User avatar
Ronald P. Regensburg
Expert User
Posts: 6330
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: New builds of BasiliskII for 10.4 Tiger?

Post by Ronald P. Regensburg »

The 2009 build used to work fine in Tiger on both PPC and Intel and it worked at least up to Snow Leopard. I do not know why it does not wok in Tiger for you. I am not surprised that it does not work in High Sierra.

At the time I built the 2009 build, one needed Snow Leopard to build for Tiger and later. The instructions are still in our wiki. In a number of later OSX versions it appeared to be not possible. And I doubt that it will now still work with the current source code.

Did you add a compatible ROM file and did you configure BasiliskII in the GUI application? If so, than please post here the content of the configured prefs file:
Launch Terminal (in /Application/Utilities/) and type at the prompt

Code: Select all

open ~/.basilisk_ii_prefs
followed by a return.
The file will open in your default text editor. Select all content and copy and paste it here in your reply.
graphiteguy
Space Cadet
Posts: 7
Joined: Sat May 09, 2020 8:41 pm

Re: New builds of BasiliskII for 10.4 Tiger?

Post by graphiteguy »

I have tried both a Quadra900 ROM and a IIci ROM (and the machine setting for each). I get the same result of a gray screen--never a flashing question mark. Both ROM files work on the 2020 build on High Sierra.

Code: Select all

extfs /Users/macuser/Desktop/basilliskii/unix
screen win/512/384
seriala <none>
serialb <none>
ether slirp
udptunnel false
udpport 6066
rom /Users/macuser/Desktop/basiliskii/IIci.ROM
bootdrive 0
bootdriver 0
ramsize 268435456
frameskip 6
modelid 5
cpu 3
fpu true
nocdrom false
nosound false
noclipconversion false
nogui false
jit false
jitfpu false
jitdebug false
jitcachesize 0
jitlazyflush false
jitinline false
keyboardtype 5
keycodes false
mousewheelmode 1
mousewheellines 3
dsp /dev/dsp
mixer /dev/mixer
ignoresegv true
idlewait false
User avatar
Ronald P. Regensburg
Expert User
Posts: 6330
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: New builds of BasiliskII for 10.4 Tiger?

Post by Ronald P. Regensburg »

Looks OK.
Performa or Quadra roms should work best. I never tried a IIci rom with BasiliskII.
My experience is that the rom file does not need to match the machine ID or cpu settings.

Do you run Tiger on a PPC or Intel machine?
graphiteguy
Space Cadet
Posts: 7
Joined: Sat May 09, 2020 8:41 pm

Re: New builds of BasiliskII for 10.4 Tiger?

Post by graphiteguy »

PPC G4. Tiger (10.4) is the last version for PPC with classic support. 10.5 is "universal" without classic environment and Snow Leopard (10.6) is intel only. The G4 won't run Snow Leopard so I don't have an environment to try building it. :???:

Not sure what's tripping it up. I took the config, rom, and disk images to the 2020 build on High Sierra and it works.
User avatar
Ronald P. Regensburg
Expert User
Posts: 6330
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: New builds of BasiliskII for 10.4 Tiger?

Post by Ronald P. Regensburg »

There were Tiger for Intel versions. Apple announced the transition to Intel x86 processors during Mac OS X 10.4 Tiger's lifetime, making it the first Apple operating system to work on Apple–Intel architecture machines. Indeed without Classic support.

I will see if I can bring my PowerBook G4 back to life again to see what could be your issue.
User avatar
adespoton
Forum All-Star
Posts: 3069
Joined: Fri Nov 27, 2009 5:11 am
Location: Emaculation.com
Contact:

Re: New builds of BasiliskII for 10.4 Tiger?

Post by adespoton »

Regarding the ROMs used, these are the notes I currently have for those ROMs:

Quadra 900: AppleTalk is not supported on Basilisk II. This is the worst known 1MB ROM.
IIci: In Basilisk, FPU must be enabled and AppleTalk is not supported. This is a 32-bit clean ROM. Boots System 4.1 - 7.6.1

That might help?
User avatar
Ronald P. Regensburg
Expert User
Posts: 6330
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: New builds of BasiliskII for 10.4 Tiger?

Post by Ronald P. Regensburg »

As far I can tell, the ROMs I have used for the past 15 years or so with BasiliskII, Performa.rom, Quadra.rom, and Quadra650.rom, are in fact identical files. They work with any of the model ID settings, with or without FPU enabled.
User avatar
Ronald P. Regensburg
Expert User
Posts: 6330
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: New builds of BasiliskII for 10.4 Tiger?

Post by Ronald P. Regensburg »

I revived my PowerBookG4 with Mac OS X 10.4.11 Tiger and used my October 2009 UB BasiliskII build on it. I started with the files I now use with current BasiliskII in Catalina on my iMac, files that I have been using for years through several OSX/macOS and BasiliskII versions.

This is what I found:
- The System 7.0.1 installation that I use on my Catalina iMac runs fine.
- Two 7.5.3 and two 7.5.5 installations that I use on my Catalina iMac begin to start up normally, up to showing the desktop background pattern, but the Finder does not load. I need to force quit BasiliskII. One of the 7.5.5 installations I tried was done in 2009, but used in the years after that.
- A new 7.5.3 installation, done in the October 2009 BasiliskII build, runs fine.

The cause? I can speculate, but I cannot be sure.

The solution seems to be to do a fresh System installation in the October 2009 build on Tiger.
User avatar
adespoton
Forum All-Star
Posts: 3069
Joined: Fri Nov 27, 2009 5:11 am
Location: Emaculation.com
Contact:

Re: New builds of BasiliskII for 10.4 Tiger?

Post by adespoton »

did you try tossing the NVRAM file? That's the exact symptoms I have with an NVRAM file populated by a different OS version.
graphiteguy
Space Cadet
Posts: 7
Joined: Sat May 09, 2020 8:41 pm

Re: New builds of BasiliskII for 10.4 Tiger?

Post by graphiteguy »

I have been putting different values in the config manually and skipping the GUI. I have narrowed my problem to the video configuration and the memory configuration.

Memory: Certain values cause the OS to crash for memory. Anything above 1132 will always crash. 1132 is when the system registers 1.09GB, 1.1GB will cause it to crash. I found this bug in the current build too. In the 2009 build some numbers between 64-768 also crash but this seems to be more general instability (crashes during boot at random). I found this bug is also in SheepShaver but not in the current build of BasiliskII.

Video: The video bug causes the ROM not to load. I'm less clear what value is making the video cause the ROM not to load. A config file from the 2020 GUI works but a config from 2009 GUI does not. I'll upload a working config once I find the value that works. This suggests to me the video bug is a configuration created with the 2009 GUI.
User avatar
adespoton
Forum All-Star
Posts: 3069
Joined: Fri Nov 27, 2009 5:11 am
Location: Emaculation.com
Contact:

Re: New builds of BasiliskII for 10.4 Tiger?

Post by adespoton »

Have you been doing these tests removing the NVRAM file each time? Because if you haven't, having incompatible values in NVRAM and in config can also cause issues.
graphiteguy
Space Cadet
Posts: 7
Joined: Sat May 09, 2020 8:41 pm

Re: New builds of BasiliskII for 10.4 Tiger?

Post by graphiteguy »

adespoton wrote:Have you been doing these tests removing the NVRAM file each time? Because if you haven't, having incompatible values in NVRAM and in config can also cause issues.
I think so. I am removing ~/.basilisk_ii_xpram
User avatar
Ronald P. Regensburg
Expert User
Posts: 6330
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: New builds of BasiliskII for 10.4 Tiger?

Post by Ronald P. Regensburg »

Here, on my PowerBook G4, removing ~/.basilisk_ii_xpram made no difference compared to my earlier findings above.

Interestingly, newer BasiliskII builds do not create a ~/.basilisk_ii_xpram file. No such file in my Home folder on Catalina.
Edit 1: Indeed, in the latest BasiliskII build, settings that are saved in pram (like the alert sound) are not preserved between startups.
Edit 2: All SDL2 64bit builds I have from kanjitalk755 source since July 2018 have this issue.
I will contact kanjitalk755 about this issue.
Last edited by Ronald P. Regensburg on Thu May 14, 2020 10:31 am, edited 4 times in total.
Reason:  
User avatar
Ronald P. Regensburg
Expert User
Posts: 6330
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: New builds of BasiliskII for 10.4 Tiger?

Post by Ronald P. Regensburg »

BTW:
In the first post graphiteguy wrote: I need MacOS 7.5 and 8.6. Neither works in the classic mode.
8.6 will not run in BasiliskII. You will need SheepShaver for that.
User avatar
Ronald P. Regensburg
Expert User
Posts: 6330
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: New builds of BasiliskII for 10.4 Tiger?

Post by Ronald P. Regensburg »

graphiteguy wrote:Memory: Certain values cause the OS to crash for memory. Anything above 1132 will always crash. 1132 is when the system registers 1.09GB, 1.1GB will cause it to crash. I found this bug in the current build too. In the 2009 build some numbers between 64-768 also crash but this seems to be more general instability (crashes during boot at random). I found this bug is also in SheepShaver but not in the current build of BasiliskII.
I am not sure this can be called bugs. Best use the usual values for RAM memory: 64, 128, 256, 512, 1024 MB. Higher values should not be used for BasiliskII. I never use more than 512 MB, except with testing.
Video: The video bug causes the ROM not to load. I'm less clear what value is making the video cause the ROM not to load. A config file from the 2020 GUI works but a config from 2009 GUI does not. I'll upload a working config once I find the value that works. This suggests to me the video bug is a configuration created with the 2009 GUI.
Why do you call it a "video bug"?. Do you think it is related to graphics settings?

I created a prefs file in Tiger using the GUI app that was bundled with the 2009 BasiliskII build and I created a prefs file in Catalina using the new (beta) GUI app. I entered the same settings in both. The resulting prefs files are identical except for the JIT settings. The old GUI does not allow entering JIT settings and sets all JIT settings to false. In the new GUI I also set JIT to false by not enabling JIT compiler, although the JIT settings do not really matter because JIT is disabled in the source code because of bugs in that feature. (The new GUI writes a typo there, "jitdebug flase" instead of "jitdebug false".)

So, whatever the issue, it is not related to the GUI used to write the settings.
User avatar
Ronald P. Regensburg
Expert User
Posts: 6330
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: New builds of BasiliskII for 10.4 Tiger?

Post by Ronald P. Regensburg »

1. The xpram file issue in the SDL2 port is fixed by kanjitalk755. I posted a new build with the fix.

2. Apparently this also fixed the issue with using installed system disk images alternately with new and old BasiliskII versions.

Here, after been used once with the new fixed BasiliskII build in Catalina, those disks now again boot fine with the 2009 BasiliskII build in Tiger.

I did not need to remove the existing ~/.basilisk_ii_xpram file in Tiger. It may be needed in some cases.
Post Reply