Page 1 of 1

problems installing game-file not found

Posted: Mon Jul 13, 2020 9:42 pm
by brudi303

i just downloaded and set up the Macintosh emulator, which kind of seemed to have worked, to play the game "eastern mind: the lost souls of tong-nou". When I want to play it, it never works tho. I downloaded the .iso file of the game and put all the contents from the shared folder to the MacOS753 (hard disk i believe?) but when I click onto the icon it asks me "Where is TongNou:TongNou:d_logo?" (see picture) and I can not seem to find the file it is looking for. With the .iso file of the game, there also came along two other applications, which seem to run tho. One of them previews the characters so a little window opens and music starts to play, which makes it seem to me like it should work over all. The installation guide, which was in the download also tells me to put the qicktime folder into the macs system folder, which won't work either, because the files that I want to replace, apparently are in use it says. Might that be the problem causing thing? If not does maybe someone have an idea how I can solve that problem?

Thanks in advance!

Re: problems installing game-file not found

Posted: Tue Jul 14, 2020 7:00 am
by Ronald P. Regensburg
Do not transfer files from a disk image file using the shared folder.
An .iso file is a disk image file, usually created from a CD. Add that file it to the volumes list in the BasiliskII GUI. The next time you launch BasiliskII, the CD disk will be mounted on the BasiliskII desktop. Best lock the image file in the host system to convince the software on the disk that is on a non-writeable CD.

Re: problems installing game-file not found

Posted: Tue Jul 14, 2020 8:26 am
by brudi303
Hi, thanks for the fast answer. Adding the .iso file to the volumes doesn't want to work either. Instead when I add it there and then start basilisk, the system doesn't work at all and I get this error sound whenever I try to do something. Is there something wrong with how I added it to the volumes?

Re: problems installing game-file not found

Posted: Tue Jul 14, 2020 9:34 am
by Ronald P. Regensburg
I do not know what could be the issue. I tried it here in BasiliskII with the .iso downloaded from Macintosh Garden. The disk mounts and the game runs fine.

- Apparently you use BasiliskII on a OSX/macOS host. Which OSX or macOS version?
- Which BasiliskII build (date) do you use?

Also post the content of your BasiliskII prefs in your reply:

Launch Terminal (in /Application/Utilities/) and type at the prompt

Code: Select all

open ~/.basilisk_ii_prefs
followed by a return.
The file will open in your default text editor. Select all content and copy and paste it here in your reply.

Edit: You do not need to install the included QuickTime 2. QT 2.1 is already installed with System 7.5.3.

Re: problems installing game-file not found

Posted: Tue Jul 14, 2020 9:48 am
by brudi303
I am running macOS mojave 10.14.4 and downloaded the latest Basilisk from the 16th of May 2020 that you posted in the "Currently recommended BasiliskII builds for MacOSX/OSX/macOS:" thread.

After typing in the command into the Terminal it gives me this:
disk /Users/****/Basilisk ii/MacOS753
disk /Users/****/Basilisk ii/Eastern Mind (Mac-EN).iso
extfs /Users/****/Basilisk ii/shared
screen win/1024/768
serialb /dev/null
ether slirp
udptunnel false
udpport 6066
rom /Users/****/Basilisk ii/1mbMacrom/PERFORMA.ROM
bootdrive 0
bootdriver 0
ramsize 67108864
frameskip 0
modelid 5
cpu 4
fpu true
nocdrom false
nosound false
noclipconversion false
nogui false
jit true
jitfpu true
jitdebug false
jitcachesize 2048
jitlazyflush true
jitinline true
keyboardtype 5
keycodes false
mousewheelmode 0
mousewheellines 1
dsp /dev/dsp
mixer /dev/mixer
ignoresegv true
idlewait true

Should I maybe just try to setup the whole mac emulation again, since it seems to work for you? Maybe I messed up some minor stuff while installing...

Re: problems installing game-file not found

Posted: Tue Jul 14, 2020 2:49 pm
by Ronald P. Regensburg
I don't see any problems in your configuration. You could make a few adjustments, though:
- Give BasiliskII a little more RAM
- Disable JIT, it is not functional in this build
- Set Mac Model ID to Quadra 900. The indication "MacOS 8.x" is misleading. It will work fine with System 7.5 and later. Only for earlier System 7 versions one does indeed need to choose Mac IIci.

It is strange that your setup works without the CD .iso image and does not work when that image is added. Maybe something is wrong with the image file? Try a fresh download. I got mine from Macintosh Garden.

Re: problems installing game-file not found

Posted: Tue Jul 14, 2020 3:08 pm
by brudi303
Changed the settings as you told and downloaded a fresh .iso version. Works now. Thanks a lot :)

Re: problems installing game-file not found

Posted: Tue Feb 23, 2021 10:21 pm
Just saw this post. Is it correct, that I can create an "iso" disc image, put my files/applications into it, and then "find" it on GUI launch. Then run from that image?

Also, if that works, would it likely also work to transfer to the HD image I first set up, so I do not have to load the .iso? Not that I would care!!!! If it works.... I really miss SuperPaint. (Tons of files I made with it, and want to use.)

Thanks!!!!!!!!!!!!!!! For SheepShaver and all the help.

Re: problems installing game-file not found

Posted: Wed Feb 24, 2021 8:51 am
by Ronald P. Regensburg
Always give detailed information about your setup. Otherwise it is impossible to give a proper answer.

From your other posts I understand that you have SheepShaver running on a Mac with macOS 10.13 (High Sierra) and that you own games on "disks". I suppose that you mean CD-ROMs.

From the SheepShaver setup manual:
You can create disk images from CD-ROMs using Disk Utility in macOS 10.14 (Mojave) and earlier:
- Mount the CD in OSX/macOS
- Start Disk Utility (in the /Applications/Utilities/ folder))
- Select the CD volume (not the drive) in the list on the left
- Click New Image in the tool bar or in newer Disk Utility versions use New Image from the File menu
- Choose DVD/CD master for the format
- Save the image file. It will have a .cdr extension.

You can add the image file to the volumes list in SheepShaver preferences and check the CDROM box next to it.

The next time you run SheepShaver, the CD will mount on the SheepShaver desktop.

Note: Do not remove the CD from the desktop, always use the volumes list in preferences to add or remove CDs.