Mac OS 7.1

About BasiliskII, a 68k Mac emulator for Windows, MacOSX, and Linux that can run System 7.x through MacOS 8.1.

Moderators: Cat_7, Ronald P. Regensburg

Post Reply
tcat
Inquisitive Elf
Posts: 36
Joined: Tue Aug 04, 2020 4:04 pm

Mac OS 7.1

Post by tcat »

Hi,

New to the forum and emulation. Used to have mac many years ago.
BasiliskII built from sources on RPI, with system 7.5.3 - works boots fine.

Exploring further, I wish to install 7.1.x, tried various CD or disk images from MacGarden

Code: Select all

LC630CD_712.toast
Q610CD_71.toast
MacOS711_WW.toast
SSW-7-Pro-Disk-Images.sit
Installation completes successfully, but after booting from the disk
I am getting

Code: Select all

Illegal instruction: 000b at 00050dd8
This is how I switch disks

Code: Select all

rom /home/pi/mac/Performa-630.ROM
disk /home/pi/mac/mac.hd  <== botable 7.5.3.
disk /home/pi/mac/MacOS711_WW.toast
disk /home/pi/mac/LC630CD_712.toast
#disk /home/pi/mac/DiskTools_MacOS8.image
#disk /home/pi/mac/Stuff-it_Expander55.dsk
disk /home/pi/mac/DiskCopy.dsk
disk /home/pi/mac/installer.hd
disk /home/pi/mac/Performa-630.hd <== target for 7.1.x, does not boot
Any ideas?
Many thanks
Tomas
emendelson
Forum All-Star
Posts: 1228
Joined: Tue Oct 14, 2008 12:12 am

Re: Mac OS 7.1

Post by emendelson »

User avatar
Ronald P. Regensburg
Expert User
Posts: 6329
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: Mac OS 7.1

Post by Ronald P. Regensburg »

Or the wrong Machine ID setting? Should be for System 7.1

Code: Select all

modelid 5
tcat
Inquisitive Elf
Posts: 36
Joined: Tue Aug 04, 2020 4:04 pm

Re: Mac OS 7.1

Post by tcat »

Hi,

Yes, wrong rom and modelid.

7.1.1 or 7.1.2 installed from LC630CD

works with rom LC-III or Quadra-650

modelid 5

what is cpu for 3/4 standing for 68030 / 68040???

About this mac shows model IIic, slightly confused.

What if I needed Quadra950 and System 7.1 that used to be my real machine

Many thanks
User avatar
Ronald P. Regensburg
Expert User
Posts: 6329
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: Mac OS 7.1

Post by Ronald P. Regensburg »

Note that BasiliskII does not emulate a 'real' Mac, not a real Mac model that ever existed.

For modelid there are two choices that I am aware of, 5 and 14:
modelid 5 the emulator presents itself as Mac IIci (needed for System 7)
modelid 14 the emulator presents itself as Quadra 900 (can be used with System 7.5 and later)

cpu 2 is 68020
cpu 3 is 68030
cpu 4 is 68040

fpu false or true is without or with FPU
(cpu 4 should normally be combined with fpu true)
Last edited by Ronald P. Regensburg on Wed Aug 05, 2020 8:19 am, edited 1 time in total.
Reason:  
tcat
Inquisitive Elf
Posts: 36
Joined: Tue Aug 04, 2020 4:04 pm

Re: Mac OS 7.1

Post by tcat »

Ah, many thanks.
fpu false or true is without or with FPU
(cpu 4 should normally be combined with fpu true)
EDIT
What if I needed fpu for 68030 which is a 68882 extra chip put in socket in some
LC/Performa models.

Thank you so far.
Tom
Last edited by tcat on Wed Aug 05, 2020 9:41 am, edited 1 time in total.
User avatar
Ronald P. Regensburg
Expert User
Posts: 6329
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: Mac OS 7.1

Post by Ronald P. Regensburg »

You can choose to use fpu true with any of the three cpu setiings. Only with cpu 4 better use fpu true always.
User avatar
adespoton
Forum All-Star
Posts: 3068
Joined: Fri Nov 27, 2009 5:11 am
Location: Emaculation.com
Contact:

Re: Mac OS 7.1

Post by adespoton »

I've used all sorts of modelids with BII -- most of them work except the PowerBook ones. ROMs function as listed here: https://docs.google.com/spreadsheets/d/ ... -Dk7QDyKPY

For 7.1, you need to ensure the ModelID lines up with the system enabler you use. Note that the ModelID is the Gestalt ID minus 6, so the IIci is Gestalt ID 11 and ModelID 5. Gestalt IDs of 6 and lower aren't supported by BII.
tcat
Inquisitive Elf
Posts: 36
Joined: Tue Aug 04, 2020 4:04 pm

Re: Mac OS 7.1

Post by tcat »

Hi,

Installed Q610CD_71.ZIP, SSW-7-Pro-Disk-Images.sit, Q610CD_71.ZIP, and
LC630CD_712.ZIP.

Tried these ROMs, LC-III.ROM, Performa-630.ROM, ..

Cannot get audible sound in 7.1.1 or 7.1.2, just menu bar flashes instead.

Seems like a feature?

Many thanks
Tom
User avatar
adespoton
Forum All-Star
Posts: 3068
Joined: Fri Nov 27, 2009 5:11 am
Location: Emaculation.com
Contact:

Re: Mac OS 7.1

Post by adespoton »

For those OS versions, you may need to follow the instructions elsewhere on here to open the Sound control panel and select the appropriate output device. You may also need the Sound Manager extension.
tcat
Inquisitive Elf
Posts: 36
Joined: Tue Aug 04, 2020 4:04 pm

Re: Mac OS 7.1

Post by tcat »

Hi,
For 7.1, you need to ensure the ModelID lines up with the system enabler you use
Please see picture https://github.com/tcat-qldom/MacOS-7

System enabler 040, modelid 5
LC-III.ROM (1M) - works
IIci.ROM (512K) - does not [BII reference build]

Installed LC630CD-7.1.2.toast ==> best results
Presents itself as System Z-7.1.1, what is "Z" ???
For those OS versions, you may need to follow the instructions elsewhere on here to open the Sound control panel and select the appropriate output device. You may also need the Sound Manager extension.
Sound panel opened, `built-in' volume, but no sound, just menu bar flashing instead,
as if some disability feature enabled.

No sound extensions found.

I am getting sound with OS 7.5.3. [System753.iso.7z]

BasiliskII says

Code: Select all

pi@raspberry:~/mac $ Basilisk II V1.0 by Christian Bauer et al.
Reading ROM file...
Using SDL/pulse audio output
WARNING: Unknown VideoDriverStatus(11)
WARNING: FSM <1.2 found, disabling ExtFS
No external access to Unix, unlike with 7.5.3. that mounts `Unix' volume.
Tom
User avatar
Ronald P. Regensburg
Expert User
Posts: 6329
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: Mac OS 7.1

Post by Ronald P. Regensburg »

Sound control panel:
Can't you select "Sound Out" settings in the drop-down menu?
There you will need to select (click to highlight) "Built-in" for the playback device.

"Unix" disk:
For 7.1 you will need to install the File System Manager extension.
See topic here: https://www.emaculation.com/forum/viewt ... f=6&t=7752
tcat
Inquisitive Elf
Posts: 36
Joined: Tue Aug 04, 2020 4:04 pm

Re: Mac OS 7.1

Post by tcat »

Hi,
Sound control panel:
Can't you select "Sound Out" settings in the drop-down menu?
There you will need to select (click to highlight) "Built-in" for the playback device.
Actually no, menu offers:

Code: Select all

Alert Sounds
Sound In
No `Sound Out', as per picture at earlier ULR, it says `Built-in Volume' underneath the slider control.

Compared to 7.5.3.

Code: Select all

Alert Sounds
Sound In
Sound Out
Volumes
It all refers to `Built-in Volume'.

Tom
User avatar
adespoton
Forum All-Star
Posts: 3068
Joined: Fri Nov 27, 2009 5:11 am
Location: Emaculation.com
Contact:

Re: Mac OS 7.1

Post by adespoton »

7.1.x has an issue with finding the sound hardware on Basilisk II. The sound manager extension from 7.5 can fix this IIRC.
Presents itself as System Z-7.1.1, what is "Z" ???
"Z" refers to the international install series; it allows you to install in languages other than US English.
tcat
Inquisitive Elf
Posts: 36
Joined: Tue Aug 04, 2020 4:04 pm

Re: Mac OS 7.1

Post by tcat »

For 7.1, you need to ensure the ModelID lines up with the system enabler you use
Installed enabler 040 is for System 7.1.2P that would be Performa?

Emulator presents itself as IIci, searching Gestalt-11 gives the id 5 for IIci.
Still not any wiser about sound not working, I need specific enabler XXX for IIci,
other than 040, which one?

7.5.3 has also 040, sound works there, though.

Back to ROM search?

Tom
User avatar
adespoton
Forum All-Star
Posts: 3068
Joined: Fri Nov 27, 2009 5:11 am
Location: Emaculation.com
Contact:

Re: Mac OS 7.1

Post by adespoton »

The sound issue has to do with a separate sound extension that allows System 7.1.x to use the virtual sound hardware presented by BII. 7.5.x has drivers for that hardware built-in.
tcat
Inquisitive Elf
Posts: 36
Joined: Tue Aug 04, 2020 4:04 pm

Re: Mac OS 7.1

Post by tcat »

Hi,

Sound Manager 3.1. did it, as you said.
Not present at MacGarden, though
https://macgui.com/downloads/?file_id=20779

Tom
User avatar
adespoton
Forum All-Star
Posts: 3068
Joined: Fri Nov 27, 2009 5:11 am
Location: Emaculation.com
Contact:

Re: Mac OS 7.1

Post by adespoton »

Yeah; that's the one. Now I've got to hunt down why my upload to MG appears to be missing in action.

[edit] no, they're there, just hard to find: https://macintoshgarden.org/apps/helper-extensions-bii
tcat
Inquisitive Elf
Posts: 36
Joined: Tue Aug 04, 2020 4:04 pm

Re: Mac OS 7.1

Post by tcat »

Hi,

Now with MPW (E.T.O.) installed I can do tricks with `Gestalt'.

Interesting about ROMs, as LC630.ROM and LCIII.ROM
both works with System 7.1.2. and Gestalt reports them indenticaly.
Mac-IIci.ROM does not boot, at least the version I got.

7.1.2 Installed from LC630-CD.toast, reports as 7.1.0

Code: Select all

Gestalt -s proc fpu mach romv rom sysv

Processor type          68030   # cpu 3 rom LCIII
FPU type                68881
Machine type            IIci
ROM version             6.7C
ROM size                1048576
System version          7.1.0

Processor type          68030	# cpu 3 rom LC630
FPU type                68881
Machine type            IIci
ROM version             6.7C
ROM size                1048576
System version          7.1.0

Processor type          4    # dump ids 
FPU type                1
Machine type            11
ROM version             6.7C
ROM size                1048576
System version          7.1.0
User avatar
adespoton
Forum All-Star
Posts: 3068
Joined: Fri Nov 27, 2009 5:11 am
Location: Emaculation.com
Contact:

Re: Mac OS 7.1

Post by adespoton »

Please cross-reference against https://docs.google.com/spreadsheets/d/ ... -Dk7QDyKPY and update comments with system enabler info if needed. I seem to recall that 7.1.2/7.1.0 issue as well. Version numbering was a bit of a mess from 7.1.2 through 7.5.3.
tcat
Inquisitive Elf
Posts: 36
Joined: Tue Aug 04, 2020 4:04 pm

Re: Mac OS 7.1

Post by tcat »

Done, for IIci, LCIII, LC630, and Q650.
T.
User avatar
adespoton
Forum All-Star
Posts: 3068
Joined: Fri Nov 27, 2009 5:11 am
Location: Emaculation.com
Contact:

Re: Mac OS 7.1

Post by adespoton »

Just to clarify: 1993-02-01 ECBBC41C fa16d49527c4e6e9c0d9e46904133d39 LC III, LC III+, LC 520, Performa 460, Performa 520 (v2) 7.1-7.6.1 4-36M 1M MC68030 MC68882 Vail, Route66 Boots 7.1.x, w/o sys enabler

I should be adding the LC/Performa 630 to the hardware list there, correct?
tcat
Inquisitive Elf
Posts: 36
Joined: Tue Aug 04, 2020 4:04 pm

Re: Mac OS 7.1

Post by tcat »

Hi,
LC/Performa 630
needs an enabler I should think.
I have updated some comments for IIci, LCIII, LC630, and Q650, that is four distinct rows,
in the sheet.
Surprisingly IIci does not boot at all with 7.1.x., IIci is a reference ROM (very promising comments in the table),
so it would be interesting if someone else confirms that, too.

Tried with various enablers here
https://macintoshgarden.org/apps/apple-system-enablers
Some machines do not require an enabler.

EDIT
I matched each row by generating md5 and comparing header (first long word) of each ROM tested.

Tom
Post Reply