Installation System 7.1 - Disk 2 ?!

About BasiliskII, a 68k Mac emulator for Windows, MacOSX, and Linux that can run System 7.x through MacOS 8.1.

Moderators: Cat_7, Ronald P. Regensburg

Post Reply
User avatar
Sebiohazard
Tinkerer
Posts: 79
Joined: Tue Aug 27, 2019 2:15 pm

Installation System 7.1 - Disk 2 ?!

Post by Sebiohazard »

Good morning all !

I have a problem installing System 7.1 with Basilisk II. I started with the install 1.img floppy & now the installation asks me for floppy # 2 but I don't know how to go back to the emulator menu & insert this floppy ?

Image

How to proceed ?

Greetings !
User avatar
Cat_7
Expert User
Posts: 5380
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Re: Installation System 7.1 - Disk 2 ?!

Post by Cat_7 »

Hi,

As you noticed you cannot change floppies.
If you have the floppies as disk images, you should put them on another disk image and add that to the volumes list in the GUI.

You can roughly follow this guide (which I haven´t tested)

Use the GUI to:
1. Create a new disk image of perhaps 500 Mb onto which you will install System 7.
2. Create a new disk image of perhaps 20 Mb onto which you will copy the system 7 floppy disk images.

Use HFV explorer to:
3. Copy the individual disk images to the 500 Mb disk image

Use the GUI to boot an existing Mac OS 7.5 or 8.0 installation, but first add:
4. The 500 Mb system 7 disk image
5. The 20 Mb disk image with the system 7 floppy images.

Once booted, mount all the system 7 disk images and start the installation from the first disk images. You might need the disk copy 4.2 program to mount the images.
Install onto the 500 Mb system 7 disk.
Once finished, shut down Basilisk and start the GUI to remove the system 7.5 or 8.0 and the 20 Mb floppy disk image from the volumes list. Then start Basilisk.

Best,
Cat_7
User avatar
Sebiohazard
Tinkerer
Posts: 79
Joined: Tue Aug 27, 2019 2:15 pm

Re: Installation System 7.1 - Disk 2 ?!

Post by Sebiohazard »

Hello thank you for your help :)

1. I found a method to install System 7.1 very easily without going through all these steps... just use Mini vMac & & once the installation is complete start Basilisk II with this HDD :)

2. I have also installed my favorite Flashback game in floppy version, but i have a big problem ! With Mini vMac the game does not start & with Basilisk II Flashback starts but I have no sound ?!

How to proceed ?

Greetings !
User avatar
adespoton
Forum All-Star
Posts: 3388
Joined: Fri Nov 27, 2009 5:11 am
Location: Emaculation.com
Contact:

Re: Installation System 7.1 - Disk 2 ?!

Post by adespoton »

In BII you'll need to use the Sound control panel to select the audio output before you'll hear anything, especially if you initially set up the image on Mini vMac.
User avatar
Sebiohazard
Tinkerer
Posts: 79
Joined: Tue Aug 27, 2019 2:15 pm

Re: Installation System 7.1 - Disk 2 ?!

Post by Sebiohazard »

adespoton wrote: Thu May 27, 2021 2:51 pm In BII you'll need to use the Sound control panel to select the audio output before you'll hear anything, especially if you initially set up the image on Mini vMac.
Hello !

I went to the sound settings but I couldn't find the " audio output " option ?!
User avatar
Sebiohazard
Tinkerer
Posts: 79
Joined: Tue Aug 27, 2019 2:15 pm

Re: Installation System 7.1 - Disk 2 ?!

Post by Sebiohazard »

I installed System 7.5.3 by following this tutorial here & the sound works however I don't have the startup sound ?!

I found a post here on the subject but I don't know what MD5, SHA1, CRC checksums are ?!

Greetings !
User avatar
Cat_7
Expert User
Posts: 5380
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Re: Installation System 7.1 - Disk 2 ?!

Post by Cat_7 »

You need to have the sound you want to play at boot available in your basilisk folder as a file called startup.wav

Do you have that? And does it play in Windows when you double-click it?

Best,
Cat_7
User avatar
Sebiohazard
Tinkerer
Posts: 79
Joined: Tue Aug 27, 2019 2:15 pm

Re: Installation System 7.1 - Disk 2 ?!

Post by Sebiohazard »

Hello !

Yes I have this " startup.wav " file in the Basilisk folder (it comes with the archive) & yes the sound is working in Windows :) I don't know why it doesn't work ?!

Greetings !
User avatar
Sebiohazard
Tinkerer
Posts: 79
Joined: Tue Aug 27, 2019 2:15 pm

Re: Installation System 7.1 - Disk 2 ?!

Post by Sebiohazard »

What more do I have to do ?
User avatar
Ronald P. Regensburg
Expert User
Posts: 6781
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: Installation System 7.1 - Disk 2 ?!

Post by Ronald P. Regensburg »

Nothing. If the sound file "startup.wav" is in the same folder as BasiliskII.exe, the sound should play when BasiliskII is started.
Post Reply