Switch to full style
About BasiliskII, a 68k Mac emulator for Windows, MacOSX, and Linux that can run System 7.x through MacOS 8.1.
Post a reply

Trouble booting OS 8

Tue Dec 31, 2002 3:07 am

HI, I'm having trouble booting mac OS 8 on basillisk 2,
When I install it normally (defualt settings) the booting progress bar goes to about 3/4ths and then the thing freezes immidiately... It also freezes when i boot without extentions, it just freezes when the desktop shows, It does it all the time at the exact same moment, I've erased the disk and reinstalled the os 4 times. And it does the same thing...
If you've had this problem and have fixed it, tell me what to do!

Tue Dec 31, 2002 3:26 am

By the way, I said that the bar freezes immidiately, the whole emulator freezes...

Compatible ROM?

Wed Jan 01, 2003 2:43 am

Are you using a ROM image that is compatible with Mac OS 8? Check in the tab to see if Basilisk II mentions if the model you selected is OS 8 Able.

Also, I know that Basilisk II does crash when OS 8 starts the Setup Assistant, so remember to quickly exit that application after a fresh install of OS 8.

Other than a ROM Issues, are you making sure that your memory is set properly and that your other emulator settings are ok? Post the complete preferences file for Basilisk II here and I can look over them.

Wed Jan 01, 2003 10:50 pm

here's the preference file, the rom is a quad 650. My friend uses the same type and it works for him...

Your Preferences File

Thu Jan 02, 2003 12:50 am

I'm going over your preferences file here and I see some problems. Now I don't know how exactly the emulated Mac works per say, but alot of Mac models from the 68k line did not support 256MB of RAM. This may be your first problem, because the actual machine code does not support it.

* ROM: 1 MB
* RAM: 4 MB or 8 MB on motherboard, expandable to 132MB or 136MB using 80ns 72-pin SIMMs; motherboard had 4 SIMM slots which can be filled individually but should ideally be filled in interleaved pairs; can use 4 MB, 8 MB, 16 MB, and 32 MB SIMMs (see 64 MB SIMMs on 68K Macs for information on 64 MB SIMMs)

So I would not use 256MB RAM since I'm sure it can cause some problems. To be honest, 128 is fine for most Macs.....

I run my emulators with FPU off since the Baslisk FPU is still buggy. Use a software FPU instead if you really need it.

I generally turn audio off since it uses up alot of resources and is generally slow and not accurate. (Unless you play games)

In the "Priorities" tab, you have "Frame Buffer" as "above normal"..you are not using frame buffer, you are using direct x, so put this down to normal and move DirectX and GDI up to "above normal" this will speed your refresh rate.

But turn the memory down, a real Quadra 650 does not support 356MB RAM, so I have no reason to doubt the emulator won't.

Citon X600

Thu Jan 02, 2003 3:21 pm

hmmmmm.... It still doesn't work, I'm begginning to think that it might be the OS software... what do you think?


Fri Jan 03, 2003 1:25 am

Yeah, it could be bad os software, lots of files tend to get corrupted online.

Sad to hear that.

Sat Jan 04, 2003 3:29 pm

Set your Model ID (General tab) to 14 instead of 30.

You might want to set both your ports to "File" as well.

Sat Jan 04, 2003 10:30 pm

nope still doesnt work, could be a problem with my computer, although it runs OS 7.5.5 perfectly...
My computer is a Windows ME, 128 MB RAM, 633 Mhz Celeron (Yuck :? ).
I really want to get os 8 to work, i know that it isn't the cd that's corupted (i tryed it on my friends and it worked perfectly)... HELP! :(:(:(

Windows ME?

Sun Jan 05, 2003 5:59 am

You are using Windows ME? UGHHH!

Sorry, but that is the worst OS Microsoft ever put out. Even Darek from Emulators Inc. knows that. You should read his little article and guide about fixing it, it's about the only good thing he ever published, and even then I wouldn't doubt that he ripped it. :roll:

I would suggest deleting your Basilisk II preferences file and start over. I have uploaded my preferences file and it works for OS 8.

I would also recommend making a new HFV file and starting fresh. Delete the PRAM file where you ROM is located as well.

I can't post the prefs file I am getting an error from phpBB2. Here is my prefs:

disk D:\Drive Backups\M68K Technology\test.hfv
cdrom E:\
scsi0 <Free SCSI slot 0>
scsi1 <Free SCSI slot 1>
scsi2 <Free SCSI slot 2>
scsi3 <Free SCSI slot 3>
scsi4 <Free SCSI slot 4>
scsi5 <Free SCSI slot 5>
scsi6 <Free SCSI slot 6>
screen dxwin/640/480/0
seriala FILE
serialb FILE
rom D:\Drive Backups\M68K Technology\Archive Volumes\Volume K\Machine Roms\Centris650\Centris650.rom
bootdrive 0
bootdriver 0
ramsize 67108864
frameskip 6
modelid 30
cpu 68040
fpu false
nocdrom true
nosound true
nogui false
noclipconvert false
nofloppyboot true
noscsi true
ntdx5hack false
rightmouse 0
keyboardfile BasiliskII_keyboard
pollmedia false
priority_ether_run 0
priority_ether_idle 0
priority_serial_in_run 0
priority_serial_in_idle 0
priority_serial_out_run 0
priority_serial_out_idle 0
priority_cpu_run 0
priority_cpu_idle -1
priority_60hz_run 1
priority_60hz_idle 1
priority_1hz_run 1
priority_1hz_idle 1
priority_pram_run 0
priority_pram_idle -1
priority_gui_run 1
priority_gui_idle 0
priority_gdi_run 1
priority_gdi_idle -1
priority_dx_run 1
priority_dx_idle -1
priority_fb_run 0
priority_fb_idle -1
priority_sound_run 0
priority_sound_idle 0
noaudio true
debugscsi 0
debugfilesys 0
debugserial 0
framesleepticks 14
showfps true
stickymenu false
etherpermanentaddress true
ethermulticastmode 0
disable98optimizations false
realmodecd false
ethernt5 {18D590BC-B866-48E9-819D-90DCC12C0406}
soundbuffers 3
soundbuffersize8000 1024
soundbuffersize11025 2048
soundbuffersize22050 2048
soundbuffersize44100 4096
nosoundwheninactive true
mousewheelmode 1
mousewheellines 1
mousewheelreversex false
mousewheelreversey false
mousewheelclickmode 0
mousewheelcust00 +37+3B-3B-37
mousewheelcust01 +37+3C-3C-37
usealtescape false
usealttab false
usecontrolescape false
usealtspace false
usealtenter false
disableaccuratetimer true
guiautorestart 0
gethardwarevolume true
enableextfs false
usentfsafp false
extdrives #C
debugextfs 0
portfile0 C:\B2TEMP.OUT
portfile1 C:\B2TEMP.OUT
DX_fullscreen_refreshrate Monitor default
mousemovementmode 0
usestartupsound true
smp_ethernet 0
smp_serialin 0
smp_serialout 0
smp_cpu 0
smp_60hz 0
smp_1hz 0
smp_pram 0
smp_gui 0
smp_gdi 0
smp_dx 0
smp_fb 0
smp_audio 0
idlesleep 1
idlesleepenabled false
idletimeout 0
routerenabled false
ftp_port_list 21
disablescreensaver false
keyboardtype 5

Wed Jan 15, 2003 2:15 am

I finally got it to boot! I shut it down, and when i went to boot it again, it froze!!
Now there is a 1/10 chance it will boot.
And by the way, after it freezes i'll alt-tab it and it give throw this error:
Error number 0x1C1EE6BC has occured...
Post a reply