Page 1 of 1

Where's the Option Key?

Posted: Thu Feb 26, 2009 2:35 pm
by madcrow
In Basilisk II, Alt = Command and Control is control... Where is the option key? I had thought that maybe the Windows key might be it, but it doesn't seem to do the trick. I really do want to be able to input special characters (my Launcher needs some tabs, for one thing), so the lack of an option key is cramping me here. What can I do?

Posted: Thu Feb 26, 2009 4:19 pm
by ClockWise
On my system the Windows key is mapped to the option key, and I can make special characters with no problem.

Do you have a non-standard keyboard?

Posted: Thu Feb 26, 2009 4:29 pm
by madcrow
Nope. I have a normal, boring US keyboard. Maybe my problem has something to do with some sort of window manager conflict where KDE is "stealing" keys from the program or something. I'll have to try it in WindowMaker or something...

Posted: Thu Feb 26, 2009 4:37 pm
by ClockWise
Well, you can always adjust the keycodes file.

I opened the BasiliskII_Keycodes, and in the Windows section changed the line "59 122 # F1" to instead read "59 58 # F1" afterwich the F1 key functioned as the option key.

Of course then you lose the F1 key. But 58 is the Mac keycode for option, so you can use that to map any key to option.

Just check the "raw keycode" box in the GUI.

Posted: Fri Feb 27, 2009 1:02 pm
by madcrow
Thanks for the tip. I'll have to get do that.