Switch to full style
About BasiliskII, a 68k Mac emulator for Windows, MacOSX, and Linux that can run System 7.x through MacOS 8.1.
Post a reply

BasiliskII MacOSX Universal build 4 October 2009 available

Sun Oct 04, 2009 9:18 pm

New version build from source 4 October 2009, but without the "SDL audio patch" change that was applied 19 February 2009. The "SDL audio patch" caused poor sound performance, apparent in all BasiliskII for MacOSX builds in the past months.

This build works in Mac OS X 10.4 through 10.7. In 10.7 (Lion) it will only work in window mode, not in full-screen mode.

Get the new BasiliskII for Mac OS X here:
http://www.xs4all.nl/~ronaldpr/basilisk ... 091004.zip

In the application I added the build date (200910004) to the version number (still 1.0) that has lost its meaning.

The icon is based on a 16th century picture of the mythological basilisk:

Thanks to our forum member "vasi", a newer BasiliskGUI (for Mac OS X 10.6 and later only) can be found here:
https://github.com/downloads/vasi/b2gui ... I-10.6.zip

Other needed files, such as the GUI application and a keycodes file, are not included. Those can be found in the downloads from Gwenole Beauchesne's site: (link removed)
Edit: Because Gwenole's site appears to be removed, the above BasiliskII download now includes the old PPC GUI application and the keycodes file.

Edit: Cat_7 wrote a guide for setting up BasiliskII for Mac OS X with the freely available download of System 7.5.3 from Apple:
http://www.emaculation.com/doku.php/bas ... _osx_setup
Last edited by Ronald P. Regensburg on Fri Nov 18, 2011 1:15 pm, edited 4 times in total.

Tue Oct 06, 2009 1:38 pm

thank you very much for your work and support. :)

Wed Nov 18, 2009 5:40 am

I'm running 10.6.1 & it won't open, it just bounces in the dock for a second & then vanishes. If I try opening it with Rosetta, it "opens" but, I get the spinning beachball if I click the icon in the Dock.

Wed Nov 18, 2009 9:30 am

Did you setup BasiliskII using the BasiliskIIGUI application?

Wed Dec 30, 2009 3:37 am

Other needed files, such as the GUI application and a keycodes file, are not included. Those can be found in the downloads from Gwenole Beauchesne's site:

The link to the GUI app and keycodes appears to be dead, is there somewhere else I can download them at?


Wed Dec 30, 2009 9:53 pm

jayman30usa wrote:
Other needed files, such as the GUI application and a keycodes file, are not included. Those can be found in the downloads from Gwenole Beauchesne's site:

The link to the GUI app and keycodes appears to be dead, is there somewhere else I can download them at?

I can't imagine that all of Gwenole Beauchesne's site has suddenly been removed, so I suppose it is a temporary problem with the server or the domain.

Sat Jan 02, 2010 3:56 pm

Well, apparently the site has been removed.

I changed the BasiliskII download (linked from the first post in this thread) to include the GUI application and the keycodes file.

Mon Feb 01, 2010 3:02 pm

I don't know if this something you can fix, but in this build the Alt/Option key seems to have no effect. (I've tested this System 7.5.5 only.)

The Alt/Option key works exactly as it should when I use a build that is named (on my disk, perhaps not originall) BasiliskII-UB2008. The About box in this version says "Basilisk II 1.0, Mac OS X Port 19", and the date in Get Info is 4 January 2008.

Can anyone else reproduce this problem? If so, can it be fixed in the newer build?

By the way, the problem occurs whether or not I select "use raw keycodes" in the prefs.

Mon Feb 01, 2010 3:19 pm

The option key works here as expected, for instance for typing special characters.
BasiliskII 1.0.20091004, System 7.5.5, MacOSX 10.5.8, Intel Mac.

Mon Feb 01, 2010 3:29 pm

You are right that the Option key works for typing special characters. But, at least on my system, it does not work in the Finder itself. For example, if the Finder is active, and a window is open, and I hold down the Option key and click Special, I *should* see the menu item "Clean up by name." But in the newest build, nothing happens - the menu does not even open at all!

In the older build, if I do exactly the same thing (hold down the Option key and click Special), then the menu opens, with "Clean up by name" at the top.

Does this occur on your system also?

EDIT: Forgot to mention: Intel Mac, OS X 10.6 fully updated.

Mon Feb 01, 2010 9:34 pm

Yes, indeed. In this BasiliskII build the option key does not work in the Finder. With the option key pressed, the menus do not work and also closing all windows does not work.

The option key does work in the 18 July 2008 build I have here and it does work, also with 7.5.5, in the latest SheepShaver builds. (SheepShaver shares much of its code with BasiliskII.)

I do not know what could cause this problem. I am no developer, I only build from source. The only thing I could do is make several builds, each time leaving out a different change that was added to the source since July 2008, but that is a very time consuming procedure.

Mon Feb 01, 2010 11:21 pm

Also Option-drag doesn't work - you can't make a copy of a file by Option-dragging it to another folder. Perhaps there should be a warning about this on the first post?

If you don't have a copy of that "Mac OS X Build 16" easily available, I can send it - but I think I got it here originally!

Tue Feb 02, 2010 12:25 am

In this build apparently left and right mouse button clicks on the host side are received in the guest OS reversed. When you right-click with the option key pressed, it works as it should with a left-click.

Does any one of the developers read this? I will send a note to the basilisk-devel mailing list.

Tue Feb 02, 2010 2:40 am

Fascinating! I hope this can now be fixed if a developer reads your message.

Basilisk II setup guide for OS X (offline)

Wed Mar 10, 2010 4:39 pm

I would like to set up the Basilisk emulation to run Mac OS 7.5.3 on my OSX 10.5.8 Intel Mac. For some reason, 7.5.3 was the last system that will run some old Trueform multi-page forms I need. Adobe abandoned the program a long time ago after it bought the company.

I went to http://www.emaculation.com/doku.php/basilisk_ii that talks about what's needed. But the link under 'Documentation and Guides', Basilisk II setup guide for OS X (offline): http://macscene.net/wiki/index.php/Basilisk_II_Setup_Guide, which I had hoped would give more instructions on how to set it up, does not work.

Am I correct that Basilisk would be the best emulator for 7.5.3 on OSX? I notice that other emulators are also discussed on this web site, such as SheepSaver.

I've downloaded BasiliskII for Mac OS X from the link above, the Graphical Disk Image Chooser from a link on the Basilisk II page, and the System 7.5.3 disk images from Apple. Although I've been using computers for over 25 years, my knowledge in limited to mainly using them for the task needed. I'm an architect by trade. Can you offer any information where I might be able to get some installation instructions?

Wed Mar 10, 2010 10:06 pm

SheepShaver emulates a PPC Mac, BasiliskII emulates a 68k Mac. Both can run 7.5.3, but if the application you need is 68k only it will probably run better in BasiliskII.

Regrettably, the site that contained the only available setup instructions for BasiliskII MacOSX was unexpectedly removed and no one appears to have saved a copy. To get an idea about how to proceed, you can study the setup guide for BasiliskII Windows and the setup guide for SheepShaver MacOSX. Though not identical, the basics are similar.

The ROM file you need for BasiliskII is a different one than the ROM files used for SheepShaver. Look for quadra650.rom or performa.rom. Configuration for BasiliskII is done with the BasiliskIIGUI application that is provided with the BasiliskII application. Terrible interface, but it works. Settings are saved when BasiliskII is started with the Start button in BasiliskIIGUI.

An alternative is the BasiliskII port by Nigel Pearson. The emulator itself has several problems, but it has a prettier and more intuitive interface for configuring the various settings. After you have finished setup, you can then use the more stable BasiliskII version you downloaded here. (Both ports of BasiliskII use the same preference file, the file ~/.basilisk_ii_prefs which is invisible in the Finder.)

BasiliskII port by Nigel Pearson: http://web.netcall.com.au/~pear_compute ... iskII.html

Edit: I wrote that the invisible preference file is ~/.basiliskii_prefs, but it is ~/.basilisk_ii_prefs (corrected now in the above text).

Works like a charm!

Sat Aug 21, 2010 1:27 pm

THANK YOU - I am happily using both Basilisk II & Sheepshaver on an Intel MacBook 2.4 GHz, 4 GB RAM OS 10.6.4 and my MacBook Air. I am running the great old outliner pgm MORE 3.1 and the outstanding word processor WriteNow 4.0. My intention is to load some other favorite classic pgms as well . . .

My advice to others taking the plunge is: Read - re-READ & then read again the setup instructions provided as this site recommends.

I happily discovered you can back up your set up and easily transfer it to another computer - I did that between my MacBook and MacBook Air via a simple 1 Gb USB thumb drive. I transferred my MacBook's folder containing 1) Basilisk pgm, 2) Mac ROM, and 3) a 500Mb disk image housing OS 7.5 and my classic pgms. Now I have a portable classic I can travel with along with my OS X machines.

Sat Nov 06, 2010 8:24 pm

At least a GUI without square buttons?
And a GUI with a .nib?
i want to edit with xcode

Sat Nov 06, 2010 10:12 pm

Hi, such a GUI is available in OSX, both inside SheepShaver (see File/Preferences) and as a standalone OSX-native GUI. For historical reasons there is also the square-buttoned GTK gui (if that is what you mean).

Download the source, and you'll see.


Tue Feb 15, 2011 5:03 pm

Ive tried both sheep shaver and basilisk 2 and neither of them can run power pete without crashing my mac! I have a MacBook Pro 2.52ghz intel corei7 with 8gb ram, this should not be a problem. What am i doing wrong?

Tue Feb 15, 2011 11:12 pm


I tried Power Pete in both SheepShaver and Basilisk (in Windows 7) and the game runs OK. In Basilisk it is very slow, but in SheepShaver it runs perfectly. (or perhaps too fast...)

Perhaps you are experiencing a difference between the windows and OSX versions of sheepshaver/basilisk. I would have to try in OSX.

EDIT: No, the game runs in both emulators in OSX, although way to fast in sheepshaver, but OK in Basilisk
Did you try to set "ignore illegal memory accesses" in the preferences for Basilisk? (it wasn't selected in my settings)


Wed Feb 16, 2011 5:40 am

Thanks for the tip, but I still only made it through the first level on basilisk before I had to shut down manually because it froze. I have tried sheepshaver in the past and it was even worse, I could reinstall it and try again, but I'd like to know what settings you use in basilisk. From what i can tell i have it set up for max performance, but i cant be sure...

BasiliskII MacOSX Universal build 4 October 2009 available

Sat Mar 05, 2011 3:52 pm

Ronald: can you provide some more detail as to how you create these builds? I tried building the src/MacOSX from CVS head using the command line autoconf/configure/make, but failed. (I've posted to basilisk-devel with some details/questions).

FYI: I grabbed Gwenolé's site from archive.org and posted the Basilisk II portions at http://voltaire.nfshost.com/transfer/20 ... lisk2.html

Sat Mar 05, 2011 4:26 pm

Ronald will give you a complete answer soon enough, but in the meantime there is this guide:

http://www.emaculation.com/doku.php/com ... r_basilisk

It might help.

Sat Mar 05, 2011 4:46 pm

I have not created a BasiliskII build since October 2009. After reading your recent email to the basilisk-devel mailing list, I tried to build BasiliskII in 10.6.6 with XCode 3.2.2 and SDL 1.2.14 in the same way I did that in 2009 in Tiger with XCode 2.5 and with an earlier SDL version of SDL (1.2.12 ?) and exactly as is described in the new guide that ClockWise linked to above.

To my surprise, the resulting BasiliskII.app in the Unix directory had the icon that belongs to Nigel Pearson's version of BasiliskII. I tried the application, but it crashed on launch. I did not investigate further.

It took many adjustments to the source code before a working SheepShaver could be built in Snow Leopard. Maybe BasiliskII encounters similar problems.
Post a reply