Switch to full style
About BasiliskII, a 68k Mac emulator for Windows, MacOSX, and Linux that can run System 7.x through MacOS 8.1.
Post a reply

Re: BasiliskII for Linux

Sun May 12, 2013 10:59 pm

Okay, tested the filesharing between two machines emulating MacOS 7.5.4, and still no luck. Netatalk, the linux implementation of AppleTalk, doesn't see the emulations either... Does any of this usually work? If so, could the problem be related to the fact, that I'm trying this over a Wi-Fi network?

Re: BasiliskII for Linux

Mon May 13, 2013 4:23 am

fatfreddie wrote:If so, could the problem be related to the fact, that I'm trying this over a Wi-Fi network?

Probably. Can you plug in an ethernet cable or two and try it with a wired network?

Re: BasiliskII for Linux

Mon May 13, 2013 5:26 am


Most routers do not support Appletalk over wireless connections.
Even our Appletalk solution for OSX with the IpNetRouter software doesn't have an implementation of Appletalk over wireless. The developer never implemented it. And modern-day router developers consider it to be a legacy protocol.


Re: BasiliskII for Linux

Tue May 14, 2013 12:23 pm

That explains that! ...it's a pity though, I hoped to get it working in some way, since I don't have the option to revert to a wired connection... Well, on the other hand it's just a detail, I can still share the files over the host machines and make them available in the Unix folders.

Re: BasiliskII for Linux

Tue Nov 26, 2013 5:28 pm

For what it's worth, I can share files using Appletalk between Basilisk II running OS 7.5.3 on a Winxp machine using Wifi and real Mac's hard wired to the same router, but only by first setting the Network control panel on the Basilisk and on the real Mac's (where applicable) to 'Classic Networking' so that all the machines are using MacTCP instead of Open Transport, with the rider that the Basilisk can find the Mac's in it's chooser window but not the other way round.

Re: BasiliskII for Linux

Mon Feb 10, 2014 2:17 pm

Hi Cat,

I have installed BasiliskII on Ubunto running inside VirtualBox on a Mac Mini and when I start BasiliskII in fullscreen mode* my mouse curser appears at top left of the Mac desktop but then disappears making it impossible to use.

*I'm using a HD TV as a monitor

I'm also using a K400 Logitech wireless keyboard which works fine under VirtualBox and Ubuntu.

Can you suggest a fix?

Re: BasiliskII for Linux

Tue Dec 30, 2014 6:31 pm

After running Basilisk II for several years problem free on Xubuntu 12.04 LTS I upgrade this past week (same hardware, new OS). In order to mirror my OS disks I had to use Ubuntu Server 14.04 LTS and then add the Xubuntu Desktop. Today i attempted to reinstall Basilisk II using the same software I had been using; BasiliskII_SDL_Linux_13_09_2010. I can't get it to run.

I'm seeing the error: "error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory", which is very similar to a problem that was addressed in a much earlier response. I've read through all the responses to date and have tried anything that seemed remotely relevant to no avail. I suspect because I installed Ubuntu Server I'm probably missing a package (or several).

One thing I noticed was that the default PATH did not contain a pointer to /usr/lib, so I included that. I also added every gtk package that looked appropriate. GCC and G++ are both installed.

Any suggestions on packages that may be missing? Anything other suggestions? I'd really like to get BasiliskII working again...


Re: BasiliskII for Linux

Mon Jan 05, 2015 11:21 pm

My guess is that it is compiled against a libgtk object file for x11, and the change in x server has messed things up somehow? It seems to me a recompile using current SDL, GTK and xorg libs *should* do the trick.

Re: BasiliskII for Linux - Ubuntu 17.10?

Tue Mar 27, 2018 2:02 pm

Hi, I need some help building/starting Basilisk II, long story short I moved off of OS X onto a laptop running Ubuntu 17.10.

There is a Basilisk II package however it doesn't seem to work. It throws:
Basilisk II V1.0 by Christian Bauer et al.
ERROR: Could not initialize SDL: No available video device.

I tried to pass the --display option to it, no luck there either, got the same result. X11 works fine, the DISPLAY variable is set (:1) I'm able to run xlogo, etc. without issue.

I then did a git clone off https://github.com/cebix/macemu.git but the only Linux make options seem to be rpm oriented. How do I compile Basilisk II?

I'm sure there's going to be another issue after I build it, as this machine has a 4K display.

Thanks for any advice.

Re: BasiliskII for Linux

Tue Mar 27, 2018 5:06 pm

Do you have the SDL runtime and SDL development packages installed?

Is this any help with compiling?
https://www.emaculation.com/doku.php/co ... x_flavours


Re: BasiliskII for Linux

Sun May 06, 2018 7:50 pm

Following the instructions on that page got it to compile without errors, but running the resulting binary causes the same issue where sdl fails to initialize.
Yeah, both the libsdl1.2-dev and libsdl1.2debian packages are installed. (There doesn't seem to be any libsdl1.2 packages in artful).

$ ./BasiliskII
Basilisk II V1.0 by Christian Bauer et al.
ERROR: Could not initialize SDL: No available video device.

Both sdl-config and sdl2-config run.
Versions are: 1.2.15 and 2.0.6

I also tried adding --enable-sdl-static to the ./configure.

Re: BasiliskII for Linux

Sun May 06, 2018 7:56 pm

Interesting. Ran strace against it, right before it complains, it tries to open the frame buffer, but no such device exists. That's a clue.

close(7)                                = 0
openat(AT_FDCWD, "/dev/fb0", O_RDWR)    = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/dev/fb/0", O_RDWR)   = -1 ENOENT (No such file or directory)
write(1, "ERROR: Could not initialize SDL:"..., 60ERROR: Could not initialize SDL: No available video device.
) = 60

Re: BasiliskII for Linux

Thu Jun 14, 2018 12:20 am

I'm trying to get BasiliskII working on Xubuntu 18.04. I have an old copy of source (macemu) that I downloaded several years ago and had running. I am able to get the autogen.sh to complete without errors (that I see, anyway) and am given the instruction to run "make". When I do, I get a screenful of errors that scroll past what I'm able to save. I executed make again and directed the output to a file. The output says:

g++ -I./../include -I./. -I. -I./../CrossPlatform -I./../uae_cpu -I./../slirp -DHAVE_CONFIG_H -DOS_linux
-DDATADIR=\"/usr/local/share/BasiliskII\" -g -O2 -I../../../cxmon/src -I../../../cxmon/src/disass
-fno-merge-constants -fno-gcse-sm -c ./../main.cpp -o obj/main.o
Makefile:194: recipe for target 'obj/main.o' failed

I have no idea what this means...

Thinking I might have a bad copy of the source code, I came back to this forum and attempted to download using the same commands I did last time (found here: viewtopic.php?t=6375 ):

$ cvs -d :pserver:anoncvs@cvs.cebix.net:/home/cvs/cebix login
(password is "anoncvs")
$ cvs -d :pserver:anoncvs@cvs.cebix.net:/home/cvs/cebix checkout BasiliskII
$ cd BasiliskII/src/Unix
$ ./autogen.sh
check output if config is correct if no do ./configure with needed options
$ make
$ ./BasiliskII

What I found is that the server cvs.cebix.net doesn't exist anymore.

I also tried downloading the zip files for the Linux builds (found here: viewtopic.php?t=6580 ), but after unzipping them I have no idea what to do with them. They aren't a directory, and they don't execute for me.

Can someone help me decode my error, point me to another location for the source code, and/or tell me what to do with the Linux build files?

Any assistance is appreciated.


Re: BasiliskII for Linux

Thu Jun 14, 2018 12:30 am

A quick update on my previous post.

I was able to find the latest source code on github and successfully downloaded it. Unfortunately, I get the exact same error when running the make command.

Still searching....

Re: BasiliskII for Linux

Thu Jun 14, 2018 12:25 pm

I was able to fix the missing framebuffer due to nvidia drivers issue by doing:

modload uvesafb

But then got permissions errors on the console. I haven't quite figured out exactly all the devices I needed to chown to my user, however, running sudo BasiliskII now brings up the GUI.

Re: BasiliskII for Linux

Fri Jun 15, 2018 3:45 am

OK. Got it working. The problem was that I didn't have all my package requirements installed.
Thanks to anyone who spent any time thinking about my problem.

Re: BasiliskII for Linux

Fri Jun 15, 2018 12:08 pm

I see you were eventually able to get it compiled, so this comes too late.

One thing, if you get an error like that and don't see the actual error message, you can copy & paste the exact gcc command into the terminal and see what error it actually throws. In what you posted above it looks like make is hiding the output. Note that you might have to figure out what directory to cd into first.

Re: BasiliskII for Linux

Sun Sep 30, 2018 12:33 am

I downloaded the windowed-mode binary and I can't launch it.
Post a reply