Page 1 of 1

Too fast!

Posted: Thu Jul 14, 2011 11:23 pm
by mark
Hi, I have never used a Mac emulator before but have just installed Basilisk II so I can play some classic games I used to have on my LCII. However when I try to play "Shadow Keep" it is just ridiculously fast.

How can I make my emulator run more slowly? I've looked through the forum but can't find anything that helps :(

PC specs:
Intel Core i7
XP Pro 64 bit

Basilisk II prefs:

disk C:\Games\BasiliskII\install.hfv
screen win/512/342
seriala COM1
serialb COM2
udptunnel false
udpport 6066
rom C:\Games\BasiliskII\quadra650.rom
bootdrive 0
bootdriver 0
ramsize 8388608
frameskip 6
modelid 5
cpu 3
fpu false
nocdrom true
nosound false
noclipconversion false
nogui false
jit true
jitfpu true
jitdebug false
jitcachesize 8192
jitlazyflush true
jitinline true
keyboardtype 5
keycodes false
mousewheelmode 1
mousewheellines 3
ignoresegv false
idlewait true
enableextfs true
debugextfs false
pollmedia true
etherpermanentaddress true
ethermulticastmode 0
routerenabled false
ftp_port_list 21
portfile0 C:\B2TEMP0.OUT
portfile1 C:\B2TEMP1.OUT

Posted: Thu Jul 14, 2011 11:37 pm
by Cat_7
Hi, welcome!

The short answer to your question is that you can't make Basilisk run slower. Some games were not coded to take "real time" into account. Perhaps other emulators allow you to set the speed they run with, but Basilisk doesn't have that feature.


Posted: Fri Jul 15, 2011 12:22 am
by IPalindromeI
Disable the JIT (this JIT dramatically makes emulation faster, turn it off for max slownewss) - then adjust the Mac's refresh rate, also try an older PC, slow down the Mac by loading it with extensions will never need, or try another emulator. SheepShaver emulates a more complex Power Mac which will be slower. Or the older build of Basilisk, or even SoftMac unoptimized ;)

Posted: Fri Jul 15, 2011 2:01 am
by Silent Flamer
Try Mini vMac . Mini vMac has alot of speed controls , even down to 1 MhZ . Basilisk II's speeds are meant for the newer color Macintoshes , such as the Quadras . Those newer computers never had slow speeds such as the Plus .

Posted: Fri Jul 15, 2011 5:11 am
by ClockWise
If you check this page, you will see that without JIT, Basilisk is much slower, as ipalindromei said. SoftMac is slow, too... but it doesn't support sound.

Results include:

Installing an Application

The test required the emulators to install Wordperfect 3.5. Here's the results:

SoftMac 2008: 10.8 seconds
SoftMac XP: 9.7 seconds
Basilisk II JIT R5: 3.3 seconds
Basilisk II JIT R3: 3.2 seconds
Basilisk II .9: 11.2 seconds


Stuffit Test One

...Marathon III Infinity, which is 35.6 MB in size and contains a number of individual files. I expanded the archive in each emulator using Stuffit 5.5. Here are the results:

SoftMac 2008: 7 minutes, 16 seconds
SoftMac XP: 7 minutes, 9 seconds
Basilisk II JIT R5: 2 minutes, 4 seconds
Basilisk II JIT R3: 2 minutes, 18 seconds
Basilisk II .9: 7 minutes, 25 seconds

Posted: Fri Jul 15, 2011 8:31 am
by 24bit
Hello, just to complete the listings above,
Fusion_PC in DOsBox is really slow and DOSBox has some kind of time slice adjustments
to make the hosted programs even slower. DOSBox can only use one core, but unfortunately
it can not locate too much RAM.
It might be worth a shot still.
Best wishes!

Posted: Sat Jul 16, 2011 7:45 am
by mark
Thanks for all the replies.

I'd already tried unchecking JIT, and it makes very little difference - I guess I'll start using Mini vMac.

Thanks again.

Posted: Sat Jul 16, 2011 9:42 am
by 24bit
Sure MiniVMac is a very good choice.
If your games are all right with a small monochrome screen, give it a try.
MiniVMac's MacII emulation is in progress and looks good.
The ASC emulation is missing howerver, so there will be no sound.

Fusion_PC can have 256 colors (at least), sound and rather big screens - the bigger the screen, the slower the apps.
DOSBox can safely allocate 31MB or 63MB as a maximum. Enough for Fusion and most old games.
See also:

Best wishes!

Re: Too fast!

Posted: Fri Feb 19, 2021 12:05 am
by terdy
Late to the party, but I just got shadow keep running on Basilisk II. I was able to slow the game down by opening it up (first by mounting the game .dsk file as a volume inside the BSII GUI), opening the drive on the desktop, and opening shadow keep, clicking the black/white picture of a dragon, the going to file -> new quest. Once the game loaded, I clicked the 'speed' option (just left of the character image) and changed the speed to the slowest setting. Now my character moves at a reasonable pace and I'm not getting insta killed by baddies.

Hope that helps.