Login  •  Register


The time is now: Thu Jun 27, 2019 2:06 am

Emaculation wiki  •  Delete all board cookies



Post new topic  Reply to topic Page 1 of 1 [ 4 posts ]
Print view Previous topic  |  Next topic
Author Message
PostPosted: Mon Apr 15, 2013 9:13 pm 
Offline
Space Cadet

Joined: Mon Apr 15, 2013 8:56 pm
Posts: 3
Location: Cádiz, Spain
Greetings, I'm new here.

Yesterday I read on the Internet that the Macintosh version of Warcraft: Orcs & Humans is better then its DOS counterpart, and both of them come in a hybrid CD. It has higher resolution and CD music.

So, thanks to the tutorial on this very website, I managed to get System 7.5.3 on Basilisk II. My host OS is Windows 7 64-bit.

I popped my Warcraft CD in and made an ISO image, as Basilisk II can't access the CD drive on a 64-bit version of Windows.

I installed it and began to play.

The intro runs fine, the main menu appears, the mission objectives video goes smoothly...And I finally began to play.

But, for my dismay, the units were slower than snails. Even setting the game speed at fastest didn't work. And the background music didn't sound at all.

My Basilisk II settings are these:

Image
Image
Image
Image
Image
Image
Image

The CD-ROM Driver is disabled because it wouldn't work with my OS. I set the RAM at 16 MB because 8 weren't enought for running the game (by a few KBs). And the JIT Compiler is disabled because it caused me trouble when updating my System to 7.5.3 (thanks to this post I solved the problem :razz:).

So, can you help me out? Every helpful post will be highly appreciated.

See you around!

_________________
:)


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Mon Apr 15, 2013 9:22 pm 
Offline
Master Emulator

Joined: Fri Sep 17, 2004 4:22 am
Posts: 339
Well, now that you've updated your system, why not try enabling the JIT compiler?

I think you also might want to try switching the CPU Type to 68040 with FPU.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Tue Apr 16, 2013 9:35 am 
Offline
Space Cadet

Joined: Mon Apr 15, 2013 8:56 pm
Posts: 3
Location: Cádiz, Spain
Hello Jorpho, thank you for your reply.

As you can see in this picture, these are all my available CPUs:

Image

There is no 68040 with FPU.

(Well, I Google'd that and according to Wikipedia, the 68040 has a FPU integrated on it. I tried it and it didn't help me at all.)

Also, switching on the JIT compiler didn't work at all.

Another interesting fact is that the scrolling speed (you know, when you navigate through the map) works fine.

So, the only problems I see is the moving speed of the units, and no music plays during the game. Aside from that, the game works fine.

_________________
:)


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Thu Apr 25, 2013 2:36 am 
Offline
Master Emulator
User avatar

Joined: Tue Feb 23, 2010 7:35 am
Posts: 430
I'm very sure the problem is related to RAM. Most games, even today, run like snails when you don't give it adequate resources. If possible, please increase your RAM from 16MB to something higher like 64MB, or something in the middle if you don't have that much RAM to spare.

Also, change the RAM allocation for the game itself too. Find the application file, select it, go to the File menu (or was it the Edit menu?) and click "Get Info" (maybe I got that wrong too...). Or, you could just select it and hit Option-I. From there, there should be 3 fields at the bottom of the window that pops up that says things like "Mininum memory" and "Recommended memory".

For a game like WarCraft, I'd say give it about at least 16MB (yes, that's the current memory you allocate for the entire emulated Macintosh right now. That's why I said increase the RAM in the GUI).

Good luck in getting it running. Again, I am VERY sure it's related to the RAM. Of course, I might be wrong.


Top
 Profile  
Reply with quote Post a reply  
Display posts from previous:  Sort by  
Post new topic  Reply to topic Page 1 of 1 [ 4 posts ]


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
 

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group