Win2k Build 142 of Basilisk 2 - _old version runs better!

About BasiliskII, a 68k Mac emulator for Windows, MacOSX, and Linux that can run System 7.x through MacOS 8.1.

Moderators: Cat_7, Ronald P. Regensburg

Post Reply
Cr0w

Post by Cr0w »

I use JIT and it's a steady 85 fps with excellent performance on my AthlonXP 1800+/512 MB.
Not sure why that happens to some people. :?:
User avatar
ClockWise
Site Admin
Posts: 4116
Joined: Mon May 20, 2002 4:37 am
Location: Uiwang
Contact:

Re: Win2k Build 142 of Basilisk 2 - _old version runs better

Post by ClockWise »

What OS are you ruinning them in?

bdzld wrote:Hey all!

Anyone else found that build 142 runs a lot faster with the unoptimised exe over the other one? I've tried playing with the refresh settings, graphics etc, but can only get 9fps in basilisk with the optimised exe. I'm using a 1GHz Athlon, with 560mb of ram, I thought this would be ok to run it?

Hope someone with a similar setup can tell me how it goes with them ;)

ta!

Dan
Cr0w

Post by Cr0w »

XP Pro here.
User avatar
ClockWise
Site Admin
Posts: 4116
Joined: Mon May 20, 2002 4:37 am
Location: Uiwang
Contact:

Post by ClockWise »

Are you using the proper GUI for the JIT version of Basilisk?

If not, it will not work properly.

Try instsalling JIT from this executable:

http://hosted.barrysworld.net/basiliski ... kIIJIT.exe
User avatar
ClockWise
Site Admin
Posts: 4116
Joined: Mon May 20, 2002 4:37 am
Location: Uiwang
Contact:

Post by ClockWise »

Goddam. Post your Basilisk II prefs file here. Or cut and paste it, ro something.

My system is pretty close to yours. I will try it out...

[post the prefs from your REGULAR Basilisk II install]
User avatar
ClockWise
Site Admin
Posts: 4116
Joined: Mon May 20, 2002 4:37 am
Location: Uiwang
Contact:

Post by ClockWise »

I don't know, I don't know...

I tried it with the same ROM, the same disk and an almost identical system and got about 83 frames per second.

Keep trying?
User avatar
ClockWise
Site Admin
Posts: 4116
Joined: Mon May 20, 2002 4:37 am
Location: Uiwang
Contact:

Post by ClockWise »

Bugs me. I used the same prefs file (along with the same other stuff) and got a different result.

Hit the "screen" tab and try WINDOWS GDI type instead of Linear Frame Buffer.
User avatar
ClockWise
Site Admin
Posts: 4116
Joined: Mon May 20, 2002 4:37 am
Location: Uiwang
Contact:

Post by ClockWise »

Shouldn't be a problem. Maybe someone smarter than me (like Jim Watters) will come by and solve all your problems.
Mac Emu
Forum All-Star
Posts: 1217
Joined: Mon May 20, 2002 11:50 am
Location: Ouraion

Post by Mac Emu »

bdzld wrote:here it is..

__

modelid 30
pollmedia true
Change your Model Id to 14 instead of 30(General tab). Also try shutting off the Poll Media feature (Disk tab) as this will slow things down (press Ctrl-Shift-F11 to mount removable media).

You don't have any JIT options in your BasiliskII_prefs file
Use the BasiliskIIGUI that comes with either Hendy's installer or directly via this link. This particular BasiliskIIGUI.exe has been hacked to include a "JIT" tab where the JIT options can be set (and automatically written to the BasiliskII_prefs).

Use the following settings for JIT:
  • jitcachesize 8192
    jitwantcmov true
    jitfpu true
    jitatraps true
    jit true
    jitlazyflush 1
On some systems, the old (non-assembly optimized) Basilisk II build works better. No doubt Lauri optimized Build 142 for whatever system he was on. I've heard numerous reports on B142 choking on PIII/PIV systems. Like you, I have an Athlon (1.4 GHz). B142 does crash a bit. I actually haven't tried out the BasiliskII_old.exe. I use Basilisk II/JIT for Windows R3 mainly.
Mac Emu
Forum All-Star
Posts: 1217
Joined: Mon May 20, 2002 11:50 am
Location: Ouraion

Post by Mac Emu »

Certain extensions/control panels or emulator settings may effect speed. Same goes for various background processes running in Windows. Fragmentation shouldn't really effect performance.

1. Turn off any virus checking programs running in the sys tray. (Along with any other programs running.)

2. Make your swap file a constant size.

3. Make sure you have the latest DirectX installed (via Windows update).

4. Try setting your monitor to 256 colors (via the display control panel) before running the emulator. Most 68k Mac games need to run at 256 colors anyway.

5. Don't give the emulator more then half the installed physical RAM on your system unless you don't mind performance hits.

6. Make sure the partition your hard drive file is located on isn't to fragmented. It's also a good idea to run a Macintosh disk defragmenter under the emulator every once in a while.

7. Shut off System Restore on Windows Me/XP!

The following is from Emulators, Inc. (don't buy from them though! Darek is a $%&*#!) ...

"Anyway, one of the things PC Health does is a feature called System Restore that constantly, and I mean CONSTANTLY, keeps backing up files. Since Windows Millennium was released we've received email after email after email from our customers saying that since upgrading to Millennium, their computers are running slower and their hard disk keeps thrashing.

The reason is very simple. Every file accessed, every documented opened, every file touched gets backed up to a hidden directory called C:\_RESTORE\TEMP. This is fine if you are dealing with letters to grandma that are a few kilobytes in size, but what about large bitmaps? Large disk image files used by emulation software? Large downloads from the Internet? Yup, they get duplicated too. Your hard disk just fills up, and fills up, and fills up, until it runs out of space! I've had this happen several times on my own computers after upgrading to Windows Millennium.

I tried to disable the System Restore feature, by clicking on Start, Programs, Accessories, System Tools, System Restore, only to discover that System Restore can't be turned off there.

Worse, according to Microsoft's own documentation, (see http://msdn.microsoft.com/library/techart/winmesr.htm) the System Restore feature will keep backing up files until your hard disk fills up! The System Restore feature shuts itself off once your hard disk has less than 200 megabytes of disk space. However even this is not enough. In once instance, while running SoftMac 2000 with a 600 megabyte disk image file, the system managed to completely fill up the C: drive, causing Windows to no longer be able to grow the swap file. As a result, SoftMac ran out of memory, the Windows desktop ran out of memory and could not refresh the desktop properly, and the whole machine crashed and burned. We needed to reboot, at which point there were only a few megabytes of space left on what hours earlier had been a mostly empty 6 gigabyte hard disk! System Restore had copied gigabytes of useless duplicate files (including many copies of the 600 meg Macintosh disk image) to the hidden directory.

How to shut off this ridiculous System Restore "feature"? Well, this was the kicker. You can't simply delete the backed up files because the entire _RESTORE directory is marked as "in use" and thus can't be deleted. And since Microsoft removed the "Exit to DOS" feature, one can't just exit Windows to a DOS prompt like before. While there is an obscure "Disable System Restore" option buried away in the System control panel applet, interestingly enough under the "Performance - File System - Troubleshooting" tab, that still doesn't help with all the wasted hard disk space.

So here is my brute force solution to shut off and remove all traces of System Restore:

In Control Panels, Add/Remove Programs, create a Windows boot disk. It's really an MS-DOS boot disk.

Shut down Windows and reboot the PC from the floppy disk.

Type SMARTDRV 8192 to install an 8 megabyte disk cache (it will speed up the file deletion)

Go the C: prompt by typing C:

Type "C:\WINDOWS\COMMAND\DELTREE C:\_RESTORE" to remove all the System Restore files.

Create a bogus file called _RESTORE by, for example, running EDIT and creating a blank text file.

Type "C:\WINDOWS\COMMAND\ATTRIB +r +s +h _RESTORE" to hide this file. This will prevent Windows from re-creating its hidden directory.

Now reboot the PC and watch Windows Millennium run much faster!

The whole System Restore feature is just an idiotic idea. My advice - if you have a slow PC, run Windows 95 OSR2 or Windows 98 Second Edition on it. If you have a faster PC with at least 16 megabytes of memory, run Windows 98 Second Edition. If you have 64 megabytes and run at 200 MHz or faster, don't even bother with a consumer version of Windows. Upgrade yourself to Windows NT 4.0 or Windows 2000 (a.k.a. NT 5.0) and enjoy all the benefits of a true 32-bit SMP-capable pre-emptive multi-tasking operating system. In Windows XP, Microsoft has intelligently made System Restore an in-your-face and easy-to-find option in the "My Computer" Properties dialog. It takes all of 5 mouse clicks (or 1 keystroke and 3 mouse clicks) to disable."

Another thing to try is disabling any themes (like animated cursors).

Under Fusion PC mouse behavior can be erratic or lethargic. If you try running Fusion PC under Windows 9x/Me, try disabling mouse acceleration. Under DOS, try out different DOS mouse drives (ctmouse.com - cute mouse) works pretty good on my system, but some mouse.exe's cause problems.

Image[/code]
Post Reply