Login  •  Register


The time is now: Thu Jun 27, 2019 2:04 am

Emaculation wiki  •  Delete all board cookies



Post new topic  Reply to topic Page 1 of 1 [ 2 posts ]
Print view Previous topic  |  Next topic
Author Message
PostPosted: Sun Feb 15, 2015 7:49 am 
Offline
Space Cadet
User avatar

Joined: Sun Feb 15, 2015 7:13 am
Posts: 1
Hi, first post.

I just set up Basilisk last night, and it seems to be working fine. Only issue is I have a couple of old games on CD I would like to play. When I insert CDs into the drive while running Basilisk, nothing happens. So, I tried shutting down Basilisk, inserting the CD, then starting it up again. If the virtual machine boots with the CD already in the physical drive, it appears to read the CD as soon as it starts up, so I know there is some form of communication between the CD drive and the system. However I get that message telling me the CD is not readable by the computer and would I like to reformat it. CD in question is an original copy of Day of the Tentacle from c. 1996, not a CD-R I burned or anything. Have tried this with multiple discs from the same time period, same issue.

A solution that occurred to me is to simply try creating an image of the CD and mounting that instead of trying to mount the physical CD. I was able to successfully create an HFS image of the game CD and mount it in Basilisk, however when I try to run the application it tells me the CD is not in the drive, so I assume the issue is that the application is expecting the disk to be in whatever place Mac System 7 has the CD drive set to. I also tried creating and mounting an image using Virtual CD imager, same issue; disk mounts okay and works, but the game application can't find the disk. What I was wondering is, would it be possible to configure Basilisk in a way that would, instead of reading CDs from my computer's CD drive, instead have whatever path leads to the CD drive lead to a disk image instead? Is that a thing that could be done or am I way off my nut and not understanding how the system/emulator works?

Anyway, I guess the quick summation of my problem would be that I want to play games that require a mounted CD to run, and I would like to know how to either A) fix the issue with the CD mounting so that Basilisk mounts the CDs correctly or B) set up Basilisk to mount a disk image and assign it to the spot a CD-ROM would normally mount to so that the game will think the CD is in the drive.

B) would probably be my preferred way of doing this, actually, since it would enable me to simply keep a bunch of disk images on a hard drive and not have to hunt around for my old copies of things every time I want to play something. However, I will take whichever solution anyone can provide or whichever is less complicated.

Please and thank you.

If it matters, I am running Basilisk on a Mac I purchased new in 2011, currently running OS 10.10.2.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Sun Feb 15, 2015 11:04 am 
Offline
Expert User
User avatar

Joined: Thu Feb 09, 2006 10:24 pm
Posts: 5422
Location: Amsterdam, Netherlands
Your disk image was probably created in a wrong format, read-only or compressed.

OSX 10.8 (Mountain Lion) and later prevent mounting of physical CD-ROMS in SheepShaver and BasiliskII. There are workarounds described in the Known Issues section of the SheepShaver for OSX setup manual that do indeed involve disk images. The workarounds are the same for BasiliskII.

http://www.emaculation.com/doku.php/she ... own_issues


Top
 Profile  
Reply with quote Post a reply  
Display posts from previous:  Sort by  
Post new topic  Reply to topic Page 1 of 1 [ 2 posts ]


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
 

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group