Switch to full style
About BasiliskII, a 68k Mac emulator for Windows, MacOSX, and Linux that can run System 7.x through MacOS 8.1.
Post a reply

System Alert sounds with BII and system 7.5.3 on Win10 64bit

Sat Dec 03, 2016 5:19 am

Heyo, all!

Just stumbled across BII - I ran mac OS6 and 7 back when I was younger and kinda miss it, so I figured I"d give this a shot. Install was pretty straight forwards, didn't have any major issues, just an oddity:

Audio works, and I can hear the system alert sound, and in the Sounds control panel I can change the system alert volume, but attempting to select any of the other system alert sounds (wild eep for example), it just continues to play the default noise.

Now, I can go into the System briefcase and play the wildeep sound from there and it plays that good ol' "Eeep" just fine, so I know the emulator is passing sound correctly, and I know the sound file is good, and I know it's in the system briefcase where it should be, and sure enough it shows up in the sound control panel, but selecting it, it still just plays the default beep.

I saw someone mention this elsewhere on the web but never got a response.

Just curious if I'm missing something obvious.

Thanks!

Re: System Alert sounds with BII and system 7.5.3 on Win10 6

Sat Dec 03, 2016 11:25 am

Switching system alert sounds should work methinks.
At least it does on my side. I don´t use BII much with a W10 host, but just gave it a go.
Exe from here, Cat_7: http://www.open.ou.nl/hsp/downloads2/Ba ... 2-2015.zip
Needed files, Cat_7: http://www.open.ou.nl/hsp/downloads/Bas ... 1_2010.zip
Boot volume, MG: http://macintoshgarden.org/apps/macos-753-emulators

Looks like this on W10-64 pro, Eeep it does. :)

Image

Re: System Alert sounds with BII and system 7.5.3 on Win10 6

Sun Dec 04, 2016 7:18 am

Yeah that's exactly what I'm running, but when selecting Eep, it just does the default system beep, no eep. ohwell.

Re: System Alert sounds with BII and system 7.5.3 on Win10 6

Sun Dec 04, 2016 9:40 am

BasiliskII saves the system beep settings (and several other settings) in the xpram file on the host. Maybe something wrong with that file? Try: stop BasiliskII, delete the xpram file, and start BasiliskII again.

Re: System Alert sounds with BII and system 7.5.3 on Win10 6

Thu Dec 21, 2017 6:42 am

I generally wouldn't bump an old topic, but I'm having the same exact problem (though I'm using Win 7 32bit). I've tried everything I could think of and yet the default beep persists. :sad: I had hoped to hear these sounds once again while using BII... Any help would be most appreciated.

Re: System Alert sounds with BII and system 7.5.3 on Win10 6

Sun Jan 28, 2018 12:26 am

I'm having the same issue: only the "Simple Beep" sound plays regardless of which alert sound is chosen. I'm running Basilisk II 1.0 on OSX, so it doesn't seem to be only a Windows issue.

Re: System Alert sounds with BII and system 7.5.3 on Win10 6

Sun Jan 28, 2018 1:36 pm

Strange, I never had a System sound issue with BasiliskII.
Feel free to try this boot image: http://macintoshgarden.org/apps/macos-753-emulators
As the MacOS was installed "For every Mac" some extensions won´t work with BasiliskII.
For example, a missing mpeg decoder pops up an alert at boot time.
Other than that the OS should work with System sounds, Mac or Windows.
Post a reply