E-Maculation
https://www.emaculation.com/forum/

Color issue in old version of Basilisk II
https://www.emaculation.com/forum/viewtopic.php?f=6&t=9307
Page 1 of 1

Author:  agent_js03 [ Mon Apr 24, 2017 4:40 pm ]
Post subject:  Color issue in old version of Basilisk II

Hi all,

I am using Basilisk II build 142 on Windows 98. I am encountering a strange problem.
Basically I have installed System 7.5 and when I select 256 colors and boot up, everything is in black and white. I can go to the monitors panel, switch to 256 grays and then back to 256 colors, and it will be in color until I shut down or restart and then the same problem will happen again. Has anyone seen this before? Is there a known workaround?

I remember running Basilisk II with system 7.5 on the family computer (also running Windows 98) about 15 years ago and never had this problem, so I am wondering if it is either DirectX or my graphics driver that could be the culprit...

Thanks in advance.

Author:  adespoton [ Mon Apr 24, 2017 9:19 pm ]
Post subject:  Re: Color issue in old version of Basilisk II

I had this exact issue; it has to do with the pram file. Ensure that this can be read/written to where it gets created, and remove the old version so it can be created from scratch. Also, in the prefs file, ensure that you're starting in 256 color mode.

Author:  agent_js03 [ Sat Apr 29, 2017 2:10 am ]
Post subject:  Re: Color issue in old version of Basilisk II

Hi adespoton,
Thanks so much for the reply.
I did as you said, the pram is being written in the same directory as Basilisk II. I looked at the folder properties and the "Read only" box is unchecked. I don't know beyond that how to find out whether it is writable or not.
Also I checked the Basilisk II prefs file. I see the following line:

screen dx/800/600/8

I believe the 8 at the end refers to 8-bit color, i.e. 256. Is this correct? Or can I use something else?

Thanks again for answering. I was not sure whether to expect help on this issue since it is such an old version of Basilisk.

Author:  adespoton [ Sun Apr 30, 2017 4:09 am ]
Post subject:  Re: Color issue in old version of Basilisk II

That all seems correct; the only other thing I can think of is to remove the pram file and let it create a fresh one; something might be corrupted in there.

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/