Basilisk II crashes repeatedly

About BasiliskII, a 68k Mac emulator for Windows, MacOSX, and Linux that can run System 7.x through MacOS 8.1.

Moderators: Cat_7, Ronald P. Regensburg

Post Reply
Space Cadet
Posts: 4
Joined: Mon Jan 15, 2018 9:45 pm

Basilisk II crashes repeatedly

Post by Zbig »

Hi! I'm using... I'm trying to use Basilisk II 20120528 with Quadra605.rom and Mac OS 7.6.1 iso image found at their site under Slackware 14.2. I've got five problems to solve:

1. Everytime when shutting Basilisk down, it spits out list of (what seems to be) errors:

Sorting out untranslated instructions count...

Rank Opc Count Name
000: a975 196030208 ILLEGAL
001: e541 67860158 ASL
002: a829 59906941 ILLEGAL
003: a88f 39066583 ILLEGAL
004: a873 37562222 ILLEGAL
005: a055 22592252 ILLEGAL
006: a871 19010985 ILLEGAL
007: a874 18390397 ILLEGAL
008: 007c 17419117 ORSR
009: a972 16621900 ILLEGAL
010: 40e7 16540340 MVSR2
011: 46df 16538291 MV2SR
012: a030 15273109 ILLEGAL
013: a025 13011818 ILLEGAL
014: a029 12079911 ILLEGAL
015: a974 11554254 ILLEGAL
016: a973 11554154 ILLEGAL
017: a971 11554061 ILLEGAL
018: a822 7812624 ILLEGAL
019: a02a 6126730 ILLEGAL

Is it normal? If not - how can I fix it?

2. How can I create "virtual harddisk" to be able to install _just anything_ there? Should I use internal "Drive Setup" tool for this? If so - it always either answers "it cannot be used on this computer", or (sometimes) simply crashes complaining like this:

Caught SIGSEGV at address 0x10ffff9c4 [IP=0x7808c7bb]
D0: 0071abb4 D1: 0000a01f D2: 0071abb4 D3: 9d082a76
D4: 78d4a290 D5: 00000000 D6: 78152a85 D7: 00000000
A0: 0071aba8 A1: 00000000 A2: 0003757a A3: 0080db50
A4: 00000044 A5: 00000000 A6: fffff988 A7: 00775e0a
USP=00000000 ISP=00775e0a MSP=00000000 VBR=00000000
T=00 S=1 M=0 X=0 N=0 Z=0 V=0 C=0 IMASK=0
FP0: 11,4275 FP1: nan FP2: nan FP3: nan
FP4: nan FP5: nan FP6: nan FP7: nan
N=0 Z=0 I=0 NAN=0
0080dc0c: 202e 003c 6010 200e c0b8 MOVE.L (A6,$003c) == $fffff9c4,D0
next PC: 0080dc10
### Compile Block statistics
Number of calls to compile_block : 301004
Total emulation time : 70,9 sec
Total compilation time : 0,4 sec (0,6%)

Now what? [RESOLVED]

3. For similar reasons I'm unable to install Word 5.1 - I added diskette images as floppies, and I can even start installation by clicking installer from first diskette - unfortunately, it rather quickly crashes.

4. To be able to process Mac "stuffit" archives - because Mac OS doesn't seem to recognize ".sit" files at all, this is "just some file" for OS inside Basilisk - I wanted to install appropriate archive tool I found here:
It turned out that some highly intelligent guy uploaded stuffit... packed by stuffit (try to install ZIP packed by ZIP, when you haven't ANY earlier version installed). OK, somehow I managed to unpack it under Windows with unar. What should I do with the contents of the archive to install this and to make MacOS recognize .sit files? "Step-by-step" please, if possible - I'm not Mac-fanboy, in fact I only want to have Word installed, just to convert a few very old text files. I tried Basilisk - compiled by myself using scripts found at "Slackbuilds" - on two different machines: dated 32-bit Athlon and not-so-old i8 Intel. Unfortunately, on both there are very similar problems, described above.

5. And similar problem while Word 6 installation attempt using file found at the site ( ): after unpacking its archive there seems no binary installer present (the same problem as with stuffit archive). If I'm correct I should use some kind of script I can see in the archive, by interpreting it with MacOS' "Installer" utility - is it right? But when I select "choose" and then I enter a folder, where these files are located (I unpacked them before), it shows no file. It seems, it doesn't recognize any file as "executable installer".

Could someone help? Thanks in advance!
Last edited by Zbig on Mon Jan 15, 2018 11:25 pm, edited 1 time in total.
Space Cadet
Posts: 4
Joined: Mon Jan 15, 2018 9:45 pm

Re: Basilisk II crashes repeatedly

Post by Zbig »

OK, I managed to create virtual HDD and to install there system from iso image file - and I can even start entire "machine" from that installed system. But I can't move any further, since Basilisk keeps crashing. If I try to copy any file/folder onto that new system disk - there's immediate crash, and I can't check/test/try anything more:

WARNING: RmvTime(00105fee): Descriptor not found
Illegal instruction: 01ff at 00000378
Caught SIGSEGV at address 0xfffffc4 [IP=0x7816b88a]
D0: 00000000 D1: 00000001 D2: 619a61fe D3: 619608f8
D4: 00070c2c D5: 67f64e73 D6: 00000000 D7: 00000000
A0: 02002704 A1: 00000000 A2: 48f8ffff A3: 0c3040f8
A4: 0c7421df A5: 00404a90 A6: 0c704a38 A7: 012f66fe
USP=00000000 ISP=012f66fe MSP=00000000 VBR=00000000
T=00 S=1 M=0 X=0 N=0 Z=1 V=0 C=0 IMASK=0
FP0: nan FP1: nan FP2: nan FP3: nan
FP4: nan FP5: nan FP6: nan FP7: nan
N=0 Z=0 I=0 NAN=0
Memory protection error

RESOLVED: I found out, that I can avoid that repeated crashing if I create new folder on that system disk first, and only then I copy files there. So I was able to move on somehow.
Last edited by Zbig on Tue Jan 16, 2018 10:58 am, edited 1 time in total.
User avatar
Expert User
Posts: 5171
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Re: Basilisk II crashes repeatedly

Post by Cat_7 »

Does the prefs editor come up when you start Basilisk?

If so, check under the Memory/Misc tab and tick all options related to ignoring memory access etc.
Also, disable the JIT compiler on the JIT Compiler tab.

If not, copy your .basilisk_ii_prefs file (found in your home folder) contents in a reply.

Does your distro not provide any newer build? Too bad.

Space Cadet
Posts: 4
Joined: Mon Jan 15, 2018 9:45 pm

Re: Basilisk II crashes repeatedly

Post by Zbig »

OK, so I was able to figure out a little bit:

1. So these supposed errors are JIT compilers complainings - after I switched JIT compiler off, it stopped bothering me with this.

2. "Virtual HDD" creation has been resolved, as I noted.

3. Just a while ago I tried to install Word 5.1 again, after switching off JIT compiler - unfortunately, it won't help. I've got again a crash:

Basilisk II V1.0 by Christian Bauer et al.
Reading ROM file...
Using SDL/pulse audio output
WARNING: RmvTime(00104326): Descriptor not found
Caught SIGSEGV at address 0x1410ff00 [IP=0x7808ca52]
D0: 0410ff00 D1: 0000a029 D2: 0000ffff D3: ffff0000
D4: 01e86ce0 D5: fffffffd D6: 00000000 D7: ffff0000
A0: 0410ff00 A1: 0410ff00 A2: 0002f3a6 A3: 0200db5c
A4: 00000078 A5: 01f2948c A6: 01e83aa4 A7: 01f279c8
USP=00000000 ISP=01f279c8 MSP=00000000 VBR=00000000
T=00 S=1 M=0 X=0 N=0 Z=0 V=0 C=0 IMASK=0
FP0: 57,685 FP1: nan FP2: nan FP3: nan
FP4: nan FP5: nan FP6: nan FP7: nan
N=0 Z=0 I=0 NAN=0
0200db92: 2051 21ca 0008 2008 4e75 MOVEA.L (A1),A0
next PC: 0200db94

After I additionally switched "Ignore illegal memory accesses" on, it seems to go longer during installation process, but it's still unable to finish, giving (within Basilisk, which isn't crashing this time) an error message: "The application Installer has unexpectedly quit, because an error of type 25 occured". My config file:

disk /home/zb/Dokumenty/basilisk/dysk_c
disk /home/zb/Dokumenty/basilisk/dysk_d
disk /home/zb/Dokumenty/basilisk/dyskietki/Commands.img
disk /home/zb/Dokumenty/basilisk/dyskietki/Converters.img
disk /home/zb/Dokumenty/basilisk/dyskietki/More Commands.img
disk /home/zb/Dokumenty/basilisk/dyskietki/Program.img
disk /home/zb/Dokumenty/basilisk/dyskietki/Proofing Tools.img
disk /home/zb/Dokumenty/basilisk/dyskietki/Install.img
extfs /
screen win/512/384
seriala /dev/ttyS0
serialb /dev/ttyS1
udptunnel false
udpport 6066
rom /home/zb/Dokumenty/basilisk/Quadra605.ROM
bootdrive 0
bootdriver 0
ramsize 33554432
frameskip 6
modelid 5
cpu 3
fpu true
nocdrom false
nosound false
noclipconversion false
nogui false
jit false
jitfpu true
jitdebug false
jitcachesize 16384
jitlazyflush true
jitinline true
keyboardtype 5
keycodes false
mousewheelmode 1
mousewheellines 3
dsp /dev/dsp
mixer /dev/mixer
ignoresegv true
idlewait true

4. I handled yesterday "Stuffit" problem - the only solution was to find working "Stuffit" in unpacked state. It's available here: ... nder-4-0-2 - fortunately, this iso file can be mounted as another HDD, and this Stuffit copy is functional.

5. Meanwhile I also found out, that it doesn't make much sense to unpack .sit archives on Windows and to try operate their supposed contents after transferring to Basilisk - but after I found working "Stuffit" copy, it turned out this copy of Word 6 is functional, and can be used with no "formal" installation, directly after unpacking, by clicking "Word" icon. Unfortunately, this version of Word doesn't read Word 3 documents - so I'd like to install that Word 5.1 anyway, since these copies ... e-word-1-0 seem to be damaged, Stuffit reports errors during unpack attempt. Or maybe any other source for Word 3 (proven, reliable copy) available?

And another problem to resolve: I noticed I can only attach as "disks" images of 880k Mac floppies - the ones of 350k and 1.4m sizes cannot be read by Basilisk (it wants to initialize/erase them everytime). Why? Can it be fixed somehow?
User avatar
Ronald P. Regensburg
Expert User
Posts: 6455
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: Basilisk II crashes repeatedly

Post by Ronald P. Regensburg »

Description of Error 25:
ID=25 Memory Full Error
You've probably run out of RAM. But you can get this error when an earlier error causes the Macintosh to falsely detect an out-of-memory condition.
You have set RAM size to 32 MB, way too small. Try at least 128 MB.
Last edited by Ronald P. Regensburg on Tue Jan 16, 2018 12:36 pm, edited 1 time in total.
Space Cadet
Posts: 4
Joined: Mon Jan 15, 2018 9:45 pm

Re: Basilisk II crashes repeatedly

Post by Zbig »

So meanwhile I switched to version 1.0rc1 - it didn't help with my problems, but then I followed your RAM-related tip. Started at 128 MB - nothing better, 256 - nothing better, 512 - still nothing better... can you imagine, that only at '1024 MB' setting it finally installed that Word 5.1? And after installation has been done, I was able to reduce memory back to 32 MB, and it works! Thanks for your suggestions, guys - I'll be finally able to convert these old papers.

One more question for the end: what would be your recommendation as a best way of transferring files into "real world" Linux filesystem? I noticed I can't simply move it within Basilisk into "Unix" folders, since file created such way has zero length.

[RESOLVED] - never mind, I admit I didn't check it again after switching to 1.0rc1 - from what I see now it's able to export files into Unix filesystem.
Post Reply