Switch to full style
About BasiliskII, a 68k Mac emulator for Windows, MacOSX, and Linux that can run System 7.x through MacOS 8.1.
Post a reply

Help w/ Basilisk on OS X El Capitan

Sat Apr 28, 2018 9:04 pm

I happened to hit return instead of mouse-click and objects on the desktop began working. I altered the desktop graphic to something bland and it all seems to be working fine. Now I just need to install a game using an ISO file, while I'm waiting for Sheep Saver related downloads to complete so I can have a PPC emulator for a different game. Hopefully, no more help posts are needed.

Hello everyone.

I never used Mac Classic OS until a year back when I needed to look at some early business applications so I know little. However it was enough to examine the apps in question.

Today I started up Basilisk for the first time in a year to re-familiarize myself a little; with the intention of loading games. I also made an alias for the desktop.

Basilisk worked fine the first time; I do not remember if I stated from the GUI, the executable or the alias, but I was able to open applications. I then shut it down as I would not be installing games for several hours.

I am unable to properly re-start. Mac OS 7.5.3 does come up but
* with a warning that it was not properly shut down previously
* there is a large rectangle in the center of the Basilisk screen that is blacked out but with distorted color bars (like old time TV static bars) running across it.
* no functions work -- clicking on applications, the OS, the Unix icon, Documents & Trash folders, etc produce a loud beep (single-note per click) and nothing else.
* the desktop menu -- File, Edit, View, etc is grayed out as is the Apple menu

I Have tried multiple restarts from app, GUI, and alias to no effect. Seemingly something changed but I don't know what nor see how a change could have occurred. The GUI setting seem the same as before although I do not have a copy of the original settings and am relying on memory that may be faulty.

Any help is truly appreciated.


Re: Help w/ Basilisk on OS X El Capitan

Sun Apr 29, 2018 9:28 am

From my experience, vintage Macs used to crash rather frequently.
After a crash, the boot drive was checked by the OS to fix probable minor faults on the HDD.
One would get this or a similar warning with the advice to hit return:


With emulators the file system check became less important as one would usually have a backup of the boot disk image somewhere on the host anyway.

If the above warning disturbs you much, it may be easily disabled via Control Panels / General Controls.
See the little check box in the middle on the left.


Mounting your ISO should be easy. Either add it to the SS volumes tab or move it to the emulated Macs HDD and mount it with this little helper: http://macintoshgarden.org/apps/virtual ... cd-utility

Don´t hesitate to report mishaps or success here, thats what this forum is about, after all. ;)

Re: Help w/ Basilisk on OS X El Capitan

Sun Apr 29, 2018 7:31 pm

Thank you for your detailed help. I was a prisoner of the PC universe from 1983 -- 2008 for professional reasons. I had Mac envy but never knew they crashed. Perhaps that was to maintain parity with Windows ;-)

I followed your advice however I must be doing something incorrectly because--

* Virtual CD…. utility 10d3.img downloaded from http://macintoshgarden.org/apps/virtual ... cd-utility main site

* Clicking on the Virtual CD … icon produced this ERROR MESSAGE
The document “Virtual-CD-DVD-Utility-10d3.img” could not be opened, because the application “Disk Copy” could not be found. Could not find a translation extension with appropriate translators.

* Disk Copy is in a desktop folder named Disk Copy right next to the desktop folder named Vitual CD DVD

* Tried opening Virtual CD - DVD Utility 10d3. img with Disk Copy by dragging the icon

* ERROR MESSAGE: the Mount Image operation did not complete (-36).
The disk “Virtual-CD-DVD-Utility-10d3.img” has a problem. Please try again or use another disk

* re-downloaded Virtual CD .. Utility 10d3 from mirror site

* Repeated all steps above with same results

* Confirmed alll system extensions are turned on

* Rebuilt the desktop

* Repeated all steps as above with same results

My aim is to be able to mount two files this week — one is ISO; the other is TOAST. Both seem to require Virtual CD .. Utility as neither is recognized by Disk Copy

LATER ADDENDUM: I am using Disk Copy 6.1.2 because 6.3.3 produces this ERROR MESSAGE when I attempt to "unstuff" it. The Shrink Wrap Engine has reported an error ERROR -36

Any help is appreciated.


Re: Help w/ Basilisk on OS X El Capitan

Mon Apr 30, 2018 1:37 pm

So I forgot DiskCopy 6 again, hm?
Sadly DC6 is not included in MacOS 7.5.3, but that should be fairly easy to fix.
Best DL the third file here: http://macintoshgarden.org/apps/disk-copy-6
Expand it in El Cap with The Unarchiver and add the resulting img to the volumes with BasiliskIIGUI.app.
When BasilliskII is up and running, you may move the Disk Copy 6.3 folder to your emulators boot drive.

For ISO and Toast:
Did you already try mounting your ISO / Toast by means of the BasiliskIIGUI.app?
Most CD images can be mounted that way, some installers on the CD may refuse to work nevertheless.

To install VirtualCD Imager:
Try DL 2 here: http://macintoshgarden.org/apps/virtual ... cd-utility
Expand it with The Unarchiver: https://the-unarchiver.en.softonic.com/mac.
Finally add it to volumes with BasiliskIIGUI.app.

After booting it should look like this: (hopefully ;) )


Note that the BasiliskIIGUI.app stopped working correctly due to new Apple security schemes.
It is still possible to edit and save the BasiliskII config file.
Running BasiliskII from the BasiliskIIGUI.app fails with Sierra or higher - not sure about El Cap, as I´m not using it right now.

Re: Help w/ Basilisk on OS X El Capitan

Mon Apr 30, 2018 4:08 pm

Thank you!

I am obviously not very familiar with Basilisk. Adding Disk Copy & Virtual CD DVD... and both games -- the ISO and TOAST files as bootable through the GUI works perfectly.

BTW My Mac is actually running Mac OS High Sierra; El Capitan is on a Parallels VM. I needed to install this so I could continue to run older OSX software I use professionally and when I saw Basilisk also not working on M-OS HS I moved it there.

I Have SCUMM VM working perfectly on it also. This week's afterwork project is to add Sheep Shaver and then the Mac version of PCX2. With any luck by the weekend I'm done installing emulators ;-0

Thanks again,

Re: Help w/ Basilisk on OS X El Capitan

Mon Apr 30, 2018 9:39 pm

You may run SheepShaver on HS if you wish, using this workaround as posted by Ronald in the compatibility section:
- macOS 10.12 (Sierra) and later
There is an issue with macOS 10.12 Sierra (in fact with an additional new security feature in Sierra) that prevents a newly installed SheepShaver to run.
The procedure to get it running is simply to copy the program (only the SheepShaver application itself!) to the desktop (and run it once),
remove the old program in the SheepShaver folder and move the new copy from the desktop to the SheepShaver folder.

OSX Server 10.5 or 10.6 in VMWare may be worth a thought too, if you also want to run PPC software.

Re: Help w/ Basilisk on OS X El Capitan

Mon Apr 30, 2018 9:52 pm

Thanks for the tip. I'm going to install on El Capitan because I'll never upgrade this VM. It will always stay at that OS level so I only need to upgrade Parallels as new versions are released. If I can I shall do so tonight. I will post when successful (optimist ;-)
Post a reply