PCE - Mac Plus Emulator

About Mini vMac and all other 68k emulators, including SoftMac, Executor, and MESS.

Moderators: Cat_7, Ronald P. Regensburg

Post Reply
User avatar
ClockWise
Site Admin
Posts: 4016
Joined: Mon May 20, 2002 4:37 am
Location: Uiwang
Contact:

PCE - Mac Plus Emulator

Post by ClockWise »

Has anyone here heard of this:

http://www.hampa.ch/pce/about.html

"PCE/macplus is a Macintosh Plus emulator. It emulates a Macintosh 128K, Macintosh 512k, Macintosh 512ke or a Macintosh Plus."
prowler
Tinkerer
Posts: 49
Joined: Thu May 14, 2009 10:53 pm
Location: Sidcup, England

Post by prowler »

I haven't heard of that emulator before. Thanks for the link, ClockWise!

Mini vMac doesn't boot some Macintosh System disk images I have found, and I can't submit a bug report because I don't own a Mac Plus. It will be useful to try them in another currently-developed emulator.
yksoft1
Master Emulator
Posts: 392
Joined: Tue Aug 14, 2007 4:32 pm
Location: People's Republic of China

Re: PCE - Mac Plus Emulator

Post by yksoft1 »

ClockWise wrote:Has anyone here heard of this:

http://www.hampa.ch/pce/about.html

"PCE/macplus is a Macintosh Plus emulator. It emulates a Macintosh 128K, Macintosh 512k, Macintosh 512ke or a Macintosh Plus."
Compiled PCE/macplus in my MinGW environment with SDL-1.2.13 enabled. It works like SoftMac, however you need to manually edit a config file and use a console to configure it.
Unlike SoftMac, It could boot from Mini vMac/BasiliskII/Sheepshaver disk image, however you need to wait for the SCSI scan before PCE could even find the Mini vMac/BasiliskII/Sheepshaver disk.
Image
Last edited by ClockWise on Mon Sep 07, 2020 9:25 am, edited 2 times in total.
Reason: secure image link
User avatar
ClockWise
Site Admin
Posts: 4016
Joined: Mon May 20, 2002 4:37 am
Location: Uiwang
Contact:

Post by ClockWise »

This emulator was updated yesterday:

http://www.hampa.ch/pce/index.html

Now at version 0.2.0
McIntosh
Tinkerer
Posts: 97
Joined: Thu Jan 06, 2011 10:41 pm

REPLY!!!!!!!!

Post by McIntosh »

pce also uses direct mouse emulation, ignoring windows mouse settings. That way, the mac os mouse settings work perfectly!
User avatar
Cat_7
Expert User
Posts: 5103
Joined: Fri Feb 13, 2004 8:59 am
Location: Sittard, The Netherlands

Re: PCE - Mac Plus Emulator

Post by Cat_7 »

Better late then never:

On 2011-09-07 PCE/macplus has been updated to version 2.1
http://www.hampa.ch/pce/index.html

Best,
Cat_7
OSH
Student Driver
Posts: 10
Joined: Fri Mar 02, 2012 11:46 pm

Re: PCE - Mac Plus Emulator

Post by OSH »

Seems like we have a new version:
http://www.hampa.ch/pce/download.html
Zenchess2
Space Cadet
Posts: 2
Joined: Sun Mar 17, 2013 2:41 pm

Re: PCE - Mac Plus Emulator

Post by Zenchess2 »

edit: below
I got a recent version of this emulator, and it appears to work great, however I can't figure out how to add to the disk images or get it to accept my mniivmac disk images.

My disk images are in .dsk format, this emulator uses .img format. The img disks won't open in hfvexplorer.

Alternatively if someone can figure out how to get the emulator to read .dsk files that would be nice too. I modified the config file to try to load them but there is some error when it comes time to load the disks.

Almost forgot: I am using windows.

edit: Ok, I figured out how i can transfer files to these disk images (open them in basilisk II and copy the files there)

However, I need more memory. In the cfg file there is a config section entitled ram, that looks like this:

# Multiple "ram" sections may be present.
ram {
# The base address
address = 0

# The memory block size
size = 4096K

# The memory block is initialized with this value.
default = 0x00
}

I need 8092 ram I think (to run smalltalk-80). However I tried both increasing the block size to 8092, and adding a new "ram" section, in which i just duplicated the above code but changed the address to 1. Unfortunately I have no idea if "1" is an acceptable value for a memory address :)

does anyone have any ideas?
k-Tracker
Space Cadet
Posts: 4
Joined: Wed Feb 18, 2015 12:12 am

Re: PCE - Mac Plus Emulator

Post by k-Tracker »

My disk images are in .dsk format, this emulator uses .img format. The img disks won't open in hfvexplorer.
IMG to DSK is easy if you're on OSX 10.10 . Install Macfuse and rename both to DMG :) Now you can read and write it. Once complete then rename DMG back to IMG. That method worked great for me.

I have another problem with PCE. Hope, somebody can help me with that.
I want to set up serial port redirection on Windows version and was completely confused by PCE syntax.
it's straight forward on linux

Code: Select all

driver = "tios:file=/dev/ttyS2"
Using same idea on Windows, like \\.\COM3 or \\\\.\\COM3 or COM3, I can't make it working.
The output to a file works great... )
please, help.
User avatar
adespoton
Forum All-Star
Posts: 3107
Joined: Fri Nov 27, 2009 5:11 am
Location: Emaculation.com
Contact:

Re: PCE - Mac Plus Emulator

Post by adespoton »

Does this help?
https://stackoverflow.com/questions/194 ... o-txt-file

It's going the other way, but that just involves flipping the < to a > .
k-Tracker
Space Cadet
Posts: 4
Joined: Wed Feb 18, 2015 12:12 am

Re: PCE - Mac Plus Emulator

Post by k-Tracker »

Great news, PCE developer has sent windows binaries which have serial port support enabled! I tested it works
User avatar
adespoton
Forum All-Star
Posts: 3107
Joined: Fri Nov 27, 2009 5:11 am
Location: Emaculation.com
Contact:

Re: PCE - Mac Plus Emulator

Post by adespoton »

k-Tracker wrote:
My disk images are in .dsk format, this emulator uses .img format. The img disks won't open in hfvexplorer.
IMG to DSK is easy if you're on OSX 10.10 . Install Macfuse and rename both to DMG :) Now you can read and write it. Once complete then rename DMG back to IMG. That method worked great for me.

Forgot to answer this part. DSK, IMG and DMG are container formats, not drive formats. DMG is DiskCopy 6.x -- basically the modern format. IMG is usually DiskCopy 4.3 or NDIF format, and was the standard on the classic Mac for years. DSK is essentially NDIF with the checksum header stripped off -- so it's a raw disk image. Now Disk Utility is set up to handle DMG by default, but recognizes NDIF and other container formats transparently.

But then we get to the tricky part: the format of the disk inside the container. Apple has used MFS, HFS and various flavours of HFS+ over the years. The only thing I've found that has let me manage MFS partitions is Mini vMac with an OS that recognizes MFS.

MacFUSE was a great solution for handling older partition formats under OS X 10.5/10.6, but is incompatible with 10.7+ -- instead, you have to install OSXFUSE for FUSE support. Unfortunately the hfsfuse plugin is statically linked against MacFUSE and won't work under OSXFUSE -- which means no NDIF HFS support under OS X 10.10.

The serial support under Windows is promising though :)
k-Tracker
Space Cadet
Posts: 4
Joined: Wed Feb 18, 2015 12:12 am

Re: PCE - Mac Plus Emulator

Post by k-Tracker »

Can't agree with that. It works for me under 10.10, I have both MacFuse and OSXFUSE running. Don't remember how exactly I did this magic, was lazy to document that at a time. But I have completely NO issues with writing to IMG images now at 10.10.
User avatar
adespoton
Forum All-Star
Posts: 3107
Joined: Fri Nov 27, 2009 5:11 am
Location: Emaculation.com
Contact:

Re: PCE - Mac Plus Emulator

Post by adespoton »

Can you please outline what version of MacFuse and fuseHFS you're using? This is something I would dearly like to get working again. And I've tried all sorts of things, including manually compiling fuseHFS as a filesystem plugin. Still won't help with MFS, but Apple hasn't supported THAT in over 25 years. They supported DOS and ProDOS partitions longer than that.

Oh, and here's the story from the dev side:
http://www.offthehill.org/articles/2010 ... w-leopard/

[edit] and our local thread: http://www.emaculation.com/forum/viewto ... f=7&t=8181

...which of course indicates that I'm getting old :) It works -- sort of -- with OSXFUSE.
k-Tracker
Space Cadet
Posts: 4
Joined: Wed Feb 18, 2015 12:12 am

Re: PCE - Mac Plus Emulator

Post by k-Tracker »

You're right, seems I used that link, I'm running ISXfuse 2.7.2
User avatar
adespoton
Forum All-Star
Posts: 3107
Joined: Fri Nov 27, 2009 5:11 am
Location: Emaculation.com
Contact:

Re: PCE - Mac Plus Emulator

Post by adespoton »

PCE got an update in February. It's now at PCE 20170208-df19414.

Does anyone have an OS X build kicking around? Hampa only has the source and the Windows builds.

Hmm... having said that, it builds pretty easily, and can be dropped into the Windows downloads and run with minimal modifications.

I could probably whip up one of my clickable builds if anyone's interested.
afberendsen
Inquisitive Elf
Posts: 27
Joined: Fri Jul 21, 2017 3:27 am
Location: Berlin, Germany

Re: PCE - Mac Plus Emulator

Post by afberendsen »

What is the configure line to be used for Mac OS X as a host?

Using this:
./configure -with-x --with-sdl --enable-tun --enable-char-ppp --enable-char-tcp --enable-char-slip --enable-char-pty --enable-char-posix --enable-char-termios

fails at

CC src/lib/tun.o
src/lib/tun.c:36:10: fatal error: 'linux/if.h' file not found
#include <linux/if.h>
^
1 error generated.
make: *** [src/lib/tun.o] Error 1
User avatar
adespoton
Forum All-Star
Posts: 3107
Joined: Fri Nov 27, 2009 5:11 am
Location: Emaculation.com
Contact:

Re: PCE - Mac Plus Emulator

Post by adespoton »

It's possible I didn't enable tun on my builds. Either that, or you don't have the tun/tap libraries installed to build against? I think I've got them installed via homebrew.
afberendsen
Inquisitive Elf
Posts: 27
Joined: Fri Jul 21, 2017 3:27 am
Location: Berlin, Germany

Re: PCE - Mac Plus Emulator

Post by afberendsen »

I am trying to compile pce for my Mac OS X 10.13.
I tried two different configurations, which gave me different errors during compilation.

1) With tun/tap

./configure -with-x --with-sdl --enable-tun --enable-char-ppp --enable-char-tcp --enable-char-slip --enable-char-pty --enable-char-posix --enable-char-termios

Code: Select all

  CC     src/lib/tun.o
src/lib/tun.c:36:10: fatal error: 'linux/if.h' file not found
#include <linux/if.h>
         ^~~~~~~~~~~~
1 error generated.
make: *** [src/lib/tun.o] Error 1
Installing tup/tap now follows a different path:

Code: Select all

$ brew tap homebrew/cask
$ brew cask install tuntap
which fails with

Code: Select all

==> Failed command:
/usr/bin/sudo -E -- /usr/sbin/installer -pkg /usr/local/Caskroom/tuntap/20150118/tuntap_20150118.pkg -target /
There is no tuntap under Caskroom

Code: Select all

$ ls /usr/local/Caskroom
rar
2) Without tun/tap

./configure -with-x --with-sdl --enable-char-ppp --enable-char-tcp --enable-char-slip --enable-char-pty --enable-char-posix --enable-char-termios

It fails with...

Code: Select all

  LD     src/arch/atarist/pce-atarist
Undefined symbols for architecture x86_64:
  "_tun_close", referenced from:
      _chr_ppp_open in char-ppp.o
      _chr_ppp_close in char-ppp.o
      _chr_slip_close in char-slip.o
  "_tun_open", referenced from:
      _chr_ppp_open in char-ppp.o
      _chr_slip_open in char-slip.o
ld: symbol(s) not found for architecture x86_64
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make: *** [src/arch/atarist/pce-atarist] Error 1
3) Forcing to disable tun/tap

Code: Select all

./configure -with-x --with-sdl --enable-char-ppp --enable-char-tcp --enable-char-slip --enable-char-pty --enable-char-posix --enable-char-termios --disable-tun
...
  Sound drivers built:     null wav
  Sound drivers not built: oss sdl
  Enabled options:
  Disabled options:        readline tun
Fails with the same error.

Code: Select all

  LD     src/arch/atarist/pce-atarist
Undefined symbols for architecture x86_64:
  "_tun_close", referenced from:
      _chr_ppp_open in char-ppp.o
      _chr_ppp_close in char-ppp.o
      _chr_slip_close in char-slip.o
  "_tun_open", referenced from:
      _chr_ppp_open in char-ppp.o
      _chr_slip_open in char-slip.o
ld: symbol(s) not found for architecture x86_64
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make: *** [src/arch/atarist/pce-atarist] Error 1
Any suggestions on how I can compile pce for my Mac OS X 10.13?
afberendsen
Inquisitive Elf
Posts: 27
Joined: Fri Jul 21, 2017 3:27 am
Location: Berlin, Germany

Re: PCE - Mac Plus Emulator

Post by afberendsen »

I managed to have a clean compilation. The binary seems to be working. However, when I tried to use the ready-made packages it doesn't show any output besides the log .

Code: Select all

$ ./configure -with-x --with-sdl --disable-char-ppp --enable-char-tcp --disable-char-slip --enable-char-pty --enable-char-posix --enable-char-termios --disable-tun
$ make
$ make install
afberendsen
Inquisitive Elf
Posts: 27
Joined: Fri Jul 21, 2017 3:27 am
Location: Berlin, Germany

Re: PCE - Mac Plus Emulator

Post by afberendsen »

Ok. I managed to compile and make it work...

Code: Select all

./configure ; make clean ; make ; make install
User avatar
macplus
Inquisitive Elf
Posts: 31
Joined: Sat Feb 04, 2017 5:12 am
Location: Argentina

Re: PCE - Mac Plus Emulator

Post by macplus »

I wonder if someone can make a GUI for it, it looks pretty good.
Compact Macs will rule supreme for all eternity! :twisted:
Post Reply