Login  •  Register


The time is now: Thu Jul 09, 2020 5:41 am

Emaculation wiki  •  Delete all board cookies



Post new topic  Reply to topic Page 1 of 1 [ 9 posts ]
Print view Previous topic  |  Next topic
Author Message
PostPosted: Fri Dec 02, 2005 5:12 pm 
Offline
Space Cadet

Joined: Fri Dec 02, 2005 5:08 pm
Posts: 3
Greetings,

I was just curious if anyone knew when a version of Sheepshaver would be available for Mac OS X Tiger. I'm actually running 10.4.3 and I'd like to use Sheepshaver to run some of my games that won't run under Classic mode. Any ideas?

Thanks,
Dean


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Fri Dec 02, 2005 5:40 pm 
Offline
Master Emulator

Joined: Sun Jan 25, 2004 3:49 pm
Posts: 377
Location: Canada
http://gibix.net/projects/sheepshaver/f ... 30.tar.bz2
this build is dated 2005 november 30 so it should be what you are looking for


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Sat Dec 03, 2005 1:18 am 
Offline
Expert User
User avatar

Joined: Fri Feb 13, 2004 8:59 am
Posts: 4904
Location: Sittard, The Netherlands
I just got it running on 10.3.9, so maybe Tiger will work as well...

Cat_7


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Sat Dec 03, 2005 10:03 pm 
Offline
Space Cadet

Joined: Fri Dec 02, 2005 5:08 pm
Posts: 3
Cat_7,

What did you do to get it running in 10.3.9? I downloaded it, expanded it and set up the path to the Rom image and everything else, whether or not I did it correctly is questionable, and all it does is go right back to the desktop, no error message no nothing.

Could you provide me a sample of your SheeShaver pref file? Maybe I did something wrong there.

Thanks,
Dean


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Sat Dec 03, 2005 11:16 pm 
Offline
Expert User
User avatar

Joined: Fri Feb 13, 2004 8:59 am
Posts: 4904
Location: Sittard, The Netherlands
Hi Dean,

What I did:

-I installed in a folder "SheepShaver-2.3" in my home folder.
-I copied a working 1GB Hard Disk image with OS 9 from Windows (don't know how to create a Hard Disk file in OSX yet)
-Edit the config file (see below)
-Use a teminal window to rename it to .sheepshaver_prefs (notice the . ). Mac OSX does not show the file afterwards, as it becomes a system file.
-Copy the config file to my user home directory from a terminal window

This is my config file:
rom /Volumes/MacOSX103/Users/hsp/SheepShaver-2.3/macos8.6.rom
disk /Volumes/MacOSX103/Users/hsp/SheepShaver-2.3/SheepShaverHD
extfs /Volumes/MacOSX103/Users/hsp/
screen win/800/600
bootdrive 0
bootdriver 0
#ramsize 67108864 To much for my system with only 288Mb
ramsize 50331648
#ramsize 33554432 not enough for IE 5
frameskip 6
gfxaccel true
nocdrom false
nonet false
ether slirp
nosound true
nogui true
ignoresegv false
jit false
keycodes true
keycodefile /Volumes/MacOSX103/Users/hsp/SheepShaver-2.3/keycodes.sdl

SheepShaver really runs fast on a PowerMac. Networking with slirp also works great. Much faster then in my Linux system. Set TCP/IP to:
-connect via ethernet
-configure through DHCP.

Good luck!
Cat_7


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Fri Dec 16, 2005 7:58 am 
Offline
Space Cadet

Joined: Thu Dec 15, 2005 11:31 pm
Posts: 2
Hi,

I've gotten SheepShaver working using Mac OS 8.6 on my iBook G4 running Mac OS 10.4.3 except for one problem.

Whenever I start SheepShaver, it gives an error message about the application quitting unexpected. However, the SS window never disappears and it keeps loading. If I just close the error dialog, I can use SS just fine.

I looked at the crash log and this is what it gives for the first few lines:

Code:
Host Name:      Vector
Date/Time:      2005-12-14 17:09:51.868 -0500
OS Version:     10.4.3 (Build 8F46)
Report Version: 3

Command: SheepShaver
Path:    /Applications/SheepShaver/SheepShaver.app/Contents/MacOS/SheepShaver
Parent:  WindowServer [62]

Version: ??? (2.3)

PID:    511
Thread: 0

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x40810000


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Fri Dec 16, 2005 8:45 am 
Offline
Expert User
User avatar

Joined: Fri Feb 13, 2004 8:59 am
Posts: 4904
Location: Sittard, The Netherlands
Yes,

I believe that is normal behaviour for now :lol:

Cat_7


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Mon Jan 02, 2006 5:51 pm 
Offline
Space Cadet

Joined: Fri Dec 02, 2005 5:08 pm
Posts: 3
NETKnightX,

can you tell me how you're pref file for Sheepshaver is set up? Since you're also running OS X 10.4.3 you might be able to help me. I'm sure I'm doing something wrong but I don't know what.

I'm trying to get Sheepshaver running on a Mac Mini G4/1.42GHz/512MB ram.

Thanks in advance for any help you can provide.

Dean


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Mon Jan 02, 2006 10:05 pm 
Offline
Expert User
User avatar

Joined: Fri Feb 13, 2004 8:59 am
Posts: 4904
Location: Sittard, The Netherlands
Hi,

Did my description of actions and example config file not help you?

What is going wrong?

Cat_7


Top
 Profile  
Reply with quote Post a reply  
Display posts from previous:  Sort by  
Post new topic  Reply to topic Page 1 of 1 [ 9 posts ]


Who is online

Users browsing this forum: No registered users and 24 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
 

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group