Compatibility

Anything about Mac emulation that does not belong in the above categories.

Moderators: Cat_7, Ronald P. Regensburg

Post Reply
HEH
Space Cadet
Posts: 3
Joined: Sun May 13, 2018 10:54 am
Location: Utrecht, Netherlands

Compatibility

Post by HEH »

I am new to this forum, but not new to emulation and/or the Mac platform, on the contrary. But having been off-side for a while, perhaps someone can give me a brief feedback on the status of different products. I am currently running10.11.6 on a MacBook Pro 2010/corei5. For my work I have to switch to Sierra or High Sierra.

Can BasiliskII and Sheepshaver run on these newer OSes?
User avatar
i886
Space Cadet
Posts: 8
Joined: Thu Mar 22, 2018 9:29 am

Re: Compatibility

Post by i886 »

Yes, sure ! :razz:
HEH
Space Cadet
Posts: 3
Joined: Sun May 13, 2018 10:54 am
Location: Utrecht, Netherlands

Re: Compatibility

Post by HEH »

Would I not run into issues with the APFS filesystem?
User avatar
adespoton
Forum All-Star
Posts: 3308
Joined: Fri Nov 27, 2009 5:11 am
Location: Emaculation.com
Contact:

Re: Compatibility

Post by adespoton »

Nope; you'd run into problems with the security architecture, but that's all documented on the Wiki in the setup guide. APFS is transparent from the userland standpoint; it only makes a difference to the OS, which has more capabilities and speed using APFS on SSDs.

Also, QEMU-PPC can now boot 9.0.4 through 10.5.6, with work in progress to boot 8.6 and earlier as well. I find that for what I do, QEMU works better than PearPC after last autumn's speed boost. Work is still ongoing to get optimized audio, ADB, video and networking into the same build.
Post Reply