Login  •  Register


The time is now: Thu Jul 02, 2020 3:59 pm

Emaculation wiki  •  Delete all board cookies



Post new topic  Reply to topic Page 10 of 11 [ 254 posts ]    Go to page Previous  1 ... 7, 8, 9, 10, 11  Next
Print view Previous topic  |  Next topic
Author Message
PostPosted: Fri Mar 20, 2020 12:45 pm 
Offline
Tinkerer
User avatar

Joined: Mon Oct 31, 2016 11:56 pm
Posts: 48
Location: Prague or space village in woods near of it
OK just try to run qemu-system-ppc.exe vanilla without parameters, if it report this error too, if not add parameters one by one to find which is generating this error.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Sun Mar 22, 2020 8:30 am 
Offline
Expert User
User avatar

Joined: Fri Feb 13, 2004 8:59 am
Posts: 4900
Location: Sittard, The Netherlands
Hi,

Yes, I see this error too in a windows 7 virtual machine. No real idea what causes it. But if I had to guess, it has something to do with the dll's included in the compiler on Fedora Linux I use to build those executables.

Non-experimental builds do run (but only without -sdl)

Best,
Cat_7


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Sun Mar 22, 2020 3:45 pm 
Offline
Space Cadet

Joined: Wed Mar 18, 2020 11:23 pm
Posts: 3
Thank you for the help but it's doesn't work. I get the error even with no parameters in the bat file.

I've tried other builds and different boot iso's too.

Either I get the GDI32 error or I just get a blank cmd32 window that never goes away.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Tue Mar 24, 2020 10:03 am 
Offline
Student Driver

Joined: Sat May 06, 2017 6:40 pm
Posts: 22
Hi Cat_7,

I'm trying to compile latest version of binaries for Linux but for some reason it fails downloading sources from git.
How I would compile latest experimental version or both? Are there different, separate sources or parameters to compile?

Regards
Thom


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Tue Mar 24, 2020 11:32 am 
Offline
Expert User
User avatar

Joined: Fri Feb 13, 2004 8:59 am
Posts: 4900
Location: Sittard, The Netherlands
Hi,

Which repositories are you using?

Best,
Cat_7


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Tue Mar 24, 2020 11:40 am 
Offline
Student Driver

Joined: Sat May 06, 2017 6:40 pm
Posts: 22
Hi Cat_7,
I'm using same as last time.

thom75 wrote:
Code:
git clone -b screamer https://github.com/mcayland/qemu qemu-screamer
cd qemu-screamer
./configure --target-list="ppc-softmmu" --enable-gtk --enable-sdl
make
cd ppc-softmmu
strip qemu-system-ppc



Kind regards,
Thom


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Tue Mar 24, 2020 12:18 pm 
Offline
Expert User
User avatar

Joined: Fri Feb 13, 2004 8:59 am
Posts: 4900
Location: Sittard, The Netherlands
Concerning the Windows 7 problem:

I tried building from the official repository and such a build also fails on windows 7. So it is not related to the screamer code.
As the GDI32 dll is a windows dll I assume my compiler/qemu are now relying on the version that is available in Windows 10.

Besides the obvious inconvenience that this presents to Windows 7 users, I would remark that Windows 7 is almost obsolete.

Best,
Cat_7


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Tue Mar 24, 2020 12:38 pm 
Offline
Tinkerer
User avatar

Joined: Mon Oct 31, 2016 11:56 pm
Posts: 48
Location: Prague or space village in woods near of it
If you know where pleas report bug report, some people are using Windows 7 just because they dont like Windows 10 appearance or data telemetry.
I search a lot, but i never found some nice Qemu forum, they should be something like that, they probably still living in age of mailing list and IRC, what is in direct contraction to not support Windows 7 which even MS still supporting.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Tue Mar 24, 2020 1:05 pm 
Offline
Expert User
User avatar

Joined: Fri Feb 13, 2004 8:59 am
Posts: 4900
Location: Sittard, The Netherlands
I guess you might try the official windows builds from Stefan Weil. Note his builds do not support sound, as the code for that is not in the official repository. Also, our guides do not cover them.

https://qemu.weilnetz.de/

Bug reports should go to the bugtracker: https://bugs.launchpad.net/qemu/
EDIT: I suggest you do not send there bug reports based on the builds we provide.

Best,
Cat_7


Last edited by Ronald P. Regensburg on Tue Mar 24, 2020 2:39 pm, edited 2 times in total.
added info on bug reports


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Tue Mar 24, 2020 3:09 pm 
Offline
Expert User
User avatar

Joined: Fri Feb 13, 2004 8:59 am
Posts: 4900
Location: Sittard, The Netherlands
Hi Thom,

Those instructions should still work. It might be you experienced a time-out on the download from those additional repositories. Sometimes happens to me as well. Just try again after a while.

Best,
Cat_7


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Wed Mar 25, 2020 9:13 pm 
Offline
Student Driver

Joined: Sat May 06, 2017 6:40 pm
Posts: 22
Hi Cat_7,

It stops around 20-21% with this message:

Code:
Cloning into 'qemu-screamer'...
remote: Enumerating objects: 476200, done.
error: RPC failed; curl 56 OpenSSL SSL_read: error:14095126:SSL routines:ssl3_read_n:unexpected eof while reading, errno 0
fatal: the remote end hung up unexpectedly
fatal: early EOF
fatal: index-pack failed


Tried yesterday and today no difference, two different PCs.
Btw is that repository with ATI and Screamer or just Screamer?

Edit: It must be my connection. Asked friend of my and He just downloaded it fine.

Regards
Thom


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Thu Mar 26, 2020 2:41 pm 
Offline
Expert User
User avatar

Joined: Fri Feb 13, 2004 8:59 am
Posts: 4900
Location: Sittard, The Netherlands
I have now compiled latest qemu /qemu with screamer sound support with msys2. At least in my virtual machine with Windows 7, they run OK.

Find them here (under experimental builds):
viewtopic.php?f=34&t=9028&p=53788#p53788

Best,
Cat_7


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Thu Mar 26, 2020 3:30 pm 
Offline
Expert User
User avatar

Joined: Fri Feb 13, 2004 8:59 am
Posts: 4900
Location: Sittard, The Netherlands
@Thom

Both screamer and regular qemu now "support" the ati card. You will need, however, the openbios from our ati-related download to run with the ati card enabled.

EDIT:
I got a message from the developer saying:
the ATI bios may not be enough for MacOS with current upstream QEMU
because I think this patch is still needed to fix some mouse issues:

http://patchwork.ozlabs.org/patch/1147878/

and that was not taken in QEMU yet. But there's also absolutely no
advantage using ati-vga vs. standard vga yet as it's still using the same
unaccalerated framebuffer because the parts of the card needed for
accelerated graphics are not yet emulated so anyone interested in using
ati-vga might want to read here:

https://osdn.net/projects/qmiga/wiki/SubprojectAti

(and help to finish emulation if they are able to).

Best,
Cat_7


Last edited by Cat_7 on Fri Mar 27, 2020 9:02 pm, edited 1 time in total.
added info from developer


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Fri Apr 10, 2020 8:23 pm 
Offline
Space Cadet
User avatar

Joined: Thu Nov 22, 2018 7:51 pm
Posts: 3
Hey Cat_7
You can ask to build version 5.0.0 rc2 for Windows, apparently it is faster and AmigaOS4.1FE does not work on version rc0 (MorphOS3.11 works)
Thanks.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Thu Apr 16, 2020 8:19 am 
Offline
Expert User
User avatar

Joined: Fri Feb 13, 2004 8:59 am
Posts: 4900
Location: Sittard, The Netherlands
New Windows build from Qemu 5.0 RC3 code is available in the first post under experimental builds.
Not tested in Windows 7.

Best,
Cat_7


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Fri Apr 17, 2020 6:23 pm 
Offline
Space Cadet
User avatar

Joined: Thu Nov 22, 2018 7:51 pm
Posts: 3
Thanks!
Works on Windows 10 64bit, not work Windows 7 64bit (gdi32.dll problem)


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Mon Apr 20, 2020 3:51 am 
Offline
Space Cadet

Joined: Fri May 17, 2019 4:27 am
Posts: 7
Hi Dear Cat_7:
I have a problem in installing MacOS9.2 to the "Qemu 4.2 with screamer sound support" experimental build edition,when I execute the .bat file it comes as "dsound: Could not initialize DirectSoundCapture" and "dsound: Reason: No sound driver is available for use, or the given GUID is not a valid DirectSound device ID".And my operating system is Win10 64bit edition, Do you have any idea in solving this problem? Thank you!
Thanks,
Vonvan Row.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Mon Apr 20, 2020 4:34 am 
Offline
Tinkerer
User avatar

Joined: Mon Oct 31, 2016 11:56 pm
Posts: 48
Location: Prague or space village in woods near of it
Its own problem that Qemu 4.2 has broken sound on windows.

There some diff files for source fixing:
https://www.vogons.org/viewtopic.php?p=817904#p817904


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Mon Apr 20, 2020 4:43 am 
Offline
Space Cadet

Joined: Fri May 17, 2019 4:27 am
Posts: 7
Thank you for replying me,I had download two diff files,but I don't know where should I put it in.Thank you!


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Mon Apr 20, 2020 7:38 am 
Offline
Expert User
User avatar

Joined: Fri Feb 13, 2004 8:59 am
Posts: 4900
Location: Sittard, The Netherlands
You cannot simply put those files somewhere and expect things to work. You would need to compile qemu yourself with those patches applied. I believe the current qemu source has these (or at least comparable) fixes included.

I think you error might be caused by windows 10 not allowing access to your microphone (even though Qemu-system-ppc cannot use it).

To Fix: Click Start, go to ⚙ Settings> Privacy Settings> Microphone. Turn On "Allow apps to access your microphone"
(https://stackoverflow.com/questions/536 ... on-windows)

Best,
Cat_7


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Mon Apr 20, 2020 8:44 am 
Offline
Space Cadet

Joined: Fri May 17, 2019 4:27 am
Posts: 7
Cat_7 wrote:
You cannot simply put those files somewhere and expect things to work. You would need to compile qemu yourself with those patches applied. I believe the current qemu source has these (or at least comparable) fixes included.

I think you error might be caused by windows 10 not allowing access to your microphone (even though Qemu-system-ppc cannot use it).

To Fix: Click Start, go to ⚙ Settings> Privacy Settings> Microphone. Turn On "Allow apps to access your microphone"
(https://stackoverflow.com/questions/536 ... on-windows)

Best,
Cat_7

Thank you for replying me,I did the same you say,but it did't work,and my qemu still turn out "dsound: Could not initialize DirectSoundCapture".Can you help me?
Thank you a lot!
Vonvan Row


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Mon Apr 20, 2020 10:47 am 
Offline
Space Cadet

Joined: Fri May 17, 2019 4:27 am
Posts: 7
nasdaq8810 wrote:
Cat_7 wrote:
You cannot simply put those files somewhere and expect things to work. You would need to compile qemu yourself with those patches applied. I believe the current qemu source has these (or at least comparable) fixes included.

I think you error might be caused by windows 10 not allowing access to your microphone (even though Qemu-system-ppc cannot use it).

To Fix: Click Start, go to ⚙ Settings> Privacy Settings> Microphone. Turn On "Allow apps to access your microphone"
(https://stackoverflow.com/questions/536 ... on-windows)

Best,
Cat_7

Thank you for replying me,I did the same you say,but it did't work,and my qemu still turn out "dsound: Could not initialize DirectSoundCapture".Can you help me?
Thank you a lot!
Vonvan Row


Dear Mr Cat_7,you are right when I re-install my audio drive it works,but there is still a problem that the sound is broken,do you have any idea about this?

Thanks!


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Mon Apr 20, 2020 2:00 pm 
Offline
Tinkerer
User avatar

Joined: Mon Oct 31, 2016 11:56 pm
Posts: 48
Location: Prague or space village in woods near of it
Patch should fix both dsound message error and broken sound.. but if you have half broken sound with screamer its normal.

These files are some simple patch, you have to download source, add text from diff files into it and build it, its not easy.


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Fri May 01, 2020 8:58 am 
Offline
Expert User
User avatar

Joined: Fri Feb 13, 2004 8:59 am
Posts: 4900
Location: Sittard, The Netherlands
2 new qemu-system-ppc sound-enabled builds for Windows have landed:

viewtopic.php?f=34&t=9028&p=53788#p53788
(find them under experimental builds)

Note that they are both still experimental, and in the case of the build with fpu speed-up even extremely experimental as no guarantee is provided for correct fpu results.

Happy testing,
Cat_7


Top
 Profile  
Reply with quote Post a reply  
PostPosted: Fri May 01, 2020 3:24 pm 
Offline
Student Driver

Joined: Thu May 10, 2007 7:54 am
Posts: 24
I just wanna ask, are those experimental windows builds going to be ported to osx too ? It is just something to wonder about, emulating on older apple os apparently grows quicker on a Microsoft platform ? Really some paradox no ?


Top
 Profile  
Reply with quote Post a reply  
Display posts from previous:  Sort by  
Post new topic  Reply to topic Page 10 of 11 [ 254 posts ]    Go to page Previous  1 ... 7, 8, 9, 10, 11  Next


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
 

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group