Issues with game/emulation speed

About BasiliskII, a 68k Mac emulator for Windows, MacOSX, and Linux that can run System 7.x through MacOS 8.1.

Moderators: Cat_7, Ronald P. Regensburg

Post Reply
aglr
Space Cadet
Posts: 3
Joined: Sun Mar 07, 2021 1:35 pm

Issues with game/emulation speed

Post by aglr »

Hi all - I'm new here; I just got BII running on my Windows 10 PC in order to try and play and old game from my childhood. I have the OS and game running just fine for the most part - however, there's a slight issue with the (frame?) speed of the program, which may be with the game or with the OS itself. The speed is generally slow and somewhat inconsistent; weirdly, it seems to be tied to mouse movement speed, so the faster I move the mouse, the faster the game moves, but only up to a point.

Not sure if I'm explaining this well, but the gist is that the game speed is inconsistent, and tends to be slightly faster when I move my mouse around a lot. So I'm getting intermittent slowdown whenever the mouse is still. From memory, the max speed reached by moving my mouse around is the original speed of the game, and ideally I'd like to have it running consistently at that speed, or something close to it, rather than slowing down slightly every time I stop moving the mouse around. It's not a terribly serious issue, but it's mildly annoying, and I was wondering about ways to fix it. Is there anything i could perhaps try to resolve this, or is it something I'll have to deal with?

Thanks in advance.
User avatar
adespoton
Forum All-Star
Posts: 3428
Joined: Fri Nov 27, 2009 5:11 am
Location: Emaculation.com
Contact:

Re: Issues with game/emulation speed

Post by adespoton »

It could be one of a number of issues: First up: which build of Basilisk II are you using? Which host OS? How fast is your processor?

Then we need to check the screen resolution options, whether you're in windowed or full-screen mode, whether JIT is disabled.

After that, we need to know which game (including version #) and guest OS version you're using.
aglr
Space Cadet
Posts: 3
Joined: Sun Mar 07, 2021 1:35 pm

Re: Issues with game/emulation speed

Post by aglr »

Thanks for the response - I'll try to provide all the information I can.

I'm fairly sure it's the most recent build of BII that I downloaded from this post here: viewtopic.php?t=5282

Host OS: Windows 10 pro (OS build 19041.804), and the emulator is running Mac OS 8.1.
CPU: AMD Ryzen 5 2600 @ 3.6GHz
Emulator resolution: 1333x1000, so that windowed mode fits neatly into my 1080p monitor.

I'm using windowed mode, and I've experimented with turning JIT compiler on and off, which doesn't seem to make a difference.

The game is Squish 2.6.8, and it's on Mac OS 8.1.

Hope this helps - thanks again.
aglr
Space Cadet
Posts: 3
Joined: Sun Mar 07, 2021 1:35 pm

Re: Issues with game/emulation speed

Post by aglr »

Update: I appear to have resolved the issue. I went into the Memory/Misc tab of the GUI and unchecked "Don't use CPU when idle." The program must have figured that if I'm not moving the mouse, then the system is idle, and that caused slowdown with a still mouse in the game. Now it seems to be running as smoothly as possible.
Post Reply