SS quits on startup (sorry!)

About SheepShaver, a PPC Mac emulator for Windows, MacOS X, and Linux that can run System 7.5.3 to MacOS 9.0.4.

Moderators: Cat_7, Ronald P. Regensburg, ClockWise

Post Reply
Maury Markowitz
Space Cadet
Posts: 1
Joined: Thu Jun 03, 2021 4:19 pm

SS quits on startup (sorry!)

Post by Maury Markowitz »

I'm sorry to have to post this, because I see the internet seems to be filled with many examples of this question and I'm sure I'm not adding to the corpus. But it seems I have followed the instructions and the app still quits on startup. I'm on a trashcan Mac Pro running 11.3.

Following the "builds and downloads" post pinned to the top of this forum, I downloaded the latest 2.5 April SS build and the SheepShaver folder. I placed the SS folder in my home directory and copied the SS app into the SS folder.

Following the "Setting up SheepShaver for OSX/macOS" I went to Macintosh Garden and downloaded MacOS904CD_Intl.ZIP. Extracting that results in a file called Mac OS 9-2.toast, which I copied into the SS folder "beside" SS app. I have also tried it within the Shared folder as one YT video suggested.

I tried to follow the guide's suggestion to go to "redundant robot sheepshaver" and grabbed both new and old-world ROMs I took the new-world, renamed it "Mac OS ROM" and placed that in the SS folder as well. It is 1.9 MB and called newworld86.rom, is that correct?

So far, have I successfully followed the guide?

I then opened the SS app. It gave me the warning about being from the 'net, I said OK, and then it immediately exits.

Reading the guide, it appears this implies it is having problems finding the ROM or it is the wrong version. I tried the old-world ROM (mac_oldworld_rom4mb, ~4 MB?) and that did not work either.

Please tell me I missed a step somewhere? If not, is there any way to debug this?
User avatar
Ronald P. Regensburg
Expert User
Posts: 6976
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: SS quits on startup (sorry!)

Post by Ronald P. Regensburg »

1. If you renamed the rom file "newworld86.rom" to "Mac OS ROM" in the Finder, the extension .rom will be hidden instead of removed. You can check in Finder Info if the name is now "Mac OS ROM" or "Mac OS ROM.rom". If the extension is still there, remove it in the Finder Info panel.
(Finder Info: Select the file icon and hit command-I)

2. If the rom file name is correct and SheepShaver still quits on launch, try this:
- Copy the SheepShaver app to a different location (like your desktop)
- Trash the original app
- Move the copy back to where the original was (in the SheepShaver folder).
Post Reply