Weird underscan request - Raspberry Pi 3

About BasiliskII, a 68k Mac emulator for Windows, MacOSX, and Linux that can run System 7.x through MacOS 8.1.

Moderators: Cat_7, Ronald P. Regensburg

Post Reply
panman_gr
Space Cadet
Posts: 1
Joined: Sat Apr 23, 2022 10:50 am

Weird underscan request - Raspberry Pi 3

Post by panman_gr »

Hello everybody,

I've been setting up an empty Classic shell with a TFT and SheepShaver/Basilisk on a Raspberry Pi 3b+. Problem is, an 8 inch TFT is too small and the 3D-printed frame would be visible, so I made a frame for a 10 inch TFT, and some pixels are hidden behind the frame. The TFT's native resolution is 1024x768, but only a central 960x704 window is visible, due to the Classic's bezel being in the way.

When I run SheepShaver from the Raspbian GUI, having fixed the overscan options in /boot/config.txt, the 960x704 resolution is being respected, and the rest is just black:
Image

But, when i run Basilisk from the command line (raspbian lite/SDL2 build) no matter what "screen" line i put in the prefs file, regardless of the overscan options in /boot/config.txt, Basilisk scales it to fill the screen all the way to the edges:
Image

The whole idea being I'd like to have the "ultimate pre-OSX machine", I've also silenced everything else so that it goes directly into Basilisk at startup without even showing it's a Raspberry Pi, so it would be great if I could also make it respect the Raspberry Pi's overscan setup, so it only displays on the visible parts. Any ideas on a fix?
Thank you :smile:
galgot
Granny Smith
Posts: 115
Joined: Thu Feb 13, 2014 3:59 pm

Re: Weird underscan request - Raspberry Pi 3

Post by galgot »

Have no idea how to fix this sorry. I mean if I understand correctly what you want to do, cropping the screen image so it fit in BasiliskII ?
I have the same kind of setup, but I used a 9", and I think it's 4:3 ratio, so it fit alright. Bought it long ago... can't find the exact model on the bay now.
More recent models are like these :
https://www.ebay.com/itm/255128337595?h ... SwoOdhOfYI
but they are 16:9 ratio...
Post Reply