Building Basikisk II for Raspberry Pi

About BasiliskII, a 68k Mac emulator for Windows, MacOSX, and Linux that can run System 7.x through MacOS 8.1.

Moderators: Cat_7, Ronald P. Regensburg

Post Reply
bfranske
Space Cadet
Posts: 3
Joined: Thu Nov 18, 2021 5:12 pm

Building Basikisk II for Raspberry Pi

Post by bfranske »

Are there any tips for building Basilisk II for the Raspberry Pi? I'm going to run the Pi booting straight into Basilisk II so my preference is to run without X if possible. It seems, from what I have gathered, this was possible at least at some point in the past but I have been unsuccessful in building and running it thus far. In particular when trying to run it after compiling I get two SDL errors about "SDL_SetWindowGammaRamp returned -1, SDL error: That operation is not supported" followed by a "WARNING: RmvTime(000f11d6): Descriptor not found" and then nothing.
User avatar
adespoton
Forum All-Star
Posts: 4273
Joined: Fri Nov 27, 2009 5:11 am
Location: Emaculation.com
Contact:

Re: Building Basikisk II for Raspberry Pi

Post by adespoton »

https://duckduckgo.com/?q=SDL2+without+X11 returns a couple of semi-useful links; looks like you need to use SDL2 targeting the frame buffer instead of X. Should be possible, but may require a bit of tweaking.
nexusle
Student Driver
Posts: 14
Joined: Wed Aug 13, 2014 5:37 am

Re: Building Basikisk II for Raspberry Pi

Post by nexusle »

To build Basilisk II (and SheepShaver; see on the corresponding thread) on Raspberry PI OS lite, follow these steps:

Code: Select all

sudo apt install git libsdl2* automake samba samba-common smbclient libmpc-dev -y
git clone https://github.com/kanjitalk755/macemu.git

cd ./macemu

cd BasiliskII/
cd src/Unix/
sudo nano ether_unix.cpp
skip to line 324 and kill the following lines (to use slirp without sudo)

Code: Select all

}

        // Don't raise SIGPIPE, let errno be set to EPIPE
        struct sigaction sigpipe_sa;
        if (sigaction(SIGPIPE, NULL, &sigpipe_sa) == 0) {
                assert(sigpipe_sa.sa_handler == SIG_DFL || sigpipe_sa.sa_handler == SIG_IGN);
                sigfillset(&sigpipe_sa.sa_mask);
                sigpipe_sa.sa_flags = 0;
                sigpipe_sa.sa_handler = SIG_IGN;
                sigaction(SIGPIPE, &sigpipe_sa, NULL);

Code: Select all

NO_CONFIGURE=1 ./autogen.sh
./configure --enable-sdl-video --enable-sdl-audio --disable-vosf --disable-jit-compiler
sudo make install
Post Reply