Installation program works under 7.6.1 and 8.6, not 9.0.4

About SheepShaver, a PPC Mac emulator for Windows, MacOS X, and Linux that can run System 7.5.3 to MacOS 9.0.4.

Moderators: Cat_7, Ronald P. Regensburg, ClockWise

Post Reply
emendelson
Forum All-Star
Posts: 1230
Joined: Tue Oct 14, 2008 12:12 am

Installation program works under 7.6.1 and 8.6, not 9.0.4

Post by emendelson »

Here's a mystery I wonder if anyone can help solve.

This archive contains the Mac version of Word for Word, a file format conversion program originally from Mastersoft, and bought by Adobe and released in 1996, and then abandoned a year or two later:

http://www.columbia.edu/~em36/Word-For-Word-7.2.sit

The installer works correctly under System 7.6.1 and 8.6, but under 9.0.4, it displays an error message asking me to mount a disk (a folder with the name of that disk is in the same folder with the installer, and seems to be all that the installer needs under 7.6.1 and 8.6).

Since I can install the program under 8.6 and copy that folder to my 9.0.4 setup, this isn't really urgent (although an extension doesn't get installed under 9.0.4 this way), but can anyone think of a way around the problem? I tried starting with extensions off, on the off-chance that it might help, but it didn't.

Thanks for any insights.
User avatar
Ronald P. Regensburg
Expert User
Posts: 6348
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: Installation program works under 7.6.1 and 8.6, not 9.0.

Post by Ronald P. Regensburg »

Not sure what is the difference with how you did the installation, but the installation proceeds fine here in MacOS 9.0.4 in SheepShaver without an error message.
emendelson
Forum All-Star
Posts: 1230
Joined: Tue Oct 14, 2008 12:12 am

Re: Installation program works under 7.6.1 and 8.6, not 9.0.

Post by emendelson »

That's very strange! I've tried it on three or four different OS 9 setups (one of them a clean, default US English system, the others with added applications) and I get the same error on all of them. I did the installation by clicking on the installer in the Word for Word 7.2 window, and also tried by clicking on the installer in the WFW Installer folder. No luck in either. I wonder what's happening?
User avatar
Ronald P. Regensburg
Expert User
Posts: 6348
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: Installation program works under 7.6.1 and 8.6, not 9.0.

Post by Ronald P. Regensburg »

I cannot imagine why it does not work on your side. I simply double clicked the installer in the 'Word For Word 7.2' folder. I have that folder on one of the mounted image volumes. It works both there or when dragged from there to the desktop.

This is in SheepShaver for macOS. I expanded the stuffit archive on the host, then moved the folder to the shared folder and in SheepShaver copied the folder from the 'Unix' disk to the other mounted volume.
emendelson
Forum All-Star
Posts: 1230
Joined: Tue Oct 14, 2008 12:12 am

Re: Installation program works under 7.6.1 and 8.6, not 9.0.

Post by emendelson »

This is very puzzling. I created two completely new SheepShaver systems, one from an international 9.0.4 CD image, one from a US English 9.0.4 CD, and the first thing I did in both was copy the unStuffed Word for Word folder to the hard disk image and try to install. Both gave me the same message asking for the WFW Installer disk.

I'm completely baffled. Obviously it should work as it does on your system, but I've now tried four different systems, with the same result.

Let's leave it at this...
User avatar
Ronald P. Regensburg
Expert User
Posts: 6348
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: Installation program works under 7.6.1 and 8.6, not 9.0.

Post by Ronald P. Regensburg »

I normally use a Dutch Mac OS 9.0.4 setup. To make sure it is not something in the language version, I created a fresh new setup with an international English 9.0.4 Mac OS. Again, installation of Word For Word worked fine.

Puzzling indeed.
emendelson
Forum All-Star
Posts: 1230
Joined: Tue Oct 14, 2008 12:12 am

Re: Installation program works under 7.6.1 and 8.6, not 9.0.

Post by emendelson »

Even more puzzling. I was curious enough to drag out my old Pismo PowerBook G3, which boots to Tiger and 9.2.2. The same problem occurred in both.
User avatar
adespoton
Forum All-Star
Posts: 3079
Joined: Fri Nov 27, 2009 5:11 am
Location: Emaculation.com
Contact:

Re: Installation program works under 7.6.1 and 8.6, not 9.0.

Post by adespoton »

Maybe it's something about how it's being unstuffed?

Which archive tool are you using?
emendelson
Forum All-Star
Posts: 1230
Joined: Tue Oct 14, 2008 12:12 am

Re: Installation program works under 7.6.1 and 8.6, not 9.0.

Post by emendelson »

Your answer is obviously the right one - I found the CD drive for my Pismo and installed from the original CD with the Adobe File Utilities, and it worked perfectly.

I've been using BetterZip on the macOS side and I think StuffIt in SheepShaver. Will continue to experiment. Meanwhile, thank you for insisting that this works!
User avatar
Ronald P. Regensburg
Expert User
Posts: 6348
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: Installation program works under 7.6.1 and 8.6, not 9.0.

Post by Ronald P. Regensburg »

In OSX/macOS I use 'The Unarchiver' for unpacking archives of any format, including stuffit and zip. It supports some 40+ archive formats. It never failed me.
Post Reply