Can we turn off font smoothing?

About SheepShaver, a PPC Mac emulator for Windows, MacOS X, and Linux that can run System 7.5.3 to MacOS 9.0.4.

Moderators: Cat_7, Ronald P. Regensburg, ClockWise

Post Reply
Demogorgon93
Space Cadet
Posts: 5
Joined: Mon Mar 29, 2021 9:30 am

Can we turn off font smoothing?

Post by Demogorgon93 »

Hello. I worship SheepShaver. It’s my favorite piece of software, along with emacs and Virtual ][.

There is surely a nostalgia dimension to my love. It’s all about the crisp pixels and clearly jagged edges.

The previous version of SheepShaver rendered fonts (and all edges) without the ghostly halo of “smoothing.” Could you kindly add an option in Preferences to turn this off? Or is it there somewhere and I’m missing it?

I don’t mean the smoothing that’s going on inside the emulated Mac—the one accessed via Control Panel. I mean the smoothing applied by SheepShaver, which is clearly optional because I can see it applying and unapplying during (emulated) boot time.

Thank you for making and maintaining this vital project.
Last edited by Demogorgon93 on Tue Mar 30, 2021 7:46 am, edited 1 time in total.
<⟨ Thus spake Demogorgon ⟩>
User avatar
Ronald P. Regensburg
Expert User
Posts: 6722
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: Can we turn of font smoothing?

Post by Ronald P. Regensburg »

You do not tell which are your host machine and OS, and exactly which SheepShaver build (date!) you use.

Your problem is possibly caused by the anti-aliasing that will accompany the scaling on high resolution (Retina) screens.

Try adding these lines to the SheepShaver prefs file:

Code: Select all

scale_nearest true
scale_integer true
If these entries are already written to the prefs file with the default "false", change "false" to "true".

See also the "Advanced features" in the SheepShaver for macOS setup manual: https://www.emaculation.com/doku.php/sh ... uilds_only
Demogorgon93
Space Cadet
Posts: 5
Joined: Mon Mar 29, 2021 9:30 am

Re: Can we turn off font smoothing?

Post by Demogorgon93 »

Hello! Please excuse this delay.

Thanks for you quick reply. I am using MBP Retina 15-inch Mid 2015. And I just upgraded from Mojave to Catalina; mine is currently 10.15.7.

It was this upgrade that caused the problem—I noticed that the SheepShaverPrefs.app was slashed out. So I downloaded SheepShaver 2.5 (created date: 2021.03.17). I noticed that there was no accompanying SSPrefs.app. Is this the “prefs file" you refer to above? If so, mine is slashed out and useless.

There is a SheepShaver.plist inside ~/Library/Preferences/. Is that the one you mean? I doubt it—it is in dictionary/key format and does not contain the lines you mention. Where is the prefs file you mention? Do I need to download something else?

UPDATE: FOUND IT. I looked inside the AppleScript script. Will try your code now …
Last edited by Demogorgon93 on Tue Mar 30, 2021 8:04 am, edited 1 time in total.
<⟨ Thus spake Demogorgon ⟩>
Demogorgon93
Space Cadet
Posts: 5
Joined: Mon Mar 29, 2021 9:30 am

Re: Can we turn off font smoothing?

Post by Demogorgon93 »

OK. I found it and made the changes. I noticed that the attributes did not already exist (and set to false). I had to add them. The change made no difference.

Then I deleted the prefs file and re-opened the SS.app to build a new one.

Then I made the boot-essential (diek) additions and opened SS.app again. → Still no difference.

So I guess I’ll have to compile it myself with Xcode. Would you happen to know the compile options that will fix this? Or tell me where to look?
Last edited by Demogorgon93 on Tue Mar 30, 2021 8:49 am, edited 1 time in total.
<⟨ Thus spake Demogorgon ⟩>
User avatar
Ronald P. Regensburg
Expert User
Posts: 6722
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: Can we turn off font smoothing?

Post by Ronald P. Regensburg »

There is no font smoothing in SheepShaver.
The anti-aliasing issue on Retina screens was addressed by adding the scaling algorithm options in the prefs file. One or both can be added, you can experiment for best result.

I am not sure what you did and which file you edited.

When you use Preferences in SheepShaver (the built-in preferences editor), settings are written to the hidden file ".sheepshaver_prefs" in your Home folder. Advanced settings are written by SheepShaver Preferences with default values. They cannot be edited in SheepShaver Preferences, so they must be edited manually using a text editor:

Make sure SheepShaver is not running.
Launch Terminal (in /Application/Utilities/) and type at the prompt

Code: Select all

open ~/.sheepshaver_prefs
followed by a return.
The file will open in your default text editor.

Look for the lines mentioned above. If they are set to "false", change "false" to "true". When changes were saved in Preferences, and if the lines were not there already, the lines will have been added with the default "false".
If they do not exist yet, add the lines. Then Close and Save.

Edit: I cannot check it on my non-Retina screen, but the difference should be obvious on Retina screens. If it does not work, something else may be broken.
Demogorgon93
Space Cadet
Posts: 5
Joined: Mon Mar 29, 2021 9:30 am

Re: Can we turn off font smoothing?

Post by Demogorgon93 »

Hello again!

Well, as I explained in the post prior to your last post, I added the following to ~/.sheepshaver_prefs:

scale_nearest true
scale_integer true

… and nothing changed.
Edit: I cannot check it on my non-Retina screen, but the difference should be obvious on Retina screens. If it does not work, something else may be broken.
Yet the smoothing DOES turn off under certain unhelpful conditions. For example, if I invoke SheepShaver > Preferences… and then move the main emulator window, smoothing turns off! The lines are much thinner, and exactly crisp.

Only an ultra-master will be able to say which makefile options or compiling flags I need to use to avoid this smoothing.
<⟨ Thus spake Demogorgon ⟩>
User avatar
Ronald P. Regensburg
Expert User
Posts: 6722
Joined: Thu Feb 09, 2006 10:24 pm
Location: Amsterdam, Netherlands

Re: Can we turn off font smoothing?

Post by Ronald P. Regensburg »

Weird.
For example, if I invoke SheepShaver > Preferences… and then move the main emulator window, smoothing turns off! The lines are much thinner, and exactly crisp.
Not sure what you mean with "invoke". Exactly what do you do? Open the Prefs window and close it or open the Prefs window and leave it open and move the SheepShaver window while Prefs is open?

What happens when you click "Save and Shut down" in Preferences, then shut down SheepShaver, and start SheepShaver again? Is the anti-aliasing gone? Or do you again need to do all this to make it go away?
emendelson
Forum All-Star
Posts: 1269
Joined: Tue Oct 14, 2008 12:12 am

Re: Can we turn off font smoothing?

Post by emendelson »

Cmd-click SheepShaver; choose Get Info; make sure that "Open in low resolution" is NOT checked. If it IS checked, experiment with the check both on and off.
Demogorgon93
Space Cadet
Posts: 5
Joined: Mon Mar 29, 2021 9:30 am

Re: Can we turn off font smoothing?

Post by Demogorgon93 »

Ronald P. Regensburg wrote: Sat Apr 03, 2021 10:51 am Weird.
For example, if I invoke SheepShaver > Preferences… and then move the main emulator window, smoothing turns off! The lines are much thinner, and exactly crisp.
Not sure what you mean with "invoke". Exactly what do you do? Open the Prefs window and close it or open the Prefs window and leave it open and move the SheepShaver window while Prefs is open?
It just means that I bring up the Preferences dialog. Once it is open, if I move the underlying window at all, smoothing disappears. But it then reappears when I close the Preferences window.
What happens when you click "Save and Shut down" in Preferences, then shut down SheepShaver, and start SheepShaver again? Is the anti-aliasing gone? Or do you again need to do all this to make it go away?
Smoothing is always on. But the advice in the following reply fixed it for me.
<⟨ Thus spake Demogorgon ⟩>
Demogorgon93
Space Cadet
Posts: 5
Joined: Mon Mar 29, 2021 9:30 am

Re: Can we turn off font smoothing?

Post by Demogorgon93 »

emendelson wrote: Sat Apr 03, 2021 1:58 pm Cmd-click SheepShaver; choose Get Info; make sure that "Open in low resolution" is NOT checked. If it IS checked, experiment with the check both on and off.
This worked! Thanks.
<⟨ Thus spake Demogorgon ⟩>
Post Reply