SheepShaver on Raspberry Pi is ... yellow

About SheepShaver, a PPC Mac emulator for Windows, MacOS X, and Linux that can run System 7.5.3 to MacOS 9.0.4.

Moderators: Cat_7, Ronald P. Regensburg, ClockWise

Post Reply
foobarney
Space Cadet
Posts: 2
Joined: Tue Apr 13, 2021 7:28 pm

SheepShaver on Raspberry Pi is ... yellow

Post by foobarney »

This is weird.

I just built SheepShaver on a Raspberry Pi 3b+ using vanilla, just-installed RasPi OS. Built and runs without much issue except that it's ... yellow. The whole screen has a yellowish-green tinge from bootup. (I'd share a screen shot but I don't think I can).

I know it's not the boot image, because it's yellow even if you boot without any volumes--just a sad, yellow, flashy floppy disk.

I've searched but was shocked that I couldn't find this happening before. Did I just miss something obvious?
User avatar
adespoton
Forum All-Star
Posts: 3426
Joined: Fri Nov 27, 2009 5:11 am
Location: Emaculation.com
Contact:

Re: SheepShaver on Raspberry Pi is ... yellow

Post by adespoton »

This sounds like you're doing an SDL 1.2 build. Specific versions of SDL 1.2 have this bug.

What happens if you build the SDL2 version?
foobarney
Space Cadet
Posts: 2
Joined: Tue Apr 13, 2021 7:28 pm

Re: SheepShaver on Raspberry Pi is ... yellow

Post by foobarney »

Sounds like a solution, but I'm not entirely sure how to do that. Install 2.0 runtime binaries and rebuild? Is there a separate config flag?

Thanks!
User avatar
adespoton
Forum All-Star
Posts: 3426
Joined: Fri Nov 27, 2009 5:11 am
Location: Emaculation.com
Contact:

Re: SheepShaver on Raspberry Pi is ... yellow

Post by adespoton »

Yeah; there's a seperate config flag; I can't remember what it is for Raspbian. But you have to set the target to SDL2 instead of X11 or SDL.
Post Reply