No sound on Ubuntu (and SheepShaver is behaving strangely)

About SheepShaver, a PPC Mac emulator for Windows, MacOS X, and Linux that can run System 7.5.3 to MacOS 9.0.4.

Moderators: Cat_7, Ronald P. Regensburg, ClockWise

Post Reply
Space Cadet
Posts: 1
Joined: Thu Apr 29, 2021 10:29 am

No sound on Ubuntu (and SheepShaver is behaving strangely)

Post by Kiwi-NFL-Fan »

I compiled SheepShaver from source for Ubuntu 20.04. It works, but there is no sound. I tried using the --mixer flag but I'm not sure what is supposed to go in there. I tried inputting the path to each of the devices in /dev/snd, but no luck.

What's even more strange is that running SheepShaver does not boot the GUI where you can configure SheepShaver (add volumes, specifiy options etc). Instead, it boots the virtual machine straight away (provided that the ROM file is in the same directory and is named simply 'ROM'). I copied the ROM file and virtual drive from my Windows installation (where the sound worked) and got it to go that way, but this would not have been possible if I had not installed on Windows first.

I'm quite confused. How can I fix this issue?
Post Reply