Official PearPC v0.3.1 released! [updated]

About PearPC, a PPC Mac emulator for Windows and Linux that can run MacOS X up to 10.4.

Moderators: Cat_7, Ronald P. Regensburg

Jon Davis
Inquisitive Elf
Posts: 39
Joined: Thu Jun 27, 2002 1:38 pm

Official PearPC v0.3.1 released! [updated]

Post by Jon Davis »

http://pearpc.sourceforge.net/

Works well!


PearPC ChangeLog
==================

version 0.3.1 (released 5. September 2004):
- JITC_X86: increased translation cache size
- (Win32) fixed: '`'/'~' key wasn't mapped
- (SDL) fixed: right-alt was mapped to left-alt
- fixed: German '<>|' key wasn't mapped
- JITC_X86: corrected tw/twi instructions (should fix java native IO calls fail)
- fixed: rfi instruction (should also fix java native IO calls fail)
- fixed: some mysterious partition mappings in src/io/prom/fs/hfsplus/partition.c
- (BEOS) updated
- disabled unused keyboard shortcuts

version 0.3 (released 13. August 2004):
- clean up everything on exit
- (experimental) idle sleep for the JITC CPU
- asynchronous keyboard and mouse events
- implemented IDE Flush
- Win32: implemented fullscreen mode proposed by Matt Jobson
- short cut keys are configurable
- correct clock/timing (Win32 + Posix) by Keith Rothman, Kimball Thurston and Stefan Weyergraf
- SDL support
- SDL: implemented fullscreen mode
- source tree reorganisation
- display functions moved to src/system/ui directory
- src/system/arch created
- system/posix,win32 and beos moved to system/osapi/
- host keyboard support separated from SystemDisplay
- host mouse support separated from SystemDisplay
- architecture-specific video acceleration functions (x86)
- configure-system: choose "jitc_x86" on x86s when no --enable-cpu given
- JITC: srawix, subfcx, divwx, divuwx,
mulhwx, mulwx, subfex, extshx implemented
- JITC: align entrypoints
[added by kybernaut]
robojam
Forum All-Star
Posts: 780
Joined: Thu Apr 17, 2003 10:52 pm
Location: Charlotte, NC. USA

Post by robojam »

Anyone for 0.4 pre then? :lol:
Once you've made something idiot proof, they go and invent a better idiot!
User avatar
Yukon Kid
Mac Mechanic
Posts: 169
Joined: Thu May 20, 2004 6:27 pm

Post by Yukon Kid »

still can't network with it.
robojam
Forum All-Star
Posts: 780
Joined: Thu Apr 17, 2003 10:52 pm
Location: Charlotte, NC. USA

Post by robojam »

I think the networking support is still pretty flaky, as there is no real pattern to who can get it working and who can't.

I'll try again with mine, but I haven't had any success so far, either using the methods suggested in the forum or by experimenting.
Once you've made something idiot proof, they go and invent a better idiot!
CaptainValor
Forum All-Star
Posts: 587
Joined: Mon May 17, 2004 11:57 pm
Contact:

Post by CaptainValor »

Tried out the 0.3 official this morning. Networking works fine, as does Full Screen and resolution changing. Just like the 0.3pre. Although I still get the "sticky Shift key" problem when changing back and forth from Full Screen mode. :?

Can't wait for 0.4pre. :)
robojam
Forum All-Star
Posts: 780
Joined: Thu Apr 17, 2003 10:52 pm
Location: Charlotte, NC. USA

Post by robojam »

For the first time I have networking up and running! I'm not sure what the difference between this and the other builds is, but I will stick with this for now as I can access the Internet!
Once you've made something idiot proof, they go and invent a better idiot!
User avatar
asapreta
Tinkerer
Posts: 83
Joined: Mon May 31, 2004 5:01 pm
Location: São Paulo - Brazil
Contact:

Post by asapreta »

My networking didn´ work.
Xanthracus
Inquisitive Elf
Posts: 38
Joined: Mon May 17, 2004 9:09 am
Location: Romania
Contact:

Post by Xanthracus »

It works slowly than 0.3 Pre nightly branch of Richar Goodwin, but I have a full screen at 1152 x 864.
Show keyboard layout not works.
The mouse hangs out.
Maybe my specs are too weak for it.

----------------------

My specs: P III 750 on mainboard based on the chipset Intel 440 BX/ZX, 416 M RAM; Maxtor 6L040J2 and Maxtor 6Y060L0.
User avatar
asapreta
Tinkerer
Posts: 83
Joined: Mon May 31, 2004 5:01 pm
Location: São Paulo - Brazil
Contact:

Post by asapreta »

With the same Panther Image I can run networking perfecly with any of Cybermagelan´s releases (p4, p4 sdl and altivec).
User avatar
PPC_Digger
Forum All-Star
Posts: 1053
Joined: Thu Jul 22, 2004 9:02 am
Location: Israel

Post by PPC_Digger »

networking works for me (0.3pre, haven't did 0.3 official yet)
User avatar
asapreta
Tinkerer
Posts: 83
Joined: Mon May 31, 2004 5:01 pm
Location: São Paulo - Brazil
Contact:

Post by asapreta »

My networking works fine on 0.3 pre too. Official isn't working.
starfall
Student Driver
Posts: 10
Joined: Thu Jun 17, 2004 1:13 am

Post by starfall »

Any major speed improvement in 0.3 official?
dilacerated
Tinkerer
Posts: 47
Joined: Sat Jun 05, 2004 9:28 pm
Location: Portland, OR

Post by dilacerated »

networking works for myself with the final :)

nice improvement from 0.2.0 final --> i love the performance step up. now it feels usable at speed with xyz Applications that have their ups and downs with the Altivec builds. still can't wait to see the Velocity engine running solidly. one thing that strikes as odd is that when loading at 1024x786@100 while not using the Full Screen function effects like the Genie transitions, menu access, mouse tracking etc are smooth whereas with it in 1024x786@100 Full Screen there's a lot of pausing/skipping.

anyhow for three months time to get this far i must say cheers to Sebastian and all involved!
User avatar
asapreta
Tinkerer
Posts: 83
Joined: Mon May 31, 2004 5:01 pm
Location: São Paulo - Brazil
Contact:

Post by asapreta »

What Network Card are u using in PearPC?
My Realtek works fine on 0.3 pre but not in final one.
dilacerated
Tinkerer
Posts: 47
Joined: Sat Jun 05, 2004 9:28 pm
Location: Portland, OR

Post by dilacerated »

asapreta wrote:What Network Card are u using in PearPC?
My Realtek works fine on 0.3 pre but not in final one.
i'm using the Realtek. one thing i noticed with some 0.3pre releases was that the network ceased to work after updating the ppc.exe file. fixing such, oddly enough, at times worked by installing the Kext package for easy install.
ali
Student Driver
Posts: 24
Joined: Sun Feb 29, 2004 8:00 am

Post by ali »

version 0.3.1 (not yet released):
- (Win32) fixed: '`'/'~' key wasn't mapped
- (SDL) fixed: right-alt was mapped to left-alt
- fixed: German '<>|' key wasn't mapped
- JITC_X86: corrected tw/twi instructions (should fix java native IO calls fail)
- (BEOS) updated
from:
http://www.richardgoodwin.com/pearpc/trunk_ChangeLog
:P
Updated:
Im running PearPC Athlon XP otimized build and its version is 0.4pre?!!
CaptainValor
Forum All-Star
Posts: 587
Joined: Mon May 17, 2004 11:57 pm
Contact:

Post by CaptainValor »

Excellent, they finally fixed the right-alt mapping mistake in the SDL version. I will get this new 0.3.1 version right away. :)
prasys
Forum All-Star
Posts: 549
Joined: Sun May 23, 2004 7:41 am
Location: MY
Contact:

Post by prasys »

0.4pre is out

I'm gonna test it....Well , there is nothing much in the changelog
robojam
Forum All-Star
Posts: 780
Joined: Thu Apr 17, 2003 10:52 pm
Location: Charlotte, NC. USA

Post by robojam »

prasys wrote:Well , there is nothing much in the changelog
Give them a chance! :wink:
Once you've made something idiot proof, they go and invent a better idiot!
CaptainValor
Forum All-Star
Posts: 587
Joined: Mon May 17, 2004 11:57 pm
Contact:

Post by CaptainValor »

Yeah remember when 0.3pre first came out? It wasn't much different from 0.2. But it evolved over time. ;)
robojam
Forum All-Star
Posts: 780
Joined: Thu Apr 17, 2003 10:52 pm
Location: Charlotte, NC. USA

Post by robojam »

The next question is going to be "When is version 1.0 coming out?"...
Once you've made something idiot proof, they go and invent a better idiot!
Minsky
Inquisitive Elf
Posts: 29
Joined: Sat Jun 19, 2004 12:42 pm

Post by Minsky »

robojam wrote:The next question is going to be "When is version 1.0 coming out?"...
I know! I know! When Pear will emulate PPC at 1:1 speed! Gimme a cookie!
CaptainValor
Forum All-Star
Posts: 587
Joined: Mon May 17, 2004 11:57 pm
Contact:

Post by CaptainValor »

I think PearPC is still missing some major inclusions before it can be released as a 1.0. Namely sound, faster graphics, and a built-in GUI for creating config files and controlling the emulator (like VMware or BSKII). Give them time to build up to a great product. :)
Xanthracus
Inquisitive Elf
Posts: 38
Joined: Mon May 17, 2004 9:09 am
Location: Romania
Contact:

Congrats

Post by Xanthracus »

ali wrote:
version 0.3.1 (not yet released):
- (Win32) fixed: '`'/'~' key wasn't mapped
- (SDL) fixed: right-alt was mapped to left-alt
- fixed: German '<>|' key wasn't mapped
- JITC_X86: corrected tw/twi instructions (should fix java native IO calls fail)
- (BEOS) updated
from:
http://www.richardgoodwin.com/pearpc/trunk_ChangeLog
:P
Updated:
Im running PearPC Athlon XP otimized build and its version is 0.4pre?!!
I ran yesterday the 0.4 pre trunk Altivec (experimental) from Richard Goodwin and...
The '`'/'~' key was correctly mapped
The Right Alt was mapped as "Option"
The progs that not running in earlier Altivec implemented versions run now (Including Word 2004 Drive Test and all system preferences)
The system runs smoothest

- I don't know anything about the network possibilities, because I'm under a firewall (provider's) and I didn't succeed anything with networkin, with any tested version (including versions thats other of you are succeeded).

I'm verry happy,

Congratulations Richard Goodwin
Last edited by Xanthracus on Wed Aug 25, 2004 8:08 am, edited 1 time in total.
ali
Student Driver
Posts: 24
Joined: Sun Feb 29, 2004 8:00 am

Post by ali »

PearPC 0.3.1 Changlelog updated again!
- disabled unused keyboard shortcuts
form:
http://cvs.sourceforge.net/viewcvs.py/p ... iew=markup
Post Reply